Topik ini menjelaskan penyebab kesalahan AccessDenied saat menggunakan JindoSDK untuk mengakses Object Storage Service (OSS) dan cara memperbaiki kesalahan tersebut.
Masalah
Tes konektivitas gagal, operasi: getFileStatus, errMsg: [RequestId]: 635B6DDE9A1F093434AC6A7C [HostId]: oss-cn-beijing-internal.aliyuncs.com [ErrorMessage]: [E1010]HTTP/1.1 403 Forbidden: <?xml version="1.0" encoding="UTF-8"?><Error> <Code>AccessDenied</Code> <Message>Bucket yang Anda akses tidak milik Anda.</Message> <RequestId>635B6DDE9A1F093434AC6A7C</RequestId> <HostId>xxx.oss-cn-beijing-internal.aliyuncs.com</HostId></Error> [ErrorCode]: 1010 [RequestId]: 635B6DDE9A1F093434AC6A7C
Penyebab
Pengguna RAM tidak memiliki izin yang diperlukan untuk mengakses OSS.
Solusi
Berikan izin yang diperlukan kepada pengguna RAM. Untuk informasi lebih lanjut, lihat Gunakan RAM untuk mengelola izin OSS.
- Gunakan JindoSDK untuk membaca dan menulis data ke OSS
# Tindakan terkait bucket oss:ListObjects oss:GetBucketInfo # Tindakan terkait objek oss:PutObject oss:GetObject oss:DeleteObject oss:AbortMultipartUpload oss:ListParts oss:RestoreObject oss:PutObjectTagging oss:GetObjectTagging oss:DeleteObjectTagging # Tindakan terkait versi oss:ListObjectVersions oss:GetObjectVersion oss:DeleteObjectVersion oss:RestoreObjectVersion oss:PutObjectVersionTagging oss:GetObjectVersionTagging oss:DeleteObjectVersionTagging - Gunakan JindoSDK untuk membaca data dari OSS
# Tindakan terkait bucket oss:ListObjects oss:GetBucketInfo # Tindakan terkait objek oss:GetObject oss:ListParts oss:RestoreObject oss:GetObjectTagging # Tindakan terkait versi oss:ListObjectVersions oss:GetObjectVersion oss:RestoreObjectVersion oss:GetObjectVersionTagging