Saat mengubah aplikasi di kluster Elastic Compute Service (ECS) menggunakan konsol Enterprise Distributed Application Service (EDAS), catatan perubahan akan dibuat. Topik ini menjelaskan pesan kesalahan dan kode kesalahan yang mungkin dikembalikan selama proses perubahan.
EDAS-10000
- Error message
EDAS-10000 NO_SPACE_LEFT_ON_DISK
- Possible cause
Ruang disk telah habis.
- Solution
Masuk ke Instance ECS dan hapus log.
EDAS-10001
- Error message
EDAS-10001 STAR_AGENT_OFFLINE
- Possible cause
StarAgent sedang offline.
- Solution
Masuk ke Instance ECS dan jalankan perintah
sh /home/staragent/bin/staragentctl restartuntuk memulai ulang agen.
EDAS-10002
- Error message
EDAS-10002 Task timeout when running
- Possible cause
Eksekusi tugas waktu habis.
EDAS-10012
- Error message
EDAS-10012 UNZIP_WAR_FAILED
- Possible cause
Gagal membongkar paket WAR menggunakan perintah unzip.
- Solution
Periksa apakah paket WAR Anda dapat dibongkar dengan sukses.
EDAS-10013
- Error message
EDAS-10013 JAR_WAR_FAILED
- Possible cause
Paket WAR gagal dibongkar menggunakan perintah JAR. Java Development Kit (JDK) terpasang secara salah atau versi JDK dalam sistem operasi tidak mencakup perintah JAR.
- Solution
Masuk ke Instance ECS sebagai pengguna root. Jalankan perintah
yum install -y java-1.8.0-openjdk-develatauyum install -y java-1.7.0-openjdk-develberdasarkan versi JDK yang ada. Pastikan bahwa Instance ECS dapat diakses dari Internet saat menjalankan perintah tersebut.
EDAS-10014
- Error message
EDAS-10014 WAR_URL_403
- Possible cause
Paket WAR gagal diunduh karena Anda tidak memiliki otoritas untuk mengakses paket WAR.
EDAS-10015
- Error message
EDAS-10015 WAR_URL_404
- Possible cause
Paket WAR gagal diunduh karena paket WAR tidak ditemukan.
EDAS-10016
- Error message
EDAS-10016 JAVA_PROCESS_ROOT
- Possible cause
Aplikasi gagal dihentikan karena proses aplikasi dimulai dengan izin root. EDAS tidak memiliki izin untuk mengelola aplikasi.
- Solution
Hentikan proses aplikasi sebagai pengguna root dan coba lagi.
EDAS-10017
- Error message
EDAS-10017 HOME_ADMIN_FILE_ROOT
- Possible cause
Aplikasi gagal dimulai karena direktori tomcat atau direktori aplikasi berisi file atau direktori yang memerlukan izin root.
- Solution
Periksa apakah direktori
/home/admin/appatau/home/admin/${tomcat-path}berisi file atau direktori yang memerlukan izin root. Jika file atau direktori seperti itu ada, pulihkan izin file atau direktori tersebut ke admin secara manual dan coba lagi.
EDAS-10020
- Error message
EDAS-10020 SLB_NOT_ENOUGH_BALANCE
- Possible cause
Instance Server Load Balancer (SLB) gagal diikat karena saldo akun Anda tidak mencukupi.
- Solution
Pastikan saldo akun Anda minimal USD 10 untuk membeli instance SLB.
EDAS-10021
- Error message
EDAS-10021 SLB_BIND_ALREADY_HAVE_SERVICE
- Possible cause
Instance SLB gagal diikat ke aplikasi karena aplikasi telah diikat ke instance SLB lainnya.
- Solution
Lepaskan instance SLB yang ada dari aplikasi di konsol EDAS. Kemudian, ikat instance SLB yang diperlukan ke aplikasi.
EDAS-10022
- Error message
EDAS-10022 K8s_READINESS_ERROR
- Possible cause
Aplikasi gagal dimulai karena pemeriksaan readiness gagal dalam periode yang ditentukan.
- Solution
Periksa apakah konfigurasi terkait valid.
EDAS-10023
- Error message
EDAS-10023 K8s_BACKOFF_RESTART
- Possible cause
Aplikasi gagal dimulai.
- Solution
Periksa apakah gambar valid.
EDAS-10024
- Error message
EDAS-10024 K8s_LIVENESS_ERROR
- Possible cause
Aplikasi gagal dimulai karena pemeriksaan liveness gagal dalam periode yang ditentukan.
- Solution
Periksa apakah konfigurasi terkait valid.
EDAS-10025
- Error message
EDAS-10025 PORT_CHECK_TIMEOUT
- Possible cause
Pemeriksaan port waktu habis selama startup aplikasi. Periode waktu habis adalah 5 menit. Port tidak diaktifkan dalam 5 menit.
- Solution
- Di halaman Aplikasi, temukan aplikasi yang diterapkan di kluster ECS, dan klik nama aplikasi. Di tab Informasi Dasar, periksa nilai Application Port di bagian Application Settings.

- Masuk ke Instance ECS dan jalankan salah satu perintah berikut untuk memeriksa apakah port diaktifkan:
- Metode 1:
netstat -lnp | grep nomor port - Metode 2:
ss -lnp | grep nomor port
- Metode 1:
- Jika port tidak diaktifkan, periksa apakah ada kesalahan yang dilaporkan dalam log startup proses aplikasi dan tangani kesalahan tersebut sesuai.
- Di halaman Aplikasi, temukan aplikasi yang diterapkan di kluster ECS, dan klik nama aplikasi. Di tab Informasi Dasar, periksa nilai Application Port di bagian Application Settings.
EDAS-10026
- Error message
EDAS-10026 URL_CHECK_TIMEOUT
- Possible cause
Pemeriksaan kesehatan URL diaktifkan untuk aplikasi, tetapi pemeriksaan akses URL waktu habis selama startup aplikasi. Periode waktu habis adalah 30 menit. Pemeriksaan kesehatan URL berhasil hanya jika kode status HTTP 200 dikembalikan setelah Anda menjalankan perintah
curl $URL. - Solution
Masuk ke Instance ECS dan jalankan
curl -v $URLuntuk memeriksa apakah URL yang dikonfigurasikan untuk aplikasi dapat diakses. Jika URL tidak dapat diakses, lihat log aplikasi dan periksa apakah proses aplikasi gagal dimulai.
EDAS-10027
- Error message
EDAS-10027 STARAGENT_CMD_EXECUTE_TIMEOUT
- Possible cause
Eksekusi perintah waktu habis dalam proses rilis. Periode waktu habis adalah 60 detik. Kesalahan waktu habis terjadi jika perintah rilis tidak dieksekusi dalam 60 detik.
- Solution
- Coba lagi tugas yang gagal di konsol EDAS.
- Jika kesalahan masih berlanjut, bergabunglah dengan grup DingTalk (ID: 31723701) untuk mendapatkan dukungan teknis.
EDAS-10028
- Error message
EDAS-10028 PULL_WAR_TIMEOUT
- Possible cause
Saat menggunakan URL paket WAR atau JAR kustom untuk menerapkan aplikasi, kesalahan ini terjadi jika penarikan paket WAR atau JAR waktu habis. Periode waktu habis adalah 5 menit.
- Solution
Pastikan bahwa URL valid. Masuk ke Instance ECS dan jalankan perintah
wgetuntuk mengunduh paket kustom menggunakan URL dan periksa apakah unduhan dapat selesai dalam 5 menit.