Merestart Instans ECS.
Deskripsi operasi
Ini adalah operasi asinkron. Setelah instans direstart, instans memasuki status Starting. Anda dapat memanggil DescribeInstanceStatus untuk mengkueri status instans. Ketika status yang dikembalikan adalah Running, instans telah direstart.
Sebelum memulai
Anda tidak dapat merestart instans yang terkunci karena alasan keamanan. Untuk informasi selengkapnya, lihat Dampak kunci keamanan Sumber daya pada operasi API.
Anda hanya dapat merestart Instans ECS yang berada dalam status Running (
Running).
Coba sekarang
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
ecs:RebootInstance |
update |
*Instance.
|
None | None |
Parameter permintaan
|
Parameter |
Type |
Required |
Description |
Example |
| InstanceId |
string |
Yes |
ID instans. |
i-bp67acfmxazb4ph**** |
| ForceStop |
boolean |
No |
Apakah akan menghentikan Instans ECS secara paksa sebelum merestartnya. Nilai valid:
Nilai default: false. |
false |
| DryRun |
boolean |
No |
Apakah akan menjalankan dry run saja. Nilai valid:
Nilai default: false. |
false |
Elemen respons
|
Element |
Type |
Description |
Example |
|
object |
|||
| RequestId |
string |
ID permintaan. |
473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E |
Contoh
Respons sukses
JSONformat
{
"RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E"
}
Kode kesalahan
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 500 | InternalError | The request processing has failed due to some unknown error. | |
| 403 | IncorrectInstanceStatus | The current status of the resource does not support this operation. | |
| 403 | InstanceLockedForSecurity | The specified operation is denied as your instance is locked for security reasons. | Instans tempat disk tersambung terkunci karena alasan keamanan. |
| 403 | DiskError | IncorrectDiskStatus. | |
| 403 | InstanceExpiredOrInArrears | The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode). | |
| 403 | InvalidParameter.KMSKeyId.CMKUnauthorized | %s | |
| 403 | InvalidParameter.KMSKeyId.CMKNotEnabled | %s | |
| 403 | InvalidParameter.KMSKeyId.KMSUnauthorized | %s | |
| 403 | OperationDenied.KMSKeyUnauthorized | The operation is denied due to missing KMS key authorization. Please check the KMS key permissions and ensure the key is properly authorized for this operation. | |
| 404 | InvalidParameter.KMSKeyId.NotFound | The specified KMSKeyId does not exist. Please verify that the key ID is correct and that the key resides in the current region. | |
| 404 | InvalidInstanceId.NotFound | The specified InstanceId does not exist. | Instans yang ditentukan tidak ada. Periksa apakah ID instans sudah benar. |
| 503 | LimitedOperation.ServiceUnavailable | The service is currently unavailable. Please try again later. | Layanan saat ini tidak tersedia. Coba lagi nanti. |
Lihat Error Codes untuk daftar lengkap.
Catatan rilis
Lihat Release Notes untuk daftar lengkap.