Topik ini menjelaskan pengecualian yang terjadi saat menggunakan konsol Container Compute Service (ACS) untuk mengakses kluster, penyebabnya, serta solusi yang dapat diterapkan. Topik ini membantu menyelesaikan pengecualian berikut: permintaan server API gagal saat mengakses sumber daya kluster, permintaan server API gagal saat mengakses log pod, akun tidak memiliki izin kontrol akses berbasis peran (RBAC) yang diperlukan, dan akun tidak memiliki izin Resource Access Management (RAM) yang diperlukan.
Pengecualian permintaan server API terjadi saat Anda mengakses sumber daya kluster
Masalah
Saat menggunakan konsol ACS untuk mengakses sumber daya kluster, sistem mengembalikan pesan kesalahan berikut: "Terjadi kesalahan saat memproses permintaan Anda ke server API dari kluster saat ini." Kode kesalahannya adalah ErrorQueryClusterNamespace atau APIServer.500.
Penyebab
Konfigurasi load balancing server API tidak valid atau status server API tidak normal, sehingga bidang kontrol ACS gagal terhubung ke server API.
Solusi
Masuk ke konsol ACS. Di panel navigasi sebelah kiri, klik Clusters.
Di halaman Clusters, klik kluster yang ingin Anda kelola.
Di halaman detail kluster, klik tab Cluster Resources, lalu klik hyperlink di sebelah kanan API Server SLB untuk masuk ke konsol Server Load Balancer (SLB).
Jika sistem menampilkan pesan The specified SLB ID does not exist., instance SLB untuk server API telah dihapus atau dilepaskan. Anda tidak dapat memulihkan instance SLB. Untuk menyelesaikan masalah ini, buat ulang kluster. Untuk informasi lebih lanjut, lihat Buat kluster ACS.
Jika sistem tidak menampilkan pesan tersebut, lanjutkan ke langkah berikutnya.
Periksa apakah kolom Status instance SLB menampilkan Running.
Jika instance SLB tidak dalam keadaan Berjalan, instance SLB mungkin ditangguhkan atau dikunci. Instance SLB dengan pembayaran sesuai penggunaan ditangguhkan jika jatuh tempo, sedangkan instance SLB dengan langganan dikunci jika langganan kedaluwarsa. Lunasi pembayaran tertunda atau perpanjang langganan, lalu mulai ulang instance SLB. Untuk informasi lebih lanjut tentang pembayaran tertunda terkait instance SLB, lihat Pembayaran tertunda.
Jika instance SLB dalam keadaan Berjalan, lanjutkan ke langkah berikutnya.
Periksa apakah instance SLB memiliki listener dengan pengaturan Protokol/Pelabuhan Depan dan Protokol/Pelabuhan Belakang diatur ke TCP:6443, serta apakah kolom Status listener menampilkan Running.

Jika listener sebelumnya tidak ada, konfigurasi listener untuk server API telah dimodifikasi.
Jika listener sebelumnya ada tetapi dalam keadaan Stopped, pilih listener dan klik Start.
Jika listener sebelumnya tidak ada, ajukan tiket.
Jika listener sebelumnya ada dan berjalan secara normal, lanjutkan ke langkah berikutnya.
Periksa apakah kolom Health Check Status listener menampilkan Normal.
Jika status pemeriksaan kesehatan tidak Normal, server backend instance SLB untuk server API tidak normal. Ajukan tiket.
Jika status pemeriksaan kesehatan listener Normal, lanjutkan ke langkah berikutnya.
Periksa apakah kontrol akses diaktifkan untuk listener sebelumnya.
Jika kontrol akses diaktifkan untuk listener, ini menunjukkan bahwa daftar putih listener tidak dikonfigurasi dengan benar. Untuk menyelesaikan masalah ini, tambahkan blok CIDR
100.104.0.0/16ke daftar putih. Blok CIDR menentukan alamat IP sumber dari permintaan internal yang dikirim oleh bidang kontrol ACS ke server API. Untuk informasi lebih lanjut tentang kontrol akses, lihat Kontrol akses.Jika kontrol akses dinonaktifkan untuk listener, lanjutkan ke langkah berikutnya.
Jika pengecualian tidak disebabkan karena alasan sebelumnya, ajukan tiket.
Pengecualian permintaan server API terjadi saat Anda mengakses log pod
Jika pengecualian ini terjadi saat mengakses log pod tetapi Anda dapat mengakses sumber daya kluster lainnya secara normal, lakukan operasi berikut untuk memecahkan masalah:
Periksa apakah status pod adalah Running. Jika pod tidak dalam keadaan Berjalan, lihat Pemecahan masalah pod.
Periksa semua aturan grup keamanan untuk memastikan bahwa lalu lintas masuk yang ditujukan ke pelabuhan TCP 10250 dari VPC diizinkan. Jika lalu lintas masuk ditolak, tambahkan aturan grup keamanan untuk mengizinkan lalu lintas masuk. Untuk informasi lebih lanjut, lihat Tambahkan aturan grup keamanan.
Jika pengecualian tidak disebabkan karena alasan sebelumnya, ajukan tiket.
Akun saat ini tidak memiliki izin RBAC yang diperlukan untuk melakukan operasi
Masalah
Saat mengakses konsol ACS, sistem mengembalikan pesan kesalahan berikut: "Akun saat ini tidak memiliki izin RBAC yang diperlukan untuk melakukan operasi". Kode kesalahannya adalah ForbiddenQueryClusterNamespace atau APISERVER.403.
Penyebab
Akun yang digunakan tidak memiliki izin RBAC yang diperlukan untuk melakukan operasi.
Solusi
Gunakan akun Alibaba Cloud atau akun dengan izin administrator untuk masuk ke konsol ACS. Di panel navigasi sebelah kiri, klik Authorizations.
Di tab RAM Users, temukan pengguna Resource Access Management (RAM) yang menyebabkan kesalahan dan klik Modify Permissions untuk pengguna RAM tersebut.
Di halaman Permission Management, klik Add Permissions, pilih kluster, namespace, dan peran RBAC yang telah ditentukan sebelumnya, lalu klik Submit.
Akun saat ini tidak memiliki izin RAM yang diperlukan untuk melakukan operasi
Masalah
Saat mengakses konsol ACS, sistem mengembalikan pesan kesalahan berikut: "Akun saat ini tidak memiliki izin RAM yang diperlukan untuk melakukan operasi". Kode kesalahannya adalah StatusForbidden.
Penyebab
Akun yang digunakan tidak memiliki izin RAM yang diperlukan untuk melakukan operasi.
Solusi
Gunakan akun Alibaba Cloud atau akun dengan izin RAM untuk masuk ke konsol RAM.
Berikan akun Anda izin yang diperlukan berdasarkan informasi CS yang dikembalikan oleh sistem, seperti cs:DescribeKubernetesVersionMetadata. Untuk informasi lebih lanjut, lihat Buat kebijakan RAM kustom.