Tous les produits
Search
Centre de documentation

Data Management:Créer un espace de travail et ajouter des ressources

Dernière mise à jour :Aug 28, 2026

Cette rubrique explique comment créer un espace de travail Notebook, ajouter des ressources et configurer un espace de stockage de code.

Étape 1 : Créer et accéder à un espace de travail

  1. Connectez-vous à DMS 5.0.

  2. Placez le pointeur sur l'icône 2023-01-28_15-57-17.png dans le coin supérieur gauche, puis choisissez All Features > Data+AI > Notebook.

    Remarque

    Si vous utilisez la console DMS en mode normal, choisissez Data+AI > Notebook dans la barre de navigation supérieure.

  3. Cliquez sur Create Workspace. Dans la boîte de dialogue qui s'affiche, saisissez un Workspace Name, sélectionnez une Region, puis cliquez sur OK.

    Remarque
    • Un nom d'espace de travail ne peut contenir que des lettres, des chiffres et des traits de soulignement (_).

    • Vous ne pouvez sélectionner que la région Singapour.

  4. Dans la colonne Actions de l'espace de travail cible, cliquez sur Go to Workspace.

    Remarque

    Par défaut, seul le créateur d'un espace de travail peut y accéder. Pour un développement collaboratif, le créateur de l'espace de travail doit accorder des autorisations de développement aux autres utilisateurs.

Étape 2 : Ajouter des membres au projet

Si plusieurs utilisateurs collaborent au sein d'un espace de travail, vous devez leur attribuer des rôles.

Les utilisateurs doivent être ajoutés à DMS avant que vous puissiez leur attribuer des rôles. Pour plus d'informations, consultez la section Gestion des utilisateurs.

Cliquez sur l'icône des paramètres en bas du volet de navigation de gauche et choisissez Member Management. Ensuite, cliquez sur Add Members. Dans la boîte de dialogue qui s'affiche, sélectionnez les membres à ajouter et attribuez-leur des rôles. Les rôles disponibles incluent Administrator, Developer et Read-only User.

Étape 3 : Configurer l'espace de stockage de code

  1. Dans l'espace de travail, accédez à l'onglet Project Settings image et cliquez sur Storage Management.

  2. Sur la page Storage Management, cliquez sur l'icône image située à droite de Code Space.

  3. Dans la boîte de dialogue Select OSS Directory, sélectionnez le Bucket cible.

    Le bucket sélectionné doit se trouver dans la même région que l'espace de travail actuel et sa classe de stockage doit être Standard.

    Remarque

    Si aucun bucket n'est disponible dans la région actuelle, accédez à la console Object Storage Service (OSS) pour en créer un. Pour plus d'informations, consultez la section Créer des buckets.

  4. Cliquez sur OK.

Étape 4 : Ajouter des ressources

Pour interroger et analyser des données avec Notebook, vous devez d'abord ajouter et démarrer une ressource.

  1. Dans l'espace de travail, accédez à l'onglet Project Settings image et cliquez sur Resource Configuration.

  2. Cliquez sur Add Resource et configurez les informations de la ressource.

    Paramètre

    Description

    Resource name

    Saisissez un nom descriptif.

    Resource description

    Décrivez l'objectif de cette ressource.

    Image

    • Spark 3.5+Python 3.9

    • Spark 3.3+Python 3.9

    • Python 3.9

    ADB instance

    Sélectionnez une instance AnalyticDB for MySQL.

    Remarque
    • Si vous sélectionnez une image avec Spark 3.3 ou 3,5, vous devez également sélectionner un cluster AnalyticDB for MySQL.

    • Si le cluster cible est introuvable, vérifiez s'il a été enregistré dans DMS. Pour plus d'informations, consultez la section Enregistrer une instance de base de données cloud.

    ADB resource group

    Sélectionnez un groupe de ressources.

    Executor spec

    Les spécifications de ressources pour l'exécuteur Spark. Différents modèles ont des spécifications différentes. Pour plus d'informations, consultez la colonne Model dans Paramètres de configuration de l'application Spark.

    Executor count

    Le nombre d'exécuteurs Spark.

    Remarque

    Pendant l'aperçu public de Notebook, le nombre total d'exécuteurs pour toutes les ressources d'un espace de travail ne peut pas dépasser six. Pour augmenter la limite d'exécuteurs, contactez le support technique DMS.

    Driver spec

    Les spécifications de ressources pour le pilote Spark.

    • General_XSmall_v1 (2 vCores, 8 Go)

    • General_Small_v1 (4 vCores, 16 Go)

    • General_Medium_v1 (8 vCores, 32 Go)

    • General_Large_v1 (16 vCores, 64 Go)

    Notebook specification

    Ce paramètre est disponible uniquement lorsque vous sélectionnez une image avec Python 3.9.

    • General_XSmall_v1 (2 vCores, 8 Go)

    • General_Small_v1 (4 vCores, 16 Go)

    • General_Medium_v1 (8 vCores, 32 Go)

    • General_Large_v1 (16 vCores, 64 Go)

    VPC ID

    Sélectionnez un Virtual Private Cloud (VPC) disponible.

    Zone ID

    Sélectionnez une zone dans le VPC.

    vSwitch ID

    Sélectionnez un vSwitch dans le VPC.

    Security group ID

    Sélectionnez un groupe de sécurité disponible.

  3. Cliquez sur Save.

  4. Démarrez la ressource.

    Dans la colonne Actions de la ressource, cliquez sur Start, puis cliquez sur OK.

    Remarque

    Le démarrage de la ressource prend environ une minute. Une fois la ressource démarrée, le Resource Status passe à Running.

Étape 5 : Configurer un espace de stockage utilisateur

Pour lire des données provenant de sources externes avec Notebook, vous pouvez configurer des chemins d'accès vers plusieurs buckets OSS.

  1. Dans l'espace de travail, accédez à l'onglet Settings image et cliquez sur Storage Management.

  2. Dans la zone Espace de stockage utilisateur, configurez le chemin OSS.

    Remarque

    Le chemin de montage doit commencer par /mnt/.

  3. Cliquez sur l'icône Enregistrer image.

Étape 6 : Afficher les données

  1. Dans l'espace de travail, accédez à l'onglet Data image.

  2. Dans la console SQL, vous pouvez effectuer les opérations suivantes :

    • Interroger les données

      Vous pouvez utiliser Copilot pour générer des requêtes SQL ou les écrire manuellement. La syntaxe SQL doit être cohérente avec celle de l'entrepôt de données logique .

      Remarque

      Vous pouvez utiliser la syntaxe MySQL standard pour interroger des tables, quelle que soit leur base de données source, telle qu'AnalyticDB for MySQL ou RDS for MySQL. DMS gère automatiquement la conversion et l'optimisation.

      Lorsque Copilot génère du code SQL, il apprend automatiquement les connaissances métier à partir de vos commentaires et des métadonnées des tables et des colonnes. Si les connaissances apprises sont inexactes, vous pouvez les modifier pour améliorer leur précision. Copilot utilisera ensuite ces connaissances corrigées pour fournir des réponses plus précises à des questions similaires à l'avenir.

      Si vous êtes satisfait du code SQL généré par Copilot et qu'il répond à vos exigences métier, vous pouvez « aimer » le code SQL généré. Ces commentaires aident à améliorer la génération future de code SQL.

    • Afficher les notes d'utilisation des tables

      Le système génère automatiquement une description de la table basée sur les métadonnées des tables et des colonnes. Vous pouvez développer une base de données, double-cliquer sur un nom de table, puis afficher ou modifier la description dans l'onglet Usage Notes.

Étapes suivantes

Développer avec Notebook

Gérer les ressources Notebook

Vous pouvez gérer les ressources ajoutées sur la page Resource Configuration. Pour savoir comment accéder à cette page, consultez la section Étape 4 : Ajouter des ressources.

  • Arrêter manuellement une ressource.

  • Modifier les informations de la ressource.

    Remarque

    Vous ne pouvez modifier les informations de la ressource que lorsque celle-ci est arrêtée.

  • Démarrer manuellement une ressource arrêtée.

  • Libérer automatiquement les ressources Notebook.

    Une ressource devient inactive lorsque tous les noyaux notebook associés sont terminés. La ressource est automatiquement libérée si elle reste inactive pendant une période spécifiée.

  • Afficher l'historique des jobs Spark pour une ressource Notebook.

    1. Sur la page Resource Configuration, cliquez sur SparkUI à droite de la ressource pour accéder à la page de liste des jobs.

      La page de liste des jobs (Spark History Server) affiche un tableau des enregistrements des applications Spark terminées. Le tableau comprend des colonnes telles que Version, App ID, App Name, Started, Completed, Duration, Spark User et Last Updated. Chaque entrée dispose d'un bouton Download pour télécharger son journal d'événements.

    2. Cliquez sur un App ID pour afficher les détails de l'exécution Spark.

      image