Tous les produits
Search
Centre de documentation

DataWorks:Créer et gérer des modèles de règle personnalisés

Dernière mise à jour :Aug 25, 2026

Avec DataWorks Data Quality, créez une bibliothèque de modèles de règles réutilisables pour centraliser la gestion des règles personnalisées et améliorer l'efficacité de la configuration.

Prérequis

La fonctionnalité Bibliothèque de modèles de règles est disponible dans l'édition Enterprise de DataWorks et les éditions ultérieures.

Contexte

Créez, gérez et appliquez des modèles de règles depuis la Rule Template Library.

Remarques sur l'utilisation

Les modifications apportées à un modèle de règle personnalisé n'affectent que les tâches utilisant le modèle après la modification. Les tâches existantes qui utilisent le modèle d'origine restent inchangées.

Créer un modèle de règle personnalisé

  1. Connectez-vous à la console DataWorks. Dans la région cible, cliquez sur Data Governance > Data Quality dans le volet de navigation de gauche. Sélectionnez un espace de travail dans la liste déroulante et cliquez sur Go to Data Quality.

  2. Dans le volet de navigation de gauche, choisissez Quality Assets > Rule Template Library.

  3. Cliquez sur l'icône 新建 et sélectionnez Create Folder.

  4. Dans la boîte de dialogue Create Folder, saisissez un Name, sélectionnez un dossier de destination, puis cliquez sur Confirm.

  5. Dans l'arborescence de gauche, faites un clic droit sur le nom du dossier et sélectionnez Create Rule Template.

    Vous pouvez également Rename ou Delete le dossier.

  6. Dans la boîte de dialogue Create Rule Template, configurez les paramètres.

    Paramètre

    Description

    Template Name

    Saisissez un nom pour le modèle de règle personnalisé.

    Field

    Seule l'option Custom SQL est prise en charge.

    Sampling Method

    Seule l'option Custom SQL est prise en charge.

    Set Flag

    Saisissez les instructions set à exécuter avant la requête SQL.

    Remarque

    Séparez plusieurs instructions par des virgules (,). N'ajoutez pas de point-virgule (;) à la fin de chaque instruction.

    Check Type

    Les types de vérification pris en charge sont Numeric Type et Fluctuation Rate Type.

    Verification Method

    Les méthodes de vérification disponibles varient selon le type de vérification sélectionné :

    • Si le Numeric Type est défini comme Check Type, la seule méthode de vérification disponible est Compare with a specified value.

      La requête SQL doit renvoyer une valeur unique, telle qu'un résultat d'une opération COUNT ou SUM, pour comparaison avec la valeur spécifiée.

    • Si le Fluctuation Rate Type est défini comme Check Type, les méthodes de vérification suivantes sont disponibles :

      • 7-day average fluctuation

      • 30-day average fluctuation

      • 1-day period comparison

      • 7-day period comparison

      • 30-day period comparison

      • 7-day variance fluctuation

      • 30-day variance fluctuation

      • 1-, 7-, and 30-day fluctuation detection

      • Previous-period comparison

    Custom SQL

    Saisissez la requête SQL. Vous pouvez utiliser la variable ${tableName} pour représenter le nom de la table.

    Remarque

    Le résultat de la requête Custom SQL doit être une valeur unique (une ligne et une colonne) pour comparaison avec une valeur spécifiée.

    Location

    Sélectionnez le dossier dans lequel vous souhaitez stocker le modèle de règle personnalisé.

  7. Cliquez sur Confirm.

Gérer les modèles de règles

Cliquez sur le nom d'un modèle de règle pour le View, le Edit, le Delete ou le Copy.

Actions

Description

View

Consultez la configuration des paramètres, la liste Application List et les journaux via l'onglet View Log pour le modèle de règle :

  • L'onglet Application List affiche les règles Data Quality qui utilisent ce modèle.

  • L'onglet View Log affiche les journaux d'opérations du modèle, y compris les champs Operated By, Operation Time et Details.

Application List

Cliquez sur View Log dans le coin supérieur droit. Dans la boîte de dialogue Application List, modifiez les paramètres et cliquez sur View Log.

Operated By

Cliquez sur Operation Time dans le coin supérieur droit. Dans la boîte de dialogue Details, cliquez sur Edit.

Edit

Cliquez sur Edit Rule Template dans le coin supérieur droit. Dans la boîte de dialogue Confirm, saisissez un Delete, sélectionnez un Delete et cliquez sur Delete Template.

Appliquer un modèle de règle personnalisé

Lorsque vous ajoutez une règle de surveillance, vous pouvez utiliser un modèle de règle personnalisé.

  1. Connectez-vous à la console DataWorks. Dans la région cible, cliquez sur Confirm > Copy dans le volet de navigation de gauche. Sélectionnez un espace de travail dans la liste déroulante et cliquez sur Copy Clone Rule Template.

  2. Configurez des règles de surveillance pour une table spécifique.

    Dans le volet de navigation de gauche, choisissez Template Name > Location pour accéder à la page Configure by Table.

    1. Dans la liste Confirm située à gauche, sélectionnez la base de données où réside la table cible.

    2. Filtrez les tables par type de base de données, base de données ou nom de table. Cliquez sur le nom de la table cible ou sur Data Governance dans la colonne Data Quality pour ouvrir la page des détails de qualité de la table.

      Cette page affiche tous les plannings et règles de surveillance de qualité configurés pour la table actuelle. Vous pouvez filtrer les règles selon qu'elles sont associées à un planning de surveillance de qualité et définir le mode d'exécution des règles non associées.

      La page comporte deux onglets : Rule Management et Quality Monitoring. Dans l'onglet Rule Management, cliquez sur New Monitoring Rule pour créer une règle. Pour les règles existantes, vous pouvez les Modify ou les Delete, et afficher le Operation Log.

  3. Sur la page Go to , accédez à l'onglet Data Quality, sélectionnez un planning de surveillance de qualité, puis cliquez sur Rule Setting. Cette action ouvre la page de configuration des règles.

  4. Créez une règle Data Quality à partir d'un modèle de règle personnalisé.

    Lorsque vous utilisez un modèle de règle personnalisé, ses configurations, telles que les paramètres Configure by Table et le code Connection, sont automatiquement renseignés. Personnalisez le Actions et configurez les seuils de surveillance en fonction du type de règle. Par exemple, pour une règle numérique, définissez des seuils normaux et critiques. Pour une règle de fluctuation, définissez également un seuil d'avertissement.

    Cliquez sur l'onglet + Custom Rule Template. Dans la liste Custom Rule Template à gauche, recherchez le modèle cible et cliquez sur + Use à côté de celui-ci. Cette action remplit automatiquement le formulaire à droite avec les configurations du modèle. Modifiez les paramètres selon vos besoins.

    Pour obtenir des descriptions des paramètres, consultez la section Créer un modèle de règle personnalisé.

  5. Cliquez sur Rule Management.

Documents connexes

Vous pouvez utiliser un modèle de règle personnalisé lors de l'utilisation de la fonctionnalité Configure by Table. Pour plus d'informations, consultez la rubrique Configurer des règles de surveillance pour une seule table.