Tous les produits
Search
Centre de documentation

AnalyticDB:Redash

Dernière mise à jour :Aug 24, 2026

Redash est un outil open source de business intelligence (BI) qui prend en charge diverses sources de données, telles que MySQL et PostgreSQL. Il offre une interface web intuitive pour explorer et visualiser vos données. Cette rubrique explique comment connecter Redash à AnalyticDB for MySQL.

Prérequis

Se connecter à un endpoint AnalyticDB for MySQL

  1. Après avoir démarré Redash, saisissez http://<IP address>:<port number> dans votre navigateur pour ouvrir l'interface web de Redash.

    IP address : adresse IP du serveur Redash.

    Port number : le port par défaut est 5000. Si le port 5000 est déjà utilisé, spécifiez un autre port lors du démarrage de Redash.

  2. Dans le volet de navigation de gauche, cliquez sur Settings. Dans l'onglet Data Sources, cliquez sur +New Data Source.

  3. Dans la boîte de dialogue Create a New Data Source, configurez les paramètres suivants, puis cliquez sur Create.

    Parameter

    Description

    Type Selection

    Sélectionnez MySQL dans la liste déroulante.

    Configuration

    Name

    Un nom personnalisé pour la source de données.

    Host

    L'endpoint de connexion de votre cluster AnalyticDB for MySQL.

    • Si Redash est installé sur une instance ECS située dans le même VPC que le cluster AnalyticDB for MySQL, saisissez l'adresse privée de l'instance ECS.

    • Si Redash est installé sur un serveur local, saisissez l'endpoint public.

    Port

    Le numéro de port. La valeur est fixée à 3306.

    User

    Le compte de base de données du cluster AnalyticDB for MySQL.

    Password

    Le mot de passe du compte de base de données AnalyticDB for MySQL.

    Database Name

    La base de données du cluster AnalyticDB for MySQL.

  4. Dans le volet de navigation de gauche, cliquez sur Create > New Query. Dans l'éditeur, rédigez une instruction SQL, puis cliquez sur Execute.

    Si la requête s'exécute avec succès, les résultats s'affichent dans un tableau sous l'éditeur. Cela confirme que la connexion à l'endpoint AnalyticDB for MySQL est établie.

  5. Une fois l'instruction SQL exécutée, cliquez sur + Add Visualization pour créer une visualisation à partir des résultats. Pour plus d'informations, consultez la documentation officielle de Redash.

    Dans la boîte de dialogue Visualization Editor, définissez Visualization Type sur Chart et Chart Type sur Bar. Configurez la colonne X Column (par exemple, name) et les colonnes Y Columns (par exemple, age). Un aperçu en temps réel du diagramme en barres s'affiche à droite. Après avoir confirmé les paramètres, cliquez sur Save.

Se connecter à un endpoint Spark JDBC

Préparer l'environnement

  1. (Facultatif) Copiez le fichier adb_spark.png vers le chemin cible.

    • Pour un déploiement de Redash à partir du code source, le chemin cible est <root directory of the source code>/client/app/assets/images/db-logos/.

    • Pour un déploiement de Redash via une image Docker, le chemin cible est </app directory>/client/dist/images/db-logos/.

      Remarque

      Le répertoire /app directory se trouve dans les conteneurs redash_server, redash_scheduler, redash_adhoc_worker et redash_scheduled_worker.

  2. Copiez le fichier adb_spark_ds.py vers le chemin cible.

    • Pour un déploiement de Redash à partir du code source, le chemin cible est <root directory of the source code>/redash/query_runner/.

    • Pour un déploiement de Redash via une image Docker, le chemin cible est </app directory>/redash/query_runner/.

      Remarque

      Le répertoire /app directory se trouve dans les conteneurs redash_server, redash_scheduler, redash_adhoc_worker et redash_scheduled_worker.

  3. Ajoutez le paramètre de configuration 'redash.query_runner.adb_spark_ds' au fichier __init__.py.

    • Chemin du fichier __init__.py :

      Pour un déploiement de Redash à partir du code source, le chemin cible est <root directory of the source code>/redash/settings/__init__.py.

      Pour un déploiement de Redash via une image Docker, le chemin cible est </app directory>/redash/settings/__init__.py.

      Remarque

      Le répertoire /app directory se trouve dans les conteneurs redash_server, redash_scheduler, redash_adhoc_worker et redash_scheduled_worker.

    • Le format du paramètre est le suivant :

      default_query_runners = [
          'redash.query_runner.athena',
          'redash.query_runner.big_query',
          ........
          'redash.query_runner.uptycs',
          'redash.query_runner.adb_spark_ds'
      ]

Procédure

  1. Accédez à l'interface web de Redash. Dans le volet de navigation de gauche, cliquez sur Settings. Dans l'onglet Data Sources, cliquez sur +New Data Source.

  2. Dans la boîte de dialogue Create a New Data Source, configurez les paramètres suivants, puis cliquez sur Create.

    Parameter

    Description

    Type Selection

    Sélectionnez ADB Spark dans la liste déroulante.

    Configuration

    Name

    Un nom personnalisé pour la source de données.

    Host

    L'endpoint de connexion du groupe de ressources Spark Interactive. Pour savoir comment obtenir l'endpoint, consultez la section Préparer l'environnement.

    Port

    Le numéro de port du groupe de ressources Spark Interactive. La valeur est fixée à 10000.

    Database

    La base de données du cluster AnalyticDB for MySQL.

    Username

    Le compte de base de données du cluster AnalyticDB for MySQL.

    Password

    Le mot de passe du compte de base de données AnalyticDB for MySQL.

    Resource Group

    Le nom du groupe de ressources Spark Interactive.

  3. Dans le volet de navigation de gauche, cliquez sur Create > > New Query. Dans l'éditeur, rédigez une instruction SQL, puis cliquez sur Execute.

    Par exemple, exécutez la requête select * from test_db.test_tbl. Si la requête s'exécute avec succès, les résultats s'affichent dans l'onglet Table.

  4. Une fois l'instruction SQL exécutée, cliquez sur + Add Visualization pour créer une visualisation à partir des résultats. Pour plus d'informations, consultez la documentation officielle de Redash.

    Dans la boîte de dialogue Visualization Editor, définissez Visualization Type sur Chart et Chart Type sur Bar. Pour la colonne X Column, sélectionnez name et, pour les colonnes Y Columns, sélectionnez age. Un aperçu du diagramme en barres s'affiche à droite. Après avoir confirmé les paramètres, cliquez sur Save.