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"ERROR 1045 (28000): Access denied for user" is displayed when you connect to apsaradb RDS for MySQL

Last Updated: Sep 29, 2020

Problem description

When you connect to an apsaradb RDS for MySQL instance, the following error message is displayed.

ERROR 1045 (28000): Access denied for user 'XXX'@'XXX' (using password: YES)

 

Cause

The user name or password is incorrect.

 

Solution

Alibaba Cloud reminds you that:

  • Before you perform operations that may cause risks, such as modifying instance configurations or data, we recommend that you check the disaster recovery and fault tolerance capabilities of the instances to ensure data security.
  • You can modify the configurations and data of instances including but not limited to Elastic Compute Service (ECS) and Relational Database Service (RDS) instances. Before the modification, we recommend that you create snapshots or enable RDS log backup.
  • If you have authorized or submitted sensitive information such as the logon account and password in the Alibaba Cloud Management Console, we recommend that you modify such information in a timely manner.

Please check the user name and password in the connection information.

  • Apsaradb for RDS does not provide root accounts. You must create one. For more information, see create accounts and databases.

  • If the password contains special characters, you may need to add single quotes. For example, in the command, use -p 'XXX'.

  • If you forget your password, you can console of account Management page to change the password.

    Note: After you modify the password, it may take several minutes for the new password to take effect.

    修改密码

 

 

Additional information

When you connect to an apsaradb RDS for MySQL instance, the following error message appears.

ERROR 1045 (28000): Access denied for user 'XXX'@'XXX' (using password: NO)

 

Application scope

  • ApsaraDB RDS for MySQL