This topic describes how to fix the errors when you fail to access Enterprise Distributed Application Service (EDAS) application pages and call Remote Procedure Call (RPC) services.
Problem description
EDAS application pages cannot be accessed by using HTTP. RPC services cannot be called.
Causes
The network between the service provider and the service consumer has an error, the application configuration path is improperly configured, or the application has built-in errors.
The network between the server and the registry cannot be connected, the permissions on the service are not obtained, or service calls time out.
Solutions
If EDAS application pages cannot be accessed by using HTTP, perform the following steps:
Run the
curl
orping
command on your server to check whether the page URL is valid. If the URL is valid, check whether the network connection from the access host to the server host is normal. If the network connection is abnormal, fix the network error and try again.If the network connection is normal, check whether errors are recorded in the log files in the Tomcat installation directory
/logs
to fix all the errors.Check the settings of the HTTP path, especially the context and port settings, to ensure that the port number in the page URL is the same as the port number in the HTTP path.
Run the following command to view the process ID of the Java program:
ps -ef |grep java
Run the following commands in sequence in a Java Virtual Machine (JVM) to check whether the program runs as expected:
sudo jstack -F Process ID sudo jstat -class [vmid] [interval] [count]; jmap -heap 2083
[vmid]
: the process ID of the Java program.[interval]
: the interval. Unit: seconds or milliseconds.[count]
: the number of printing times. If the default value is used, printing is ceaseless.
If RPC services cannot be called, perform the following steps:
Check whether the application that initiates the RPC call and the application that is released belong to the same account and whether the network can be connected.
Check whether the service is unavailable because the server port is blocked.
Check whether errors are recorded in the Tomcat application logs of the service. Fix all the errors until the service appears in the service list.
Check
/home/admin/logs/hsf/hsf.log
to view the error code. For more information about errors and solutions, see HSF error codes.