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:When you join an ECS instance to a domain in Windows, a message is displayed, indicating that the network path cannot be found

Last Updated:Dec 30, 2020

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Problem description

After deploying the domain controller on the Windows instance, the client prompts the following error when joining the domain.

indicating that the network path cannot be found

Cause

Client joining to a domain fails for the following reasons.

  • The TCP/IP NetBIOS Helper and Remote registrr services of the domain controller and client are not enabled.
  • DNS on the client is not directed to the private IP address of the DNS server on the domain controller.
  • The SID of the client and domain controller may conflict.

Solution

  1. Check whether the TCP/IP NetBIOS Helper and Remote registrr services of the domain controller and the client are enabled. Please refer to the following steps for the specific operation method.
  2. Log on to the Apsara stack console as an administrator and enter services.msc in the run field. Click OK.
  3. Open the service page and check whether TCP/IP NetBIOS Helper and the Remote registrr service are enabled. If not, enable the corresponding services and set them to run automatically.
  4. Check whether the DNS configuration of the client points to the private IP address of the DNS server of the domain controller. If not, modify the client DNS to point to the private IP address of the DNS server on the domain controller.
  5. Run the ping command on the client to test the connectivity to the domain name of the domain controller and check whether the resolved address is correct. If the resolution is incorrect, you need to check the domain name record on the DNS server.
  6. Check whether the SID of the client and the domain controller conflict. For more information, see the following steps.
  7. Enter cmd in the run text box, and then click OK. Open the command line tool and run the whoami /user command to check whether the system ID (SID) is the same between the client and the domain controller. If the same can be modified using the NewSID tool.
  8. Check whether security software such as client firewall is blocked.

Scope

  • ECS