Todos los productos
Search
Centro de documentos

Data Management:Crear un workspace y agregar recursos

Última actualización: Sep 03, 2026

Este tema describe cómo crear un workspace de Notebook, agregar recursos y configurar un espacio de almacenamiento de código.

Paso 1: Crear e ir a un workspace

  1. Inicie sesión en DMS 5.0.

  2. Coloque el puntero sobre el icono 2023-01-28_15-57-17.png en la esquina superior izquierda y seleccione All Features > Data+AI > Notebook.

    Nota

    Si utiliza la consola de DMS en modo normal, seleccione Data+AI > Notebook en la barra de navegación superior.

  3. Haga clic en Create Workspace. En el cuadro de diálogo que aparece, introduzca un Workspace Name, seleccione una Region y haga clic en OK.

    Nota
    • El nombre del workspace solo puede contener letras, dígitos y guiones bajos (_).

    • Solo puede seleccionar la región Singapore.

  4. En la columna Actions del workspace deseado, haga clic en Go to Workspace.

    Nota

    De forma predeterminada, solo el creador de un workspace puede acceder a él. Para el desarrollo colaborativo, el creador del workspace debe otorgar permisos de desarrollo a otros usuarios.

Paso 2: Agregar miembros al proyecto

Si varios usuarios colaboran en un workspace, debe asignarles roles.

Los usuarios deben agregarse a DMS antes de poder asignarles roles. Para obtener más información, consulte User management.

Haga clic en el icono de configuración en la parte inferior del panel de navegación izquierdo y elija Member Management. Luego, haga clic en Add Members. En el cuadro de diálogo que aparece, seleccione los miembros que desea agregar y asígneles roles. Los roles disponibles incluyen Administrator, Developer y Read-only User.

Paso 3: Configurar el espacio de almacenamiento de código

  1. En el workspace, vaya a la pestaña Project Settings image y haga clic en Storage Management.

  2. En la página Storage Management, haga clic en el icono image a la derecha de Code Space.

  3. En el cuadro de diálogo Select OSS Directory, seleccione el Bucket deseado.

    El bucket seleccionado debe estar en la misma región que el workspace actual y su clase de almacenamiento debe ser Standard.

    Nota

    Si no hay buckets disponibles en la región actual, vaya a la consola de Object Storage Service (OSS) para crear uno. Para obtener más información, consulte Create buckets.

  4. Haga clic en OK.

Paso 4: Agregar recursos

Para consultar y analizar datos con Notebook, primero debe agregar e iniciar un recurso.

  1. En el workspace, vaya a la pestaña Project Settings image y haga clic en Resource Configuration.

  2. Haga clic en Add Resource y configure la información del recurso.

    Parámetro

    Descripción

    Resource name

    Introduzca un nombre descriptivo.

    Resource description

    Describa el propósito de este recurso.

    Image

    • Spark 3.5+Python 3.9

    • Spark 3.3+Python 3.9

    • Python 3.9

    ADB instance

    Seleccione una instancia de AnalyticDB for MySQL.

    Nota
    • Si selecciona una imagen con Spark 3.3 o 3.5, también debe seleccionar un clúster de AnalyticDB for MySQL.

    • Si no encuentra el clúster deseado, compruebe si se ha registrado en DMS. Para obtener más información, consulte Register a cloud database instance.

    ADB resource group

    Seleccione un resource group.

    Executor spec

    Las especificaciones de recursos para el ejecutor de Spark. Los diferentes modelos tienen distintas especificaciones. Para obtener más información, consulte la columna Model en Spark application configuration parameters.

    Executor count

    El número de ejecutores de Spark.

    Nota

    Durante la versión preliminar pública de Notebook, el número total de ejecutores en todos los recursos de un workspace no puede exceder seis. Para aumentar el límite de ejecutores, póngase en contacto con el soporte técnico de DMS.

    Driver spec

    Las especificaciones de recursos para el driver de Spark.

    • General_XSmall_v1 (2 vCores, 8 GB)

    • General_Small_v1 (4 vCores, 16 GB)

    • General_Medium_v1 (8 vCores, 32 GB)

    • General_Large_v1 (16 vCores, 64 GB)

    Notebook specification

    Este parámetro solo está disponible cuando selecciona una imagen con Python 3.9.

    • General_XSmall_v1 (2 vCores, 8 GB)

    • General_Small_v1 (4 vCores, 16 GB)

    • General_Medium_v1 (8 vCores, 32 GB)

    • General_Large_v1 (16 vCores, 64 GB)

    VPC ID

    Seleccione una Virtual Private Cloud (VPC) disponible.

    Zone ID

    Seleccione una zona en la VPC.

    vSwitch ID

    Seleccione un vSwitch en la VPC.

    Security group ID

    Seleccione un security group disponible.

  3. Haga clic en Save.

  4. Inicie el recurso.

    En la columna Actions del recurso, haga clic en Start y luego en OK.

    Nota

    El recurso tarda aproximadamente un minuto en iniciarse. Una vez iniciado, el Resource Status cambia a Running.

Paso 5: Configurar un espacio de almacenamiento de usuario

Para leer datos de fuentes externas con Notebook, puede configurar rutas a varios buckets de OSS.

  1. En el workspace, vaya a la pestaña Settings image y haga clic en Storage Management.

  2. En el área User Storage Space, configure la ruta de OSS.

    Nota

    La ruta de montaje debe comenzar con /mnt/.

  3. Haga clic en el icono Save image.

Paso 6: Consultar datos

  1. En el workspace, vaya a la pestaña Data image.

  2. En SQL Console, puede realizar las siguientes operaciones:

    • Consultar datos

      Puede usar Copilot para generar consultas SQL o escribirlas manualmente. La sintaxis SQL debe ser coherente con la del almacén de datos lógico .

      Nota

      Puede utilizar la sintaxis estándar de MySQL para consultar tablas independientemente de su base de datos de origen, como AnalyticDB for MySQL o RDS for MySQL. DMS gestiona automáticamente la conversión y optimización.

      Cuando Copilot genera SQL, aprende automáticamente conocimiento del negocio a partir de sus comentarios y de los metadatos de tablas y columnas. Si el conocimiento aprendido es inexacto, puede editarlo para mejorar su precisión. Copilot hará referencia a este conocimiento corregido para proporcionar respuestas más precisas a preguntas similares en el futuro.

      Si está satisfecho con el SQL generado por Copilot y cumple con sus requisitos comerciales, puede dar "me gusta" al SQL generado. Estos comentarios ayudan a mejorar la generación futura de SQL.

    • Consultar notas de uso de tablas

      El sistema genera automáticamente una descripción de la tabla basada en los metadatos de la tabla y las columnas. Puede expandir una base de datos, hacer doble clic en el nombre de una tabla y luego consultar o editar la descripción en la pestaña Usage Notes.

Siguientes pasos

Develop with Notebook

Gestionar recursos de Notebook

Puede gestionar los recursos agregados en la página Resource Configuration. Para obtener instrucciones sobre cómo ir a esta página, consulte Step 4: Add resources.

  • Detener manualmente un recurso.

  • Editar la información del recurso.

    Nota

    Solo puede editar la información del recurso cuando este está detenido.

  • Iniciar manualmente un recurso detenido.

  • Liberar automáticamente recursos de Notebook.

    Un recurso queda inactivo cuando finalizan todos sus kernels de notebook asociados. El recurso se libera automáticamente si permanece inactivo durante un periodo especificado.

  • Consultar trabajos históricos de Spark para un recurso de Notebook.

    1. En la página Resource Configuration, haga clic en SparkUI a la derecha del recurso para ir a la página de lista de trabajos.

      La página de lista de trabajos (Spark History Server) muestra una tabla con registros de aplicaciones de Spark completadas. La tabla incluye columnas como Version, App ID, App Name, Started, Completed, Duration, Spark User y Last Updated. Cada entrada tiene un botón Download para descargar su registro de eventos.

    2. Haga clic en un App ID para ver detalles sobre la ejecución de Spark.

      image