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Tablestore:Troubleshoot the "Request denied by instance ACL policies" error

Last Updated:Jun 21, 2026

If the "Request denied by instance ACL policies" exception occurs when you use a Tablestore SDK to access resources in a Tablestore instance, check the network access control list (ACL) configurations of the instance and make sure that the type of the network that your client uses to access resources in the instance is allowed by the instance.

Problem description

When I use a Tablestore SDK to access resources in a Tablestore instance, the "Request denied by instance ACL policies" exception occurs. Sample error:

[ErrorCode]:OTSAuthFailed, [Message]:Request denied by instance ACL policies., [RequestId]:XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX, [TraceId]:XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX, [HttpStatus:]403

Possible cause

The type of the network that your client uses to access resources in the Tablestore instance is not allowed by the instance. For example, your client uses the Internet to access resources in the Tablestore instance. However, the instance does not allow access over the Internet.

Solution

Check the network ACL configurations of the Tablestore instance in the Tablestore console and modify the configurations to allow the type of the network that your client uses to access resources in the instance. For more information, see Network ACL.

Important

By default, Internet access is disabled for an instance. You can manually enable Internet access for an instance.

  1. Go to the Network Management tab.

    1. Log on to the Tablestore console.

    2. In the top navigation bar of the Overview page, select a resource group and a region.

    3. Click the instance name or click Manage Instance in the Actions column.

    4. On the Instance Management page, click the Network Management tab.

  2. On the Network Management tab, in the Network Access Control section, select your client's network type under Allowed Network Type.

    The available network types are VPC, classic network, and Internet. Select the appropriate network type for your client and click Settings.

  3. Click Configure.

  4. Complete the verification as prompted to complete the settings.