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Server Migration Center:What do I do if an insufficient disk space or memory error occurs during OS migration?

Last Updated:Feb 28, 2026

Server Migration Center (SMC) requires minimum disk space and memory to perform operating system migrations. If your server does not meet these requirements, the migration fails with an error. This topic describes the error messages for each migration scenario and how to resolve them.

Problem description

During an operating system migration with SMC, one of the following error messages appears:

  • Available system memory is less than 300M, memory requirement is not satisfied.

  • Total system memory is less than 512M, memory requirement is not satisfied.

  • Available system storage is less than 2G, storge requirement is not satisfied.

  • To ensure the migration, this machine must have 2G free space on disk and 300MB RAM available.

  • To ensure the migration, this machine must have 512MB RAM at least totally.

  • To ensure the migration, this machine must have 4G free space on disk and 600M RAM available

  • Memory detected: *MiB, required: *MiB

Cause

The migration fails because the server does not meet the minimum disk space or memory requirements. The specific requirements depend on your migration scenario.

CentOS/Red Hat to Alibaba Cloud Linux migrations

The following requirements apply to these migration paths:

  • CentOS 7 to Alibaba Cloud Linux 2

  • CentOS 8 to Alibaba Cloud Linux 3

  • Red Hat 8 to Alibaba Cloud Linux 3

Error message

Cause

Available system memory is less than 300M, memory requirement is not satisfied.

The available memory of the server is less than 300 MiB.

Total system memory is less than 512M, memory requirement is not satisfied.

The total memory of the server is less than 512 MiB.

Available system storage is less than 2G, storge requirement is not satisfied.

The available space of the system disk is less than 2 GiB.

CentOS to Anolis OS migrations

The following requirements apply to these migration paths:

  • CentOS 7 to Anolis OS 7

  • CentOS 8 to Anolis OS 8

Error message

Cause

To ensure the migration, this machine must have 2G free space on disk and 300MB RAM available.

The available space of the system disk is less than 2 GiB and the available memory is less than 300 MiB.

To ensure the migration, this machine must have 512MB RAM at least totally.

The total memory of the server is less than 512 MiB.

Cross-version migrations (major version upgrade)

The following requirements apply to these migration paths:

  • CentOS 7 to Alibaba Cloud Linux 3

  • CentOS 7 to Anolis OS 8

  • Red Hat 7 to Alibaba Cloud Linux 3

  • Alibaba Cloud Linux 2 to Alibaba Cloud Linux 3

Error message

Cause

To ensure the migration, this machine must have 4G free space on disk and 600M RAM available

The available space of the system disk is less than 4 GiB and the available memory is less than 600 MiB.

Memory detected: *MiB, required: *MiB

The total memory of the server is below the minimum threshold. For x86_64 architecture, the minimum is 1.5 GiB. For aarch64 architecture, the minimum is 2 GiB.

Solution

  1. Connect to the Elastic Compute Service (ECS) instance whose operating system you want to migrate. For more information, see Connect to a Linux instance by using a password or key.

  2. Free up disk space or memory, depending on which resource is insufficient.

    • If the root directory disk space is insufficient:

      Run the following commands to clean up the /tmp and /var/log directories:

      Warning

      Make sure that the files are no longer needed before you delete them. Deleting files that are still in use may affect your workloads.

      rm -rf /tmp/*
      rm -rf /var/log/syslog.*    # Delete earlier syslog files.
    • If available memory is insufficient:

      Suspend non-essential service programs, such as Java programs or the NGINX process, to free up memory. You can restart these services after the migration completes.

      For example, to suspend an NGINX process:

      ps aux | grep nginx          # Find the process ID (PID) of the NGINX process.
      kill -SIGSTOP <nginx-pid>    # Suspend the NGINX process.
  3. After you resolve the network issue, run the SMC client to retry the operation. For more information, see Run the SMC client.

  4. If you suspended any processes in Step 2, restart them after the migration completes.

    For example, to resume the NGINX process:

    kill -SIGCONT <nginx-pid>