All Products
Search
Document Center

ApsaraDB RDS:What do I do if the "ERROR 1045 (28000): Access denied for user" error message is displayed when I connect to an ApsaraDB RDS for MySQL instance?

Last Updated:Apr 17, 2025

Problem description

When you connect to an ApsaraDB RDS for MySQL instance, the following error message is displayed:

ERROR 1045 (28000): Access denied for user 'XXX'@'XXX' (using password: YES)

Cause

The username or password that you entered is invalid.

Solution

Check the username and password in the connection information.

  • ApsaraDB RDS does not provide root accounts. If you need an account, you can create one. For more information, see Create accounts and databases.

  • If the password contains special characters, the special characters must be enclosed in single quotation marks ('). For example, use -p 'XXX' in a command.

  • If you forget the password of the account that is used to connect to the RDS instance, log on to the ApsaraDB RDS console and go to the Accounts page of the instance details page. Then, you can change the password of the account on the Accounts page.

    Note

    After you change the password, the new password takes effect after a few minutes

  • If this error is returned in DMS, right-click the instance name and click Edit. Then, select Security Hosting - Manual for Access mode and enter your accout and password again.

Additional information

If the following error message is displayed When you connect to an ApsaraDB RDS for MySQL instance, no password is specified in the connection information.

ERROR 1045 (28000): Access denied for user 'XXX'@'XXX' (using password: NO)

Application scope

RDS for MySQL instances