This topic describes how to troubleshoot the registration failure of a service provider.

Problem description

After a service provider is started, it is not displayed in the Microservices Engine (MSE) console.

Cause

  • Information, such as domain names, port numbers, or namespaces, is incorrectly configured.
  • The service provider is not connected to the MSE Nacos instance but is connected to other environments.
  • The code of the service provider is invalid. As a result, the service provider is not registered with the MSE Nacos instance.
  • A network issue occurs. As a result, the registration fails.

Solution

  1. Check whether information such as domain names, port numbers, and namespaces is correctly configured for the service provider. Then, obtain the logs of the Nacos client and query the actual information from the logs. For more information about how to obtain the logs of a Nacos client, see How do I obtain logs from a Nacos client?.

    If the actual information is invalid, check whether the service provider reads a valid configuration file.

  2. If you use Enterprise Distributed Application Service (EDAS) or Serverless App Engine (SAE) to deploy the service provider, check whether Use Configured Registration Center is turned on during the deployment. For more information, see Select an O&M method for your service registry .
  3. If you use services such as Elastic Compute Service (ECS) and Container Service for Kubernetes (ACK) to deploy the service provider, obtain the logs of the Nacos client and search for information from the logs based on the keyword REGISTER-SERVICE. For more information about how to obtain the logs of a Nacos client, see How do I obtain logs from a Nacos client?.
    • If related information is not found, the application code is invalid, and the service registration is not initiated.
    • If related information is found but the service name is not the expected name, the application code is invalid, and an invalid service registration is initiated.
  4. If you find that the service provider has initiated a service registration process after you perform the preceding steps, identify the cause of the registration failure based on the logs of the Nacos client.