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Microservices Engine:What do I do if the IP address of an unavailable service provider can still be viewed in the MSE console?

Last Updated:Feb 05, 2024

This topic describes how to troubleshoot the issue that the IP address of an unavailable service provider can still be viewed in the Microservices Engine (MSE) console.

Problem description

  • A service provider is disabled, but the information about the service provider can still be viewed in the MSE console.

  • After a service provider is restarted or released, the service provider can still be viewed in the MSE console.

Cause

  • The service provider is not completely disabled. The service provider process still exists and sends heartbeat messages to maintain the connection to the MSE Nacos instance. As a result, the MSE Nacos instance does not remove the service provider.

  • An additional application process sends heartbeat messages to maintain the connection to the MSE Nacos instance. As a result, the MSE Nacos instance does not remove the service provider.

Solution

  1. If you confirm that the service provider is not required, disable the service provider in the MSE console. This ensures that no traffic is routed to the service provider. For more information about how to disable an application, see Start or shut down an application instance.

  2. Check whether the service provider is completely disabled based on the deployment environment.

    1. If the service provider is deployed on an Elastic Compute Service (ECS) instance, log on to the ECS instance with a specified IP address and run a command such as ps -ef | grep ${Application name}, netstat -anp | grep 9848, or netstat -anp | grep 8848 to check whether the service provider process exists and whether the service provider is connected to the MSE Nacos instance. If the service provider process exists and the service provider is connected to the MSE Nacos instance, disable the service provider.

    2. If the service provider is deployed in a self-managed Kubernetes cluster, a Docker, or a Container Service for Kubernetes (ACK) cluster, check whether the service provider process that corresponds to an unavailable pod or an unavailable container exists by performing the following operation: Run a command such as ps -ef | grep ${Application name} on the node or host to check whether the number of nodes in the service provider is the same as the expected number. If they are different, find the unavailable pod and completely disable the pod.

      If the service provider is deployed in an ACK cluster, submit a ticket to contact ACK technical support engineers and request them to check whether an unavailable pod exists.

    3. If the service provider is deployed on Enterprise Distributed Application Service (EDAS) or Serverless App Engine (SAE), join the EDAS or SAE DingTalk group to contact the related technical support engineers and request them to check whether the service provider fails to be removed.

      • ID of the EDAS DingTalk group: 31723701

      • ID of the SAE DingTalk group: 32874633