Problem description
When you perform application deployment, startup, scale-out, and scale-out operations on EDAS, the port health check fails, resulting in the change failure.
Cause
If you have configured a port health check, the application will check whether the relevant port of the application process is successfully opened when the application is started. If the port can be connected, the health check will be successful. If the application runs normally, the port health check must be normal, but otherwise, the URL health check is required. Therefore, the possible causes of the change failure are as follows:
- When the application starts, the 65000 port is inaccessible.
- The Tomcat container does not start properly.
Solution
- For more information, see Unable to access the application port of the ECS cluster. Troubleshoot and resolve the cause of the port exception. After processing, deploy the application again. If the application port is still abnormal, go to the next step.
- Check whether the application logs contain abnormal logs. For more information about how to view logs, see Use log files to troubleshoot problems in EDAS. According to the exception log, after processing is complete, redeploy the application.
Ideal For
- Enterprise Distributed Application Service (EDAS)