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:The EDAS application fails to be changed because the disk space is full

Last Updated:May 25, 2022

Problem description

When you deploy, start, scale out, and scale out an application in EDAS, the disk space is full and the application remains in a certain stage for a long time during the change process. 

The following error message is returned:

There is no space left on the EDAS-10000 disk.

or

No space left on device. Free space (for /home/admin) in bytes: 0exit 1. 

Cause

The disk of the machine is full. Generally, the application business logs write the disk full. In this case, you need to clean up the application logs.

Solutions

Log on to the ECS instance and clean up the application logs on the disk. For more information about the path of application logs, see Use log files to troubleshoot problems in EDAS.

Note: You must back up logs before you clear them.

Ideal For

  • Enterprise Distributed Application Service (EDAS)