All Products
Search
Document Center

:What do I do if an ECS instance experiences downtime and the "RIP:get_target_pstate_use_performance" message appears in a log?

Last Updated:Apr 15, 2024

This topic describes the solution to the issue that an Elastic Compute Service (ECS) instance experiences downtime on startup and the RIP:get_target_pstate_use_performance message appears in a log.

Problem description

Your ECS instance experiences downtime on startup and a call stack similar to the following call stack is displayed:

[    1.076899] divide error: 0000 [#1] SMP
[    1.077669] Modules linked in:
[    1.078302] CPU: 4 PID: 9 Comm: rcu_sched Not tainted 3.10.0-1127.19.1.el7.x86_64 #1
[    1.079519] Hardware name: Alibaba Cloud Alibaba Cloud ECS, BIOS 8f19b21 04/01/2014
[    1.080724] task: ffff91c8fa111070 ti: ffff91c8fa11c000 task.ti: ffff91c8fa11c000
[    1.081919] RIP: 0010:[<ffffffff85dc3089>]  [<ffffffff85dc3089>] get_target_pstate_use_performance+0x29/0xc0
[    1.083355] RSP: 0000:ffff91c8fa11fb40  EFLAGS: 00010006
[    1.093192] Call Trace:
[    1.093715]  [<ffffffff85dc4081>] intel_pstate_update_util+0x161/0x310
[    1.094550]  [<ffffffff858e9523>] ? load_balance+0x1a3/0xa10
[    1.095321]  [<ffffffff858e4e87>] update_curr+0x127/0x1e0
[    1.096123]  [<ffffffff858e52a8>] dequeue_entity+0x28/0x5c0
[    1.096894]  [<ffffffff8586d3be>] ? kvm_sched_clock_read+0x1e/0x30
[    1.097702]  [<ffffffff858e5893>] dequeue_task_fair+0x53/0x660
[    1.098490]  [<ffffffff858debe5>] ? sched_clock_cpu+0x85/0xc0
[    1.099266]  [<ffffffff858d7a56>] deactivate_task+0x46/0xd0

Cause

When an ECS instance starts, the frequency value in the current_pstate parameter of the Intel pstate driver is initialized to 0. If the system load changes when the system switches processes, the Intel pstate driver is used to adjust CPU performance. The Intel pstate driver uses 0 as the frequency value of the current_pstate parameter, which causes a division-by-zero error.

Solution

Important

Before you perform the operations in the solution on a instance on which the issue occurred, we recommend that you create snapshots for the instance to back up data. This prevents data loss caused by accidental operations. For information about how to create a snapshot, see Create a snapshot for a disk.

We recommend that you upgrade the kernel version of the instance operating system to 4.18 or later.