All Products
Search
Document Center

:How to resolve the "Your credentials don't work" error during remote logon to a Windows instance

Last Updated:Aug 25, 2026

This topic describes how to resolve the Your credentials don't work error that occurs when you remotely log on to a Windows Elastic Compute Service (ECS) instance.

Problem description

When you use Remote Desktop to access a Windows ECS instance, the Your credentials don't work error appears.

Possible causes

This issue may occur for the following reasons:

  • Reason 1: The password protected sharing feature is enabled in the Windows operating system. To resolve this issue, disable the password protected sharing feature. For more information, see Disable password protected sharing.

  • Reason 2: The instance is configured to force guest account access. To resolve this issue, disable guest account access. For more information, see Disable guest account access.

Solutions

Solution 1: Disable password protected sharing

  1. Log on to the ECS instance using Virtual Network Computing (VNC).

    For more information, see Overview of connection methods.

  2. Go to Control Panel > All Control Panel Items > Network and Sharing Center > Advanced sharing settings.

  3. In the Password protected sharing section, select Turn off password protected sharing and click Save changes.

Solution 2: Disable guest account access

  1. Log on to the ECS instance using VNC.

    For more information, see Overview of connection methods.

  2. Run Windows PowerShell as an administrator.

  3. In the Windows PowerShell dialog box, run the following command to disable guest account access.

    Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Control\Lsa" -Name "forceguest" -Value 0 -Force