Troubleshoot frequent Remote Desktop disconnections
This topic explains how to resolve frequent disconnections when connecting to a Windows instance using Remote Desktop.
Symptoms
When you connect to a Windows ECS instance from your local computer, the Remote Desktop connection disconnects if you are inactive for one to two minutes. After the disconnection, you cannot reconnect to the instance.
Cause
The startup type of the Routing and Remote Access service on the Windows ECS instance is set to Automatic (Delayed Start).
When the startup type of a service is set to Automatic (Delayed Start), Windows delays launching the service until the operating system has fully started. This setting helps prevent slow startup on resource-limited computers that load many services at once. However, if the startup type for the Routing and Remote Access service on an ECS instance is set to Automatic (Delayed Start), your Remote Desktop connection will disconnect shortly after you connect.
Resolution
Connect to the Windows instance using VNC.
For detailed instructions, see Connect to an instance by using VNC.
Click the
icon to open Control Panel, and then navigate to System and Security.In Control Panel, click System and Security > Administrative Tools, and then double-click Services.
In the Services list, double-click the Routing and Remote Access service to open the Routing and Remote Access Properties window.
In the Startup type: drop-down list, select Disabled, and click OK.