This topic describes how to resolve the issue that you can log on to a Windows Elastic Compute Service (ECS) instance by using Virtual Network Computing (VNC) but cannot use Remote Desktop to connect to the Windows instance with the same account and password.
Problem description
You can log on to a Windows ECS instance by using VNC but cannot use Remote Desktop to connect to the Windows instance with the same account and password. When you log on to the ECS console to view Windows system logs, the error message Unknown user name or bad password appears.
Cause
Local Security Setting is set to Guest only - local users authenticate as Guest for the instance.
In this case, all local users who are authenticated to the Windows instance over the network have Guest user rights.. As a result, you cannot connect to the instance by using Remote Desktop on your computer.
Solution
Right-click the Start icon and select Run. In the Run dialog box, enter gpedit.msc and click OK to go to the Local Security Policy window.
Choose Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options , and double-click Network access: Sharing and security model for local accounts.

On the Local Security Setting tab, change Guest only - local users authenticate as Guest to Classic - local users authenticate as themselves. Then, click OK to save the configuration.

Right-click the Start icon and select Run. In the Run dialog box, enter cmd and click OK to open Command Prompt.
Run the following command for the configuration to take effect:
gpupdate /forceCheck whether you can connect to the Windows instance by using Remote Desktop.