Remote Desktop connection fails when VNC succeeds

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This article describes how to troubleshoot a failed Remote Desktop connection to a Windows ECS instance when a VNC connection with the same credentials succeeds.

Problem description

You can log on to a Windows ECS instance using VNC. However, a Remote Desktop connection to the instance with the same credentials fails. The Windows system logs in the ECS console show an "Unknown user name or bad password" error.

Cause

The local security setting on the Windows ECS instance is set to Guest only - local users authenticate as Guest.

Note

When this mode is active, any local user who authenticates over the network receives only guest user rights. These limited permissions prevent Remote Desktop connections to the ECS instance.

Solution

  1. Connect to the instance using VNC.

  2. Click Start > Run. In the Run dialog box, enter gpedit.msc and click OK to open the Local Group Policy Editor.

  3. In the navigation pane, navigate to Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options. Then, double-click Network access: Sharing and security model for local accounts.

  4. On the Local Security Setting tab, change the setting from Guest only - local users authenticate as Guest to Classic - local users authenticate as themselves, and then click OK to save the change.

  5. Click Start > Run. In the Run dialog box, enter cmd and click OK to open Command Prompt.

  6. Run the following command to apply the policy.

    gpupdate /force
  7. Verify that you can connect to the Windows instance with Remote Desktop.