This topic describes the cause of and solution to the termdd blue screen issue on Windows Server 2008 R2.
Problem description
A termdd blue screen error, with an error code such as 0x000000D1, occurs on an ECS instance that runs Windows Server 2008 R2, as shown in the following figure.

The dump file indicates that the version of the termdd.sys (C:\Windows\System32\drivers\termdd.sys) file is earlier than 6.1.7601.24441.
Cause
The issue is caused by the system vulnerability described in CVE-2019-0708. Microsoft resolved this vulnerability on May 14, 2019.
Solutions
Update the operating system (OS).
Automatically update the OS using Windows Update
You can use Windows Update to update the OS to the latest version.
Connect to the ECS instance.
For more information, see Connect to a Windows instance using Workbench.
Modify the Windows Server Update Services (WSUS) address in the registry.
Go to Start > Run, and then enter regedit.
Navigate to the
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdatepath. Change the values ofWUServerandWUStatusServertohttp://update.cloud.aliyuncs.com.
Choose Start > Control Panel > System and Security > Windows Update.
After the scan for updates is complete, click Install Updates.
After the updates are installed, restart the Windows system.
Manually update the OS
Connect to the ECS instance.
For more information, see Connect to a Windows instance using Workbench.
Download the cumulative security patch KB4499164 or the security-only update patch KB4499175.
Double-click the patch to install it.
Restart the Windows system.
Common command update system
Log on to the ECS console.
In the left-side navigation pane, choose .
On the Common Commands tab, find the
ACS-ECS-ApplySecurityPatches-for-windows.ps1command and click Run.
Select the Windows instance that you want to update, configure other parameters, and update the system.
For more information, see View and run common commands.
Verify that the issue is resolved.
Check the installed patches.
After you update the system, open Command Prompt and run the
systeminfocommand to view the installed patches. Confirm that patch KB4499164 or KB4499175 is installed.
Check the version of the
termdd.sysfile.Confirm that the version of the
termdd.sys (C:\Windows\System32\drivers\termdd.sys)file is6.1.7601.24441or later.
If patch KB4499164 or KB4499175 is installed and the version of the
termdd.sysfile is6.1.7601.24441or later, the blue screen issue is resolved.