All Products
Search
Document Center

:How to fix the termdd blue screen issue on Windows Server

Last Updated:Nov 18, 2025

This topic describes the cause of and solution to the termdd blue screen issue on Windows Server 2008 R2.

Problem description

A termdd blue screen error, with an error code such as 0x000000D1, occurs on an ECS instance that runs Windows Server 2008 R2, as shown in the following figure.

image..png

The dump file indicates that the version of the termdd.sys (C:\Windows\System32\drivers\termdd.sys) file is earlier than 6.1.7601.24441.

Cause

The issue is caused by the system vulnerability described in CVE-2019-0708. Microsoft resolved this vulnerability on May 14, 2019. 

Solutions

  1. Update the operating system (OS).

    Automatically update the OS using Windows Update

    You can use Windows Update to update the OS to the latest version.

    1. Connect to the ECS instance.

      For more information, see Connect to a Windows instance using Workbench.

    2. Modify the Windows Server Update Services (WSUS) address in the registry.

      1. Go to Start > Run, and then enter regedit.

      2. Navigate to the Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate path. Change the values of WUServer and WUStatusServer to http://update.cloud.aliyuncs.com.

    3. Choose Start > Control Panel > System and Security > Windows Update.

    4. After the scan for updates is complete, click Install Updates.

    5. After the updates are installed, restart the Windows system.

    Manually update the OS

    1. Connect to the ECS instance.

      For more information, see Connect to a Windows instance using Workbench.

    2. Download the cumulative security patch KB4499164 or the security-only update patch KB4499175.

    3. Double-click the patch to install it.

    4. Restart the Windows system.

    Common command update system

    1. Log on to the ECS console.

    2. In the left-side navigation pane, choose Maintenance & Monitoring > Cloud Assistant.

    3. On the Common Commands tab, find the ACS-ECS-ApplySecurityPatches-for-windows.ps1 command and click Run.

      image

    4. Select the Windows instance that you want to update, configure other parameters, and update the system.

      For more information, see View and run common commands.

  2. Verify that the issue is resolved.

    • Check the installed patches.

      After you update the system, open Command Prompt and run the systeminfo command to view the installed patches. Confirm that patch KB4499164 or KB4499175 is installed.

      image..png

    • Check the version of the termdd.sys file.

      Confirm that the version of the termdd.sys (C:\Windows\System32\drivers\termdd.sys) file is 6.1.7601.24441 or later.

    If patch KB4499164 or KB4499175 is installed and the version of the termdd.sys file is 6.1.7601.24441 or later, the blue screen issue is resolved.