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Elastic Compute Service:What do I do if the termdd blue screen issue occurs on a Windows ECS instance?

Last Updated:Mar 24, 2025

This topic describes the cause of and solution to the termdd blue screen issue that occurs on an Elastic Compute Service (ECS) instance running Windows Server 2008 R2.

Problem description

When an ECS instance is running Windows Server 2008 R2, the termdd (with error code 0x000000D1 or other) blue screen issue occurs, as shown in the following figure.

image..png

The dump information also shows that the version of the termdd.sys (C:\Windows\System32\drivers\termdd.sys) file is earlier than 6.1.7601.24441.

Cause

The preceding issue is caused by system vulnerability CVE-2019-0708. Microsoft fixed this vulnerability on May 14, 2019.

Solution

  1. Update the operating system (OS).

    Automatically update the OS with Windows Update

    Use Windows Update to update the OS to the latest version.

    1. Use Workbench to connect to the Windows ECS instance over RDP.

    2. Modify the Windows Server Update Services (WSUS) address in the registry.

      1. Click Start, select Run, and then enter regedit.

      2. Go to the Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate path and change the values of the WUServer and WUStatusServer keys to http://update.cloud.aliyuncs.com.

    3. Choose Start > Control Panel > System and Security > Windows Update.

    4. After Windows Update scans for updates, click Install updates.

    5. After all updates are installed, restart Windows.

    Manually update the OS

    1. Use Workbench to connect to the Windows ECS instance over RDP.

    2. Download the cumulative security patch KB4499164 or security-only update patch KB4499175.

    3. Double-click the patch installation file.

    4. Restart Windows.

    Update the OS with common commands

    1. Log on to the ECS console.

    2. In the left-side navigation pane, choose Maintenance & Monitoring > Cloud Assistant.

    3. On the Common Commands tab, find the ACS-ECS-ApplySecurityPatches-for-windows.ps1 command and click Run.

      image

    4. Select the Windows ECS instance whose OS you want to update and configure other parameters to update the OS.

      For more information, see View and run common commands.

  2. Check whether the preceding blue screen issue is resolved.

    • Check the installed patches.

      After the OS is automatically or manually updated, open the Command Prompt window and run the systeminfo command to check the installed patches and confirm that the KB4499164 or KB4499175 patch is installed in the OS.

      image..png

    • Check the version of the termdd.sys file.

      Confirm that the version of the termdd.sys (C:\Windows\System32\drivers\termdd.sys) file is 6.1.7601.24441 or later.

    If the KB4499164 or KB4499175 patch is installed in the OS and the version of the termdd.sys file is 6.1.7601.24441 or later, the blue screen issue has been resolved.