This topic describes the cause of and solution to the termdd
blue screen issue that occurs on an Elastic Compute Service (ECS) instance running Windows Server 2008 R2.
Problem description
When an ECS instance is running Windows Server 2008 R2, the termdd
(with error code 0x000000D1
or other) blue screen issue occurs, as shown in the following figure.
The dump information also shows that the version of the termdd.sys (C:\Windows\System32\drivers\termdd.sys)
file is earlier than 6.1.7601.24441
.
Cause
The preceding issue is caused by system vulnerability CVE-2019-0708. Microsoft fixed this vulnerability on May 14, 2019.
Solution
Update the operating system (OS).
Automatically update the OS with Windows Update
Use Windows Update to update the OS to the latest version.
Use Workbench to connect to the Windows ECS instance over RDP.
Modify the Windows Server Update Services (WSUS) address in the registry.
Click Start, select Run, and then enter regedit.
Go to the
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate
path and change the values of theWUServer
andWUStatusServer
keys tohttp://update.cloud.aliyuncs.com
.
Choose Start > Control Panel > System and Security > Windows Update.
After Windows Update scans for updates, click Install updates.
After all updates are installed, restart Windows.
Manually update the OS
Use Workbench to connect to the Windows ECS instance over RDP.
Download the cumulative security patch KB4499164 or security-only update patch KB4499175.
Double-click the patch installation file.
Restart Windows.
Update the OS with common commands
Log on to the ECS console.
In the left-side navigation pane, choose .
On the Common Commands tab, find the
ACS-ECS-ApplySecurityPatches-for-windows.ps1
command and click Run.Select the Windows ECS instance whose OS you want to update and configure other parameters to update the OS.
For more information, see View and run common commands.
Check whether the preceding blue screen issue is resolved.
Check the installed patches.
After the OS is automatically or manually updated, open the Command Prompt window and run the
systeminfo
command to check the installed patches and confirm that the KB4499164 or KB4499175 patch is installed in the OS.Check the version of the
termdd.sys
file.Confirm that the version of the
termdd.sys (C:\Windows\System32\drivers\termdd.sys)
file is6.1.7601.24441
or later.
If the KB4499164 or KB4499175 patch is installed in the OS and the version of the
termdd.sys
file is6.1.7601.24441
or later, the blue screen issue has been resolved.