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:Troubleshoot downtime on Windows instances

Last Updated:Aug 21, 2025

If a Windows Elastic Compute Service (ECS) instance experiences issues such as kernel panics, out-of-memory (OOM) errors, or blue screen freezes, or if you receive a system event notification that the operating system has crashed, the instance is considered down. You can use the self-service diagnostics tool or system events to identify and resolve the cause.

Identify the cause of downtime

You can use the following methods to identify the specific cause of downtime for an ECS instance.

Method 1: (Recommended) Use the self-service diagnostics tool

  1. Go to ECS console - Troubleshooting.

  2. In the top navigation bar, select the region and resource group of the resource that you want to manage. 地域

  3. On the Instance Troubleshooting tab, choose Instance Connection Errors or Startup Exceptions > Instance Downtime. Then, select the ID of the instance that is down and click Start.

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  4. Identify and resolve the issue based on the diagnostic result and the proposed solution. For more information, see Common causes and solutions for downtime.

Method 2: Use system events

  1. Go to ECS console - Events.

  2. In the navigation pane on the left, click Unexpected O&M Events.

  3. Click Diagnose Operating System Issue next to the instance that is down.

    Identify and resolve the issue based on the diagnostic result and the proposed solution. For more information, see Common causes and solutions for downtime.

Common causes and solutions for downtime

The instance is down and returns error code 0000003b

The instance is down and returns error code 0000000a

The instance is down and returns error code 00000101

  • Problem description

    The instance is down and returns error code 00000101.

  • Cause

    The processor timed out when responding to a clock interrupt.

  • Solution

    Follow the steps in the Bug check 0x101: CLOCK_WATCHDOG_TIMEOUT document to troubleshoot the issue.

The instance is down and returns error code 00000133

  • Problem description

    The instance is down and returns error code 00000133.

  • Cause

    A system Deferred Procedure Call (DPC) timed out.

  • Solution

    Follow the steps in the Bug Check 0x133: DPC_WATCHDOG_VIOLATION document to troubleshoot the issue.

The instance is down and returns error code 000000ef

The instance is down and returns error code 00000050

The instance is down and returns error code 0000001e

The instance is down and returns error code 0000007e

The instance is down and returns error code 00000139

The instance is down and returns error code 0000013a

The instance is down and returns error code 00000135

The instance is down and returns error code 00000019

FAQ

Note

The following steps use Windows Server 2019 as an example. The steps for other Windows Server versions are similar.

How do I view the third-party software and drivers that are installed on an ECS instance?

  • Third-party software

    1. In the Windows operating system, open Control Panel.

    2. In Control Panel, choose Programs > Programs and Features.

    3. You can view the third-party software in the list.

      Note

      The publisher of third-party software is typically not Microsoft. Some third-party software may also display an icon in the system tray, where you can find the software and check its publisher.

  • Third-party drivers

    1. In the Windows operating system, open Device Manager.

    2. Expand each device category to view the installed third-party drivers.

How do I update system patches to the latest version?

  1. In the Windows operating system, open Windows Update settings.

  2. On the Windows Update tab of the Update & Security page, click Check for updates.

    The system automatically checks for and lists available system patches.

  3. Click Install to install the latest system patches.