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:Abnormal network connectivity due to network configuration faults

Last Updated:Oct 31, 2025

Problem description

Network connectivity is abnormal due to a network configuration fault.

Causes

This issue can be caused by the following:

  • IP configuration fault: The client is not configured to obtain an IP address automatically.

  • Protocol issue: The IPv4 protocol is uninstalled or not enabled.

  • Abnormal network component: A network component is configured incorrectly.

Solutions

Method 1: Check and configure network settings

  1. In the lower-left corner of the desktop, click the image icon.

  2. Enter Control Panel, and then click Control Panel in the window that appears.

  3. In Control Panel, select Network and Internet > Network and Sharing Center, and then click Ethernet.

  4. In the Ethernet Status window, click Details and confirm that DHCP is enabled.

  5. In the Ethernet Status window, click Properties. Select Internet Protocol Version 4 (TCP/IPv4), click Properties again, and then select Obtain an IP address automatically.

Method 2: Address an uninstalled or disabled IPv4 protocol

Solution A: Manually add the protocol through Network Connections

  1. Press Win+R, enter ncpa.cpl, and then press Enter.

  2. Right-click the network adapter you are using and select Properties.

  3. Click Install..., select Protocol, and then click Add....

  4. In the list, find and select Internet Protocol Version 4 (TCP/IPv4), and then click OK to complete the installation.

  5. Close the window and test whether network connection is restored.

Solution B: Reset the network

  1. On the taskbar, click the Start button, and then select Settings.

  2. Select Network & Internet, click the Status tab on the left, and then find and click Network Reset.

  3. On the Network Reset page, click the Reset Now button, and then select Yes in the confirmation window that appears.

    Your computer will restart automatically. You will need to reconnect to the network after the restart. For Wi-Fi networks, you may need to re-enter the password.

Solution C: Enable the protocol

  1. Press Win+R, enter ncpa.cpl, and then press Enter.

  2. Right-click the network adapter you are using and select Properties.

  3. In the list, select the Internet Protocol Version 4 (TCP/IPv4) checkbox, and then click OK.