All Products
Search
Document Center

:How to fix known software defects in Linux

Last Updated:Jun 21, 2026

This topic describes how to upgrade software packages on a Linux ECS instance to resolve issues caused by known software defects in the operating system.

Scenarios

If services on your Linux ECS instance behave unexpectedly, the cause might be a software defect in an outdated operating system. You can often resolve these issues by upgrading the software packages.

The following are known software defects:

Fixing issues by upgrading software

Port conflict on CentOS or RHEL 7

Symptoms

On some CentOS or Red Hat Enterprise Linux (RHEL) 7 instances, a service or process fails to start due to a port conflict, rendering it unavailable. Checking port usage with the netstat command shows that the port is occupied by the dhclient process, as shown in the following output:

[xxx@xxx ~]# netstat -lnput |grep dhc
udp        0      0 0.0.0.0:24399           0.0.0.0:*                          10994/dhclient
udp        0      0 0.0.0.0:68              0.0.0.0:*                          10994/dhclient
udp6       0      0 :::21027                :::*                               10994/dhclient

Cause

Under normal conditions, the ISC DHCP client (dhclient) service uses port 67/68 for DHCPv4 or port 546/547 for DHCPv6. On some ECS instances that run specific versions of CentOS or RHEL 7, the pre-installed dhclient version is earlier than 4.2.5-60. These earlier versions have a software defect that causes dhclient to occupy non-standard ports. If another service or process on the instance attempts to use one of these ports, a port conflict occurs, which prevents your service or process from starting.

Solution

Follow the instructions in Upgrade specific software packages or Upgrade all software packages to update the dhclient software package on your CentOS or RHEL 7 system.

Slow SSH connections on CentOS or RHEL 7

Symptoms

You may experience slow SSH remote connections to long-running ECS instances that run CentOS or RHEL 7. Checking the system process CPU usage may show that the systemd-logind process is consuming 100% of the CPU. The system log contains entries similar to the following:

# journalctl -u dbus
Mar 30 17:23:19 localhost dbus[21]: [system] Activating via systemd: service name='org.freedesktop.login1' unit='dbus-org.freedesk...
Mar 30 17:23:42 localhost dbus[21]: [system] Failed to activate service 'org.freedesktop.login1': timed out...

Cause

Known defects in the systemd-logind and D-Bus components cause this issue. To resolve it, update these components, especially the D-Bus component.

Solution

Follow the instructions in Upgrade specific software packages or Upgrade all software packages to update the dbus software package on your CentOS or RHEL 7 system.

Note

We recommend updating the D-Bus component to the latest version on all Linux systems.

  • For openSUSE and SUSE Linux Enterprise Server, the software package is dbus-1.

  • For other Linux distributions, the software package is dbus.

Upgrade software packages

If a known software defect in the Linux operating system is causing issues on your ECS instance, upgrade the affected components to resolve the problem. You can choose to upgrade specific software packages or upgrade all software packages. The following instructions use dhclient as an example.

Upgrade specific software packages

  1. Connect to your Linux instance remotely. For more information, see Connection methods.

  2. Run the command appropriate for your operating system to upgrade a specific software package.

    The command varies by operating system:

    • Alibaba Cloud Linux 2.1903, AnolisOS 7, CentOS 7 and earlier, Red Hat Enterprise Linux 7 and earlier:

      sudo yum update <package_name>
    • AlmaLinux, AnolisOS 8 and later, CentOS 8 and later, CentOS Stream 8 and later, Fedora 33 and later, Red Hat Enterprise Linux 8 and later, Rocky Linux:

      sudo dnf update <package_name>
    • Debian and Ubuntu:

      # First, update local software repository metadata to get the latest package information.
      sudo apt update
      # Then, upgrade the specified software package to the latest version.
      sudo apt upgrade <package_name>
    • openSUSE and SUSE Linux Enterprise Server:

      # First, update local software repository metadata to get the latest package information.
      sudo zypper refresh
      # Then, upgrade the specified software package to the latest version.
      sudo zypper update <package_name>

Upgrade all software packages

  1. Connect to your Linux instance remotely. For more information, see Connection methods.

  2. Run the command appropriate for your operating system to upgrade all installed software packages.

    • Alibaba Cloud Linux 2.1903, AnolisOS 7, CentOS 7 and earlier, Red Hat Enterprise Linux 7 and earlier:

      sudo yum update
    • AlmaLinux, AnolisOS 8 and later, CentOS 8 and later, CentOS Stream 8 and later, Fedora 33 and later, Red Hat Enterprise Linux 8 and later, Rocky Linux:

      sudo dnf update
    • Debian and Ubuntu:

      # First, update local software repository metadata to get the latest package information.
      sudo apt update
      # Then, upgrade all installed software packages to their latest versions.
      sudo apt upgrade
    • openSUSE and SUSE Linux Enterprise Server:

      # First, update local software repository metadata to get the latest package information.
      sudo zypper refresh
      # Then, upgrade all installed software packages to their latest versions.
      sudo zypper update