Insufficient data for an Auto Scaling alarm task

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This topic describes how to resolve the issue when an alarm task in the Auto Scaling console shows a status of "Insufficient Data".

Problem

After you create an alarm task (system) in the Auto Scaling console, its alarm Status shows Insufficient Data. The details are as follows:

On the Event-triggered Tasks (System) tab, two alarm tasks are listed. Their trigger conditions are (ECS) CPU utilization Average >= 90% for 3 consecutive periods and (ECS) CPU utilization Average < 72% for 15 consecutive periods, respectively. The period for both tasks is 1 minute and they are active all day. The status column displays Insufficient Data.

Cause

Auto Scaling alarm tasks depend on data from CloudMonitor. This issue occurs because CloudMonitor has not collected the required data from the associated ECS instances.

Solution

  1. Log in to the ECS console.

  2. In the left-side navigation pane, choose Deployment & Elasticity > Auto Scaling.

  3. On the Scaling Groups page, find the target scaling group and click its ID.

  4. Click the Instances tab to view and record the IDs of the ECS instances.

    This topic uses the ECS instances on the Auto Create tab as an example.

  5. Log on to the CloudMonitor console.

  6. In the left-side navigation pane, click Host Monitoring.

  7. In the search box, enter the ID of an ECS instance to check whether the CloudMonitor agent is installed.

    In the argusagent status column, click the filter icon, select Stopped/Not Installed, and then click OK.

    • If the argusagent status column displays the 图标3.jpg icon, the CloudMonitor agent is not installed. Click the 图标1.jpg or 图标2.jpg icon to install the agent automatically or manually. For more information, see Install the CloudMonitor agent.

    • If the argusagent status is Running but you see no monitoring data in the charts, proceed to the next step.

  8. Check whether the CloudMonitor agent is healthy.

    For more information, see View the status of the CloudMonitor agent.

    Note

    If the CloudMonitor agent is abnormal, restart it. For more information, see Restart the CloudMonitor agent for C++.

  9. Verify that the status of the alarm task in the Auto Scaling console is normal.