This topic provides answers to some frequently asked questions about real-time data synchronization to Hologres.
-
What do I do if the connectivity test fails for a PolarDB data source?
-
What do I do if the connectivity test fails for an Oracle data source?
-
What do I do if the connectivity test fails for a MySQL data source?
What do I do if the connectivity test fails for a PolarDB data source?
- Symptom: The network connectivity test fails when you add a PolarDB data source.
- Solution: Switch to the JDBC connection string. Check the whitelist and the VPC configuration for the exclusive resource group.
What do I do if the connectivity test fails for an Oracle data source?
- Symptom: The network connectivity test fails when you add an Oracle data source.
- Solution: Switch to the JDBC connection string. Check the whitelist and the VPC configuration for the exclusive resource group.
What do I do if the connectivity test fails for a MySQL data source?
- Symptom: The network connectivity test fails when you add a MySQL data source.
- Solution: Switch to the JDBC connection string. Check the whitelist and the VPC configuration for the exclusive resource group.
The system displays the following error message for a real-time data synchronization node: com.alibaba.otter.canal.parse.exception.PositionNotFoundException: can't find start position for XXX. What do I do?
- Error message: When a data synchronization task runs, the real-time task fails with the error message
com.alibaba.otter.canal.parse.exception.PositionNotFoundException: can't find start position for XXX. - Cause: Binary logging (binlog) is not enabled for the source PolarDB data source.
-
Solution: Enable the binary logging feature for the PolarDB data source. For more information, see Configure a PolarDB data source. Change one or more data records and change the start time to run the real-time data synchronization node to the current time.
The system displays the following error message for a real-time data synchronization node: com.alibaba.otter.canal.parse.exception.CanalParseException: command : 'show master status' has an error! pls check. you need (at least one of) the SUPER,REPLICATION CLIENT privilege(s) for this operation. What do I do?
- Error message: When a data synchronization task runs, the real-time task fails with the error message
com.alibaba.otter.canal.parse.exception.CanalParseException: command : 'show master status' has an error! pls check. you need (at least one of) the SUPER,REPLICATION CLIENT privilege(s) for this operation. - Cause: The account used for data synchronization does not have the required permissions on the source PolarDB data source, or the connected PolarDB database is not the primary node.
-
Solution: Refer to the operations in Configure a PolarDB data source to authorize the account to access the PolarDB data source. Alternatively, check whether the PolarDB database connected is deployed on the primary node. During the running of a real-time data synchronization node, the system cannot capture data from the read-only nodes of the PolarDB cluster.
The system displays the following error message for a real-time data synchronization node: com.alibaba.datax.plugin.reader.mysqlbinlogreader.MysqlBinlogReaderException: The mysql server does not enable the binlog write function. Please enable the mysql binlog write function first. What do I do?
- Error message: When a data synchronization task runs, the real-time task fails with the error message
com.alibaba.datax.plugin.reader.mysqlbinlogreader.MysqlBinlogReaderException: The mysql server does not enable the binlog write function. Please enable the mysql binlog write function first. - Cause: The `loose_polar_log_bin` parameter is not enabled for the source PolarDB data source.
-
Solution: Specify the loose_polar_log_bin parameter. For more information, see Configure a PolarDB data source.