Enables the health check feature for a virtual border router (VBR) to detect faults on physical Express Connect circuits in a timely manner. You can also use this operation to modify the health check configuration of a VBR.
Operation description
You can configure health checks for a VBR instance to monitor the connectivity of the physical Express Connect circuit between your on-premises data center and Alibaba Cloud, so that issues can be detected promptly.
Before using the health check feature, note the following information:
-
If your VBR instance uses static routing, after you configure the health check, you must add a static route entry in the on-premises data center connected to the VBR instance. The destination CIDR block of the static route is the source IP address of the health check with a 32-bit subnet mask, and the next hop is the Alibaba Cloud-side IP address of the VBR instance.
-
If your border router instance uses the BGP dynamic routing protocol, you do not need to add a route entry in the on-premises data center.
-
The EnableCenVbrHealthCheck operation is asynchronous. After you send a request, the system returns a RequestId, but the health check instance is not yet created or modified. The creation or modification task continues to run in the background. You can call the DescribeCenVbrHealthCheck operation to query the health check configuration. If the health check configuration is returned, the health check has been created or modified.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
cen:EnableCenVbrHealthCheck |
update |
*CenInstance
*virtualborderrouter
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| CenId |
string |
Yes |
The Cloud Enterprise Network (CEN) instance ID. |
cen-hahhfskfkseig**** |
| VbrInstanceRegionId |
string |
Yes |
The region ID of the VBR instance. You can call the DescribeChildInstanceRegions operation to query region IDs. |
cn-shenzhen |
| VbrInstanceId |
string |
Yes |
The VBR instance ID. |
vbr-wz95o9aylj181n5mzk**** |
| HealthCheckSourceIp |
string |
No |
The source IP address for health checks. The following configuration methods are supported:
|
192.XX.XX.1 |
| HealthCheckTargetIp |
string |
Yes |
The destination IP address for health checks. The destination IP address is the customer-side IP address of the VBR instance. |
10.XX.XX.1 |
| VbrInstanceOwnerId |
integer |
No |
The ID of the Alibaba Cloud account that owns the VBR instance. Note
This parameter is required if the VBR instance and the CEN instance belong to different accounts. |
1250123456123456 |
| HealthCheckInterval |
integer |
No |
The interval at which health check probe packets are sent. Unit: seconds. Default value: 2. Valid values: 2 to 3. |
2 |
| HealthyThreshold |
integer |
No |
The number of probe packets sent during a health check. Unit: packets. Valid values: 3 to 8. Default value: 8. |
8 |
| HealthCheckOnly |
boolean |
No |
Specifies whether to enable only the health check detection feature. Valid values:
|
false |
| Description |
string |
No |
The description. The description must be 1 to 256 characters in length and cannot start with |
testdesc |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
The response parameters. |
||
| RequestId |
string |
The request ID. |
1F59F19C-EFD2-40B1-94D5-65B40CA8E34A |
Examples
Success response
JSON format
{
"RequestId": "1F59F19C-EFD2-40B1-94D5-65B40CA8E34A"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | RouteConflict | The specified route already exists. | The specified route already exists. |
| 400 | Illegal.SourceIpOrTargetIp | The specified source IP address or destination IP address is invalid. | The error message returned because the specified source or destination IP address is invalid. |
| 400 | OperationFailed.StatusNotSupport | The VBR or VPC instance to CBN attachment is not in a valid state for the operation. | The error message returned because the status of the VBR or VPC does not support this operation. Try again later. |
| 400 | OperationFailed.SourceIpUnSupported | The specified source IP address is unsupported. | The error message returned because the specified source IP address is not supported. Enter a valid IP address and try again. |
| 400 | InvalidStatus.HealthCheck | Can not modify, please delete health check config first. | You must delete the health check configurations before you can make the modifications. |
| 400 | OperationFailed.IpAddressExhausted | No IP addresses are available for allocation. | The operation failed because no IP addresses can be allocated. |
| 400 | InvalidParameter | Invalid parameter. | The error message returned because the parameter is set to an invalid value. |
| 400 | Unauthorized | The AccessKeyId is unauthorized. | The error message returned because you do not have the permissions to perform this operation. |
| 400 | InvalidParameter.CenId | The specified parameter CenId is invalid. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.