ApsaraDB for HBase Performance-enhanced Edition supports HBase-1.x and HBase-2.x clients. This topic describes how to install the SDK for Java.

You can replace the HBase dependencies with the HBase clients released by Alibaba Cloud. Alibaba Cloud provides HBase client version 1.x and version 2.x. Choose a version based on your HBase dependencies. We recommend that you use the HBase client version 2.x.

ApsaraDB for HBase version 2.x

<dependency>
    <groupId>com.aliyun.hbase</groupId>
    <artifactId>alihbase-client</artifactId>
    <version>2.0.6</version>
</dependency>

ApsaraDB for HBase version 1.x

<dependency>
    <groupId>com.aliyun.hbase</groupId>
    <artifactId>alihbase-client</artifactId>
    <version>1.1.1</version>
</dependency>

Plug-ins used to connect to ApsaraDB for HBase Performance-enhanced Edition

We recommend that you use the HBase clients provided by Alibaba Cloud to connect to ApsaraDB for HBase Performance-enhanced Edition. If you are unable to replace the existing HBase dependency, you can use a plug-in provided by Alibaba Cloud. For example, the HBase client already exists in the third-party database that you use and cannot be changed. There are two versions of the alihbase-connector plug-ins. The alihbase-connector version 1.x corresponds to the ApsaraDB for HBase client version 1.x. The alihbase-connector version 2.x corresponds to the ApsaraDB for HBase client version 2.x

The plug-in for the ApsaraDB for HBase client version 1.x

<dependency>
    <groupId>com.alibaba.hbase</groupId>
    <artifactId>alihbase-connector</artifactId>
    <version>1.0.11</version>
</dependency>

The plug-in for the ApsaraDB for HBase client version 2.x

<dependency>
    <groupId>com.alibaba.hbase</groupId>
    <artifactId>alihbase-connector</artifactId>
    <version>2.0.11</version>
</dependency>

If your application does not support Maven dependencies, you can download the following alihbase-connector JAR files to the libs directory.

  • Click here to download the alihbase-connector JAR file of version 1.x.
  • Click here to download the alihbase-connector JAR file of version 2.x.

Afterward, you can use the Java API to connect to ApsaraDB for HBase. For more information, see Use the Java API to access ApsaraDB for HBase.