全部产品
Search
文档中心

云数据库 RDS:DescribeSlowLogs - 查看慢日志统计情况

更新时间:Aug 28, 2026

该接口用于查询慢日志统计情况。

接口说明

适用引擎

  • RDS MySQL
    说明

    MySQL 5.7 基础版暂不支持。

  • RDS SQL Server
    说明

    仅支持 SQL Server 2008 R2 版本。

  • RDS MariaDB

注意事项

  • 慢日志统计非实时采集,可能会有 6~8 小时的延迟。

  • 如果返回结果为空,请检查 StartTime 和 EndTime 配置是否符合 UTC 格式要求,如果满足,则表示该时间段内无慢日志。

  • 2024 年 09 月 01 日起,由于 SQL 的模板化算法优化,调用本接口时,SQLHash 字段的值将发生变更。详情请参见【通知】SQL 模板化算法优化

调试

您可以在OpenAPI Explorer中直接运行该接口,免去您计算签名的困扰。运行成功后,OpenAPI Explorer可以自动生成SDK代码示例。

调试

授权信息

下表是API对应的授权信息,可以在RAM权限策略语句的Action元素中使用,用来给RAM用户或RAM角色授予调用此API的权限。具体说明如下:

  • 操作:是指具体的权限点。

  • 访问级别:是指每个操作的访问级别,取值为写入(Write)、读取(Read)或列出(List)。

  • 资源类型:是指操作中支持授权的资源类型。具体说明如下:

    • 对于必选的资源类型,用前面加 * 表示。

    • 对于不支持资源级授权的操作,用全部资源表示。

  • 条件关键字:是指云产品自身定义的条件关键字。

  • 关联操作:是指成功执行操作所需要的其他权限。操作者必须同时具备关联操作的权限,操作才能成功。

操作

访问级别

资源类型

条件关键字

关联操作

rds:DescribeSlowLogs

get

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

  • rds:ResourceTag
  • rds:ResourceTag
  • rds:ResourceTag
  • rds:ResourceTag

请求参数

名称

类型

必填

描述

示例值

DBInstanceId

string

实例 ID。可调用 DescribeDBInstances 获取。

rm-uf6wjk5****

StartTime

string

查询开始日期,格式:yyyy-MM-ddZ(UTC 时间)。

2011-05-01Z

EndTime

string

查询结束日期,不能小于查询开始日期,与查询开始日期间隔不超过 31 天。格式:yyyy-MM-ddZ(UTC 时间)。

说明

当查询结束日期与查询开始日期相同时,默认从查询开始日期的 08:00 开始,最多查询 24 小时的慢日志统计情况。

2011-05-30Z

DBName

string

数据库名称。

RDS_MySQL

SortKey

string

排序依据,取值:

  • TotalExecutionCounts:总执行次数最多

  • TotalQueryTimes:总执行时间最多

  • TotalLogicalReads:总逻辑读最多

  • TotalPhysicalReads:总物理读最多

说明

仅 SQL Server 2008 R2 实例支持本参数。

TotalExecutionCounts

PageSize

integer

每页记录数,取值:30~100。默认值:30

30

PageNumber

integer

页码,取值:大于 0 且不超过 Integer 的最大值。

默认值:1

1

返回参数

名称

类型

描述

示例值

object

返回参数详情。

DBInstanceId

string

实例 ID。

rm-uf6wjk5****

EndTime

string

查询结束日期。

2011-05-30Z

Engine

string

数据库类型。

SQLServer

Items

object

SQLSlowLog

array<object>

慢日志信息列表。

object

慢日志信息详情。

AvgExecutionTime

integer

执行时间(平均值),单位:秒。

说明

仅 SQL Server 实例支持返回该参数。

1

AvgIOWriteCounts

integer

I/O 写次数(平均值)。

说明

仅 SQL Server 实例支持返回该参数。

0

AvgLastRowsAffectedCounts

integer

最后一次受影响的行数(平均值)。

说明

仅 SQL Server 实例支持返回该参数。

0

AvgLogicalReadCounts

integer

逻辑读次数(平均值)。

说明

仅 SQL Server 实例支持返回该参数。

0

AvgPhysicalReadCounts

integer

物理读次数(平均值)。

说明

仅 SQL Server 实例支持返回该参数。

0

AvgRowsAffectedCounts

integer

受影响的行数(平均值)。

说明

仅 SQL Server 实例支持返回该参数。

0

CreateTime

string

数据生成日期。

2011-05-30Z

DBName

string

数据库名称。

ceshi

MaxExecutionTime

integer

执行时长(最大值),单位:秒。

60

MaxExecutionTimeMS

integer

执行时长(最大值),单位:毫秒。

60000

MaxIOWriteCounts

integer

I/O 写次数(最大值)。

说明

仅 SQL Server 实例支持返回该参数。

0

MaxLastRowsAffectedCounts

integer

最后一次受影响的行数(最大值)。

说明

仅 SQL Server 实例支持返回该参数。

0

MaxLockTime

integer

锁定时长(最大值),单位:秒。

0

MaxLockTimeMS

integer

锁定时长(最大值),单位:毫秒。

1000

MaxLogicalReadCounts

integer

逻辑读次数(最大值)。

说明

仅 SQL Server 实例支持返回该参数。

0

MaxPhysicalReadCounts

integer

物理读次数(最大值)。

说明

仅 SQL Server 实例支持返回该参数。

0

MaxRowsAffectedCounts

integer

受影响的行数(最大值)。

说明

仅 SQL Server 实例支持返回该参数。

0

MinIOWriteCounts

integer

I/O 写次数(最小值)。

说明

仅 SQL Server 实例支持返回该参数。

0

MinLastRowsAffectedCounts

integer

最后一次受影响的行数(最小值)。

说明

仅 SQL Server 实例支持返回该参数。

0

MinLogicalReadCounts

integer

逻辑读次数(最小值)。

说明

仅 SQL Server 实例支持返回该参数。

0

MinPhysicalReadCounts

integer

物理读次数(最小值)。

说明

仅 SQL Server 实例支持返回该参数。

0

MinRowsAffectedCounts

integer

受影响的行数(最小值)。

说明

仅 SQL Server 实例支持返回该参数。

0

MySQLTotalExecutionCounts

integer

MySQL 执行次数(总值)。

1

MySQLTotalExecutionTimes

integer

MySQL 执行时长(总值),单位:秒。

1

ParseMaxRowCount

integer

解析的 SQL 行数(最大值)。

1

ParseTotalRowCounts

integer

解析的 SQL 行数(总值)。

1

ReportTime

string

数据报表生成日期。

2011-05-30Z

ReturnMaxRowCount

integer

返回的 SQL 行数(最大值)。

1

ReturnTotalRowCounts

integer

返回的 SQL 行数(总值)。

1

SQLHASH

string

慢日志统计里的 SQL 语句唯一标识符,可用于获取该 SQL 语句的慢日志明细。

U2FsdGVk****

SQLIdStr

string

对应的是慢日志统计模版 SQL 的 ID,现已废弃,请使用 SQLHASH

521584

SQLServerAvgCpuTime

integer

CPU 查询时间(平均值),单位:毫秒。

说明

仅 SQL Server 实例支持返回该参数。

0

SQLServerAvgExecutionTime

integer

执行时间(平均值),单位:毫秒。

说明

仅 SQL Server 实例支持返回该参数。

0

SQLServerMaxCpuTime

integer

CPU 查询时间(最大值),单位:毫秒。

说明

仅 SQL Server 实例支持返回该参数。

0

SQLServerMinCpuTime

integer

CPU 查询时间(最小值),单位:毫秒。

说明

仅 SQL Server 实例支持返回该参数。

0

SQLServerMinExecutionTime

integer

执行时间(最小值),单位:毫秒。

说明

仅 SQL Server 实例支持返回该参数。

0

SQLServerTotalCpuTime

integer

CPU 查询时间(总值),单位:毫秒。

说明

仅 SQL Server 实例支持返回该参数。

0

SQLServerTotalExecutionCounts

integer

SQL Server 执行次数(总值)。

1

SQLServerTotalExecutionTimes

integer

SQL Server 执行时长(总值),单位:毫秒。

1000

SQLText

string

SQL 语句。

select id,name from tb_table

SlowLogId

integer

慢查询汇总标识 ID。

26584213

TotalIOWriteCounts

integer

I/O 写次数(总值)。

说明

仅 SQL Server 实例支持返回该参数。

0

TotalLastRowsAffectedCounts

integer

最后一次受影响的行数(总值)。

说明

仅 SQL Server 实例支持返回该参数。

0

TotalLockTimes

integer

锁定时长(总值),单位:秒。

0

TotalLogicalReadCounts

integer

逻辑读次数(总值)。

1

TotalPhysicalReadCounts

integer

物理读次数(总值)。

1

TotalRowsAffectedCounts

integer

影响的行数(总值)。

0

PageNumber

integer

页码。

1

PageRecordCount

integer

本页 SQL 语句个数。

10

RequestId

string

请求 ID。

2553A660-E4EB-4AF4-A402-8AFF70A49143

StartTime

string

查询开始日期。

2011-05-01Z

TotalRecordCount

integer

总记录数。

5

示例

正常返回示例

JSON格式

{
  "DBInstanceId": "rm-uf6wjk5****",
  "EndTime": "2011-05-30Z",
  "Engine": "SQLServer",
  "Items": {
    "SQLSlowLog": [
      {
        "AvgExecutionTime": 1,
        "AvgIOWriteCounts": 0,
        "AvgLastRowsAffectedCounts": 0,
        "AvgLogicalReadCounts": 0,
        "AvgPhysicalReadCounts": 0,
        "AvgRowsAffectedCounts": 0,
        "CreateTime": "2011-05-30Z",
        "DBName": "ceshi",
        "MaxExecutionTime": 60,
        "MaxExecutionTimeMS": 60000,
        "MaxIOWriteCounts": 0,
        "MaxLastRowsAffectedCounts": 0,
        "MaxLockTime": 0,
        "MaxLockTimeMS": 1000,
        "MaxLogicalReadCounts": 0,
        "MaxPhysicalReadCounts": 0,
        "MaxRowsAffectedCounts": 0,
        "MinIOWriteCounts": 0,
        "MinLastRowsAffectedCounts": 0,
        "MinLogicalReadCounts": 0,
        "MinPhysicalReadCounts": 0,
        "MinRowsAffectedCounts": 0,
        "MySQLTotalExecutionCounts": 1,
        "MySQLTotalExecutionTimes": 1,
        "ParseMaxRowCount": 1,
        "ParseTotalRowCounts": 1,
        "ReportTime": "2011-05-30Z",
        "ReturnMaxRowCount": 1,
        "ReturnTotalRowCounts": 1,
        "SQLHASH": "U2FsdGVk****",
        "SQLIdStr": "521584",
        "SQLServerAvgCpuTime": 0,
        "SQLServerAvgExecutionTime": 0,
        "SQLServerMaxCpuTime": 0,
        "SQLServerMinCpuTime": 0,
        "SQLServerMinExecutionTime": 0,
        "SQLServerTotalCpuTime": 0,
        "SQLServerTotalExecutionCounts": 1,
        "SQLServerTotalExecutionTimes": 1000,
        "SQLText": "select id,name from tb_table",
        "SlowLogId": 26584213,
        "TotalIOWriteCounts": 0,
        "TotalLastRowsAffectedCounts": 0,
        "TotalLockTimes": 0,
        "TotalLogicalReadCounts": 1,
        "TotalPhysicalReadCounts": 1,
        "TotalRowsAffectedCounts": 0
      }
    ]
  },
  "PageNumber": 1,
  "PageRecordCount": 10,
  "RequestId": "2553A660-E4EB-4AF4-A402-8AFF70A49143",
  "StartTime": "2011-05-01Z",
  "TotalRecordCount": 5
}

错误码

HTTP status code

错误码

错误信息

描述

400 InvalidSearchTimeRange search time range cannot be longer than a month. 查询结束时间(参数名称:EndTime)与查询开始时间(参数名称:StartTime)的间隔应小于31天,请输入正确的相关参数。
400 IO.Exception IO exception, retry later. io异常。
400 SortKey.ValueNotSupported SortKey.ValueNotSupported
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. 套餐实例不允许单独操作。
400 Price.PricingPlanResultNotFound Pricing plan price result not found. 定价计划价格结果没有找到。
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. 您还未通过实名认证,不符合购买条件,请登录费用与成本进行实名认证。
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. 您的账户可用额度小于0,请先充值后再尝试购买。
400 CommodityServiceCalling.Exception Failed to call commodity service. 调用商品服务返回失败。
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. 客户您好,阿里云计划对当前地域进行优化调整,该区域云服务将停止运营,为确保您的业务连续性及数据迁移工作的平稳过渡,您目前无法操作新购类型的订单,感谢理解与支持。
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. 您购买的模块不合法,请重新购买。
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. 客户您好,该地域已裁撤。
400 Price.CommoditySys Commodity system call exception. 商品系统调用异常。
400 Pay.InsufficientBalance Insufficient available balance. 可用金不足。
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. 您选购的周期有问题,请重新选购。
400 pay.noCreditCard Account not bound to credit card. 账户未绑定信用卡。
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. 您选购的服务存在未支付订单,请支付或作废后再下单。
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. 没有为您的账户指定付款方式。我们建议您添加一种付款方式。
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. 您的基本信息未完善,请在操作前先完善您的基本信息。
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. 您的账户出现异常,详情请联系客服。
400 Api.NotSupport Specified api is not supported. 当前接口不支持。
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. 存在禁止下单的标签,请联系您的分销商处理
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. 提供的DBInstanceId不存在。
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type 当前实例规格不支持该存储类型。
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. 指定的 wal_level 参数无效。实例中仍然存在复制槽,因此无法将其设置为replica。
400 KmsApiError User secret key invalid. 用户密钥失效。
400 System.SaleValidateFailed Sales expression validation system error. 销售表达式校验系统错误。
400 Abs.InvalidAccount.NotFound account is not found. 账户不存在。
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. sql命令执行失败或执行超时
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. 当前实例引擎版本不支持归档冷数据。
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. 当前内核版本不支持归档冷数据。
400 IncorrectTargetClasscode The current instance type does not support this operation. 当前规格不支持此操作。
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. 链接地址名重复,请重新设置连接字符串。
400 RequiredParam.NotFound Required input param is not found. 没有传入必要的参数。
400 Parameters.Invalid Parameter error, please check the parameters. 参数错误,请检查参数。
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. 数据归档不支持跨地域备份和秒级快照,请检查备份策略。
400 InvalideStatus.Format The instance status does not support this operation. 实例状态不支持此操作。
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. 实例释放后的归档备份保留策略无效。
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. DB实例引擎类型不支持此操作。
400 Pay.NoCreditCard No credit cards. 无信用卡。
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. vpc网络类型实例不支持此操作。
400 MirrorInsExists Specified DB instance mirror ins already existed. 当前数据库实例镜像已存在。
400 UnsupportedClassCode The specified DB instance class stops selling. 实例规格停止售卖。
400 InvalidBackupSet The specified database does not exist in the backup set. 备份集中没有指定的数据库。
400 OrdTCommodityQueryError Failed to query for product. 查询产品失败。
400 ProductInstanceReleased The instance has been released. Please check before placing the order. 实例已释放,请核实后下单。
400 RegionEndTimeDissolvedIndia The region is no longer supported. 指定的地域无效。
500 ExternalFailure The request processing has failed due to external service failure. 请求服务失败,请稍后重试。
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. 请求服务失败,请稍后再试或联系服务人员。
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. 由于rds api服务失败,请求处理失败。
403 OrderStatus.UnPaid The specified db instance has unpaid order. 实例当前存在未支付订单,请支付后重试。
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. 缩容目标容量不能小于当前存储空间使用量
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd. SSD盘不支持此操作,请升级至ESSD。
403 InvalidUserOperatorPermission The user permission does not support this operation. 用户权限不支持此操作。
403 InvalidVswitchId Specified conn vswitch id is not valid. 指定的VSwitchId格式不正确或为空
403 IncorrectMinorVersion Current engine minor version does not support operations. 当前引擎小版本不支持此操作。
403 OperationDenied.ZoneResource There is no available zone for inventory. 没有可用的库存区域。
403 NotInFlowController Sorry,no permission. 非集团上云用户不可用,无权限。
403 InvalidKmsKey Kms key is disabled. Kms key已禁用。
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. 当前数据库实例级别不支持此操作。
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. 当前实例未授权访问密钥管理服务。
404 Request.NotFound The requested resource is not available. 请求的资源不可用。
404 HostInfo.NotFound The specified host info is not found. 指定的主机信息不存在。
408 RequestTimeout Query timed out.Please try again or narrow down the query scope. 请求超时,请重试或缩小时间范围

访问错误中心查看更多错误码。

变更历史

更多信息,参考变更详情