全部产品
Search
文档中心

云数据库 RDS:ListUserBackupFiles - 查询用户备份信息

更新时间:Aug 27, 2026

该接口用于查询所有已导入至RDS的用户备份的详情。

接口说明

适用引擎

  • RDS MySQL

功能说明

调试

您可以在OpenAPI Explorer中直接运行该接口,免去您计算签名的困扰。运行成功后,OpenAPI Explorer可以自动生成SDK代码示例。

调试

授权信息

下表是API对应的授权信息,可以在RAM权限策略语句的Action元素中使用,用来给RAM用户或RAM角色授予调用此API的权限。具体说明如下:

  • 操作:是指具体的权限点。

  • 访问级别:是指每个操作的访问级别,取值为写入(Write)、读取(Read)或列出(List)。

  • 资源类型:是指操作中支持授权的资源类型。具体说明如下:

    • 对于必选的资源类型,用前面加 * 表示。

    • 对于不支持资源级授权的操作,用全部资源表示。

  • 条件关键字:是指云产品自身定义的条件关键字。

  • 关联操作:是指成功执行操作所需要的其他权限。操作者必须同时具备关联操作的权限,操作才能成功。

操作

访问级别

资源类型

条件关键字

关联操作

rds:ListUserBackupFiles

get

*全部资源

*

请求参数

名称

类型

必填

描述

示例值

Status

string

通过用户备份文件的状态查询目标用户备份。取值:

  • Importing:导入中。

  • Failed:导入失败。

  • CheckSuccess:校验通过。

  • BackupSuccess:导入成功。

  • Deleted:已删除。

CheckSuccess

RegionId

string

地域 ID。可调用 DescribeRegions 获取。

cn-hangzhou

Comment

string

通过备注信息查询目标用户备份。

说明

您可输入目标用户备份的部分备注信息进行模糊匹配。

BackupTest

BackupId

string

通过用户备份 ID 查询目标用户备份。

b-kwwvr7v8t7of****

OssUrl

string

通过用户备份文件的 OSS 下载地址查询目标用户备份。如何获取用户备份文件的 OSS 下载地址,请参见上传 Object 后如何获取访问 URL

https://****.oss-ap-****.aliyuncs.com/backup_qp.xb

Tags

string

通过标签信息查询目标用户备份。

key1:value1

ResourceGroupId

string

资源组 ID。可调用 DescribeDBInstanceAttribute 获取。

rg-acfmy****

返回参数

名称

类型

描述

示例值

object

返回参数详情。

Records

array<object>

用户备份文件详情列表。

object

用户备份文件详情。

BackupId

string

用户备份 ID。

b-kwwvr7v8t7of****

BinlogInfo

string

备份文件中的 Binlog 文件信息,备份过程中如有增量内容则会返回此参数。

{\"binlogPosition\":\"154\",\"binlogFile\":\"0.000002\"}

Comment

string

用户备份的备注信息。

BackupTest

CreationTime

string

用户备份的导入开始时间,格式为 Unix 时间戳。单位:毫秒。

1623231084000

Engine

string

数据库引擎。

mysql

EngineVersion

string

数据库版本。

5.7

FinishTime

string

用户备份成功导入的时间,格式为 Unix 时间戳。单位:毫秒。

1623231750000

ModificationTime

string

用户备份的导入完成时间,格式为 Unix 时间戳。单位:毫秒。

1623231750000

OssBucket

string

用户备份文件所在的 OSS Bucket 名称。

BackupTest

OssFileMetaData

string

用户备份文件元信息。更多信息,请参见管理文件元信息

{\"Accept-Ranges\":\"bytes\",\"Connection\":\"keep-alive\",\"Content-Length\":81014337,\"Content-Type\":\"application/octet-stream\",\"Date\":1623309548000,\"ETag\":\"889FE9E5FCEBFE4781829488A352863B-1\",\"Last-Modified\":1622186844000,\"Server\":\"AliyunOSS\",\"x-oss-hash-crc64ecma\":\"5793608435727323129\",\"x-oss-object-type\":\"Multipart\",\"x-oss-request-id\":\"60C1BCEC92572F37318BD499\",\"x-oss-server-time\":\"166\",\"x-oss-storage-class\":\"Standard\"}

OssFileName

string

OSS 中用户备份文件的文件名。

backup_qp.xb

OssFilePath

string

OSS 中用户备份文件的路径。

test/backup_qp.xb

OssFileSize

integer

OSS 中用户备份文件的大小。单位:KB。

79115

OssUrl

string

用户备份文件的 OSS 下载地址。

https://****.oss-ap-****.aliyuncs.com/backup_qp.xb

Reason

string

用户备份文件导入失败的原因。

success

RestoreSize

string

还原用户备份所需存储空间大小。单位:GB。

20

Retention

integer

用户备份文件保留时长。单位:天。

3

Status

string

用户备份文件状态。返回值:

  • Importing:导入中。

  • Failed:导入失败。

  • CheckSuccess:校验通过。

  • BackupSuccess:导入成功。

  • Deleted:已删除。

BackupSuccess

ZoneId

string

用户备份所在的可用区 ID。

cn-hangzhou-b

RequestId

string

请求 ID。

AD67C22F-64F3-4448-A9A8-D1606D242879

示例

正常返回示例

JSON格式

{
  "Records": [
    {
      "BackupId": "b-kwwvr7v8t7of****",
      "BinlogInfo": "{\\\"binlogPosition\\\":\\\"154\\\",\\\"binlogFile\\\":\\\"0.000002\\\"}",
      "Comment": "BackupTest",
      "CreationTime": "1623231084000",
      "Engine": "mysql",
      "EngineVersion": "5.7",
      "FinishTime": "1623231750000",
      "ModificationTime": "1623231750000",
      "OssBucket": "BackupTest",
      "OssFileMetaData": "{\\\"Accept-Ranges\\\":\\\"bytes\\\",\\\"Connection\\\":\\\"keep-alive\\\",\\\"Content-Length\\\":81014337,\\\"Content-Type\\\":\\\"application/octet-stream\\\",\\\"Date\\\":1623309548000,\\\"ETag\\\":\\\"889FE9E5FCEBFE4781829488A352863B-1\\\",\\\"Last-Modified\\\":1622186844000,\\\"Server\\\":\\\"AliyunOSS\\\",\\\"x-oss-hash-crc64ecma\\\":\\\"5793608435727323129\\\",\\\"x-oss-object-type\\\":\\\"Multipart\\\",\\\"x-oss-request-id\\\":\\\"60C1BCEC92572F37318BD499\\\",\\\"x-oss-server-time\\\":\\\"166\\\",\\\"x-oss-storage-class\\\":\\\"Standard\\\"}",
      "OssFileName": "backup_qp.xb",
      "OssFilePath": "test/backup_qp.xb",
      "OssFileSize": 79115,
      "OssUrl": "https://****.oss-ap-****.aliyuncs.com/backup_qp.xb",
      "Reason": "success",
      "RestoreSize": "20",
      "Retention": 3,
      "Status": "BackupSuccess",
      "ZoneId": "cn-hangzhou-b"
    }
  ],
  "RequestId": "AD67C22F-64F3-4448-A9A8-D1606D242879"
}

错误码

HTTP status code

错误码

错误信息

描述

400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. 套餐实例不允许单独操作。
400 Price.PricingPlanResultNotFound Pricing plan price result not found. 定价计划价格结果没有找到。
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. 您还未通过实名认证,不符合购买条件,请登录费用与成本进行实名认证。
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. 您的账户可用额度小于0,请先充值后再尝试购买。
400 CommodityServiceCalling.Exception Failed to call commodity service. 调用商品服务返回失败。
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. 客户您好,阿里云计划对当前地域进行优化调整,该区域云服务将停止运营,为确保您的业务连续性及数据迁移工作的平稳过渡,您目前无法操作新购类型的订单,感谢理解与支持。
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. 您购买的模块不合法,请重新购买。
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. 客户您好,该地域已裁撤。
400 Price.CommoditySys Commodity system call exception. 商品系统调用异常。
400 Pay.InsufficientBalance Insufficient available balance. 可用金不足。
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. 您选购的周期有问题,请重新选购。
400 pay.noCreditCard Account not bound to credit card. 账户未绑定信用卡。
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. 您选购的服务存在未支付订单,请支付或作废后再下单。
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. 没有为您的账户指定付款方式。我们建议您添加一种付款方式。
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. 您的基本信息未完善,请在操作前先完善您的基本信息。
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. 您的账户出现异常,详情请联系客服。
400 Api.NotSupport Specified api is not supported. 当前接口不支持。
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. 存在禁止下单的标签,请联系您的分销商处理
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. 提供的DBInstanceId不存在。
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type 当前实例规格不支持该存储类型。
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. 指定的 wal_level 参数无效。实例中仍然存在复制槽,因此无法将其设置为replica。
400 KmsApiError User secret key invalid. 用户密钥失效。
400 System.SaleValidateFailed Sales expression validation system error. 销售表达式校验系统错误。
400 Abs.InvalidAccount.NotFound account is not found. 账户不存在。
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. sql命令执行失败或执行超时
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. 当前实例引擎版本不支持归档冷数据。
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. 当前内核版本不支持归档冷数据。
400 IncorrectTargetClasscode The current instance type does not support this operation. 当前规格不支持此操作。
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. 链接地址名重复,请重新设置连接字符串。
400 RequiredParam.NotFound Required input param is not found. 没有传入必要的参数。
400 Parameters.Invalid Parameter error, please check the parameters. 参数错误,请检查参数。
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. 数据归档不支持跨地域备份和秒级快照,请检查备份策略。
400 InvalideStatus.Format The instance status does not support this operation. 实例状态不支持此操作。
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. 实例释放后的归档备份保留策略无效。
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. DB实例引擎类型不支持此操作。
400 Pay.NoCreditCard No credit cards. 无信用卡。
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. vpc网络类型实例不支持此操作。
400 MirrorInsExists Specified DB instance mirror ins already existed. 当前数据库实例镜像已存在。
400 UnsupportedClassCode The specified DB instance class stops selling. 实例规格停止售卖。
400 InvalidBackupSet The specified database does not exist in the backup set. 备份集中没有指定的数据库。
400 OrdTCommodityQueryError Failed to query for product. 查询产品失败。
400 ProductInstanceReleased The instance has been released. Please check before placing the order. 实例已释放,请核实后下单。
400 RegionEndTimeDissolvedIndia The region is no longer supported. 指定的地域无效。
500 ExternalFailure The request processing has failed due to external service failure. 请求服务失败,请稍后重试。
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. 请求服务失败,请稍后再试或联系服务人员。
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. 由于rds api服务失败,请求处理失败。
403 OrderStatus.UnPaid The specified db instance has unpaid order. 实例当前存在未支付订单,请支付后重试。
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. 缩容目标容量不能小于当前存储空间使用量
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd. SSD盘不支持此操作,请升级至ESSD。
403 InvalidUserOperatorPermission The user permission does not support this operation. 用户权限不支持此操作。
403 InvalidVswitchId Specified conn vswitch id is not valid. 指定的VSwitchId格式不正确或为空
403 IncorrectMinorVersion Current engine minor version does not support operations. 当前引擎小版本不支持此操作。
403 OperationDenied.ZoneResource There is no available zone for inventory. 没有可用的库存区域。
403 NotInFlowController Sorry,no permission. 非集团上云用户不可用,无权限。
403 InvalidKmsKey Kms key is disabled. Kms key已禁用。
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. 当前数据库实例级别不支持此操作。
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. 当前实例未授权访问密钥管理服务。
404 Request.NotFound The requested resource is not available. 请求的资源不可用。
404 HostInfo.NotFound The specified host info is not found. 指定的主机信息不存在。

访问错误中心查看更多错误码。

变更历史

更多信息,参考变更详情