通过阅读本文,您可以快速了解如何集成iOS端推流SDK。

集成环境

名称 要求
系统版本 支持iOS 8.0及以上。
机器型号 支持iPhone 5s及以上。
CPU架构支持 ARMv7、ARM64。
集成工具 Xcode 8.0及以上版本。
bitcode 关闭。

推流SDK下载

说明 每个版本均包含arm和arm&simulator两套SDK,arm仅支持真机调试。arm和simulator支持真机+模拟器调试。项目在release上线的时候必须使用arm版本。
SDK下载与历史记录下载对应版本的iOS端推流SDK,推流SDK包含在解压包的AlivcLivePusher文件夹中,如下图所示:SDK包
上图中的文件内容区别如下:
文件名称 文件说明
AlivcLivePusherSDK/arm 推流SDK,纯arm版本。
AlivcLivePusherSDK/arm&simulator 推流SDK,arm+模拟器版本。

推流SDK集成

通过手动或Pod方式集成推流SDK后,您还需要添加请求权限、关闭Bitcode,以及查看具体使用说明。

  1. 请选择手动集成或Pod集成推流SDK。如果选择手动集成,则按照步骤2进行操作;如果选择Pod集成,则按照步骤3进行操作。
  2. 手动集成:
    1. 新建SDK测试工程,Single View App > DemoPush
    2. 分别将以下文件拖入您的Xcode工程中:
      • AlivcLibRtmp.framework
      • AlivcLivePusher.framework
      • RtsSDK.framework
      如需使用美颜和贴纸特效,还需拖入以下文件:
      • queen.framework
      • openvc2.framework
      • Face3D.framework
      • FaceDetection.framework
      • MNN.framework
      • pixelai.framework
      如需依赖播放器SDK的版本,还需拖入以下文件:
      • AliyunPlayer.framework
      • artcSource.framework
      • alivcffmpeg.framework播放器SDK-新
    3. 勾选Copy items if needed,并单击Finish勾选
    4. 成功导入SDK后,在Xcode > General > Embedded Binaries中添加SDK依赖。SDK依赖
  3. Pod集成:
    1. 在终端窗口中输入以下命令,安装CocoaPods。注:请提前在Mac中安装Ruby环境。
      sudo gem install cocoapods
    2. 进入项目所在路径,在终端窗口中输入以下命令,创建Podfile文件。
      pod init
    3. 编辑Podfile文件,添加直播SDK依赖。如需直播播放,可以添加播放器SDK依赖。
      # 推流SDK Pod (live pusher pod)
      pod 'AlivcLivePusher', '~> 4.2.1'
      pod 'RtsSDK', '~> 1.8'
      # 播放器SDK Pod (live player pod)
      pod 'AliPlayerSDK_iOS', '~> 5.4.2'
      pod 'AliPlayerSDK_iOS_ARTC', '~> 5.4.2'
    4. 在终端窗口中输入以下命令。pod命令执行完成后,会生成集成了的SDK的.xcworkspace后缀的工程文件,双击打开即可更新并安装SDK。
      pod install
      或者
      pod update
  4. 添加请求权限。
    说明 请务必添加录音权限和相机权限。
    Info.plist文件中添加摄像头和麦克风权限Privacy - Camera Usage DescriptionPrivacy - Microphone Usage Description摄像头和麦克风权限如果需要App在后台继续推流,需要打开后台音频采集模式。后台音频采集
  5. 关闭Bitcode。
    由于SDK不支持Bitcode,所以需要在工程中关闭Bitcode选项。关闭bitcode
  6. 具体使用说明。