在使用PHP SDK收发消息前,您需按照本文提供的内容来准备环境。

环境要求

  • 安装PHP 5.5.0或以上版本,更多信息,请参见安装PHP
  • 安装Composer,更多信息,请参见安装Composer

安装完成后,您可以执行php -v命令查看PHP语言版本。

安装SDK

执行以下步骤安装PHP SDK。
  1. 在您PHP安装目录下的composer.json文件中加入以下依赖:
    {
      "require": {
         "aliyunmq/mq-http-sdk": ">=1.0.3"
      }
    }
  2. 执行以下命令,通过Composer安装依赖。
composer install