CSI-Provisioner组件具备数据卷的自动创建能力,目前支持云盘、NAS两种存储卷创建能力。本文介绍在阿里云Serverless Kubernetes(ASK)中如何安装与升级CSI-Provisioner存储组件。

前提条件

安装CSI-Provisioner

ASK集群需要手动安装CSI-Provisioner。如果您的集群中没有安装该组件,您可以手动安装。关于安装CSI-Provisioner的YAML示例,请参见alibaba-cloud-csi-driver

验证安装

执行以下命令,验证CSI-Provisioner组件是否安装成功。

kubectl get pod -n kube-system | grep csi-provisioner

预期输出:

NAME              READY   STATUS     RESTARTS   AGE
csi-provisioner   1/1     Running    0          14d

从预期输出可得,Pod的状态为Running,表示CSI-Provisioner组件安装成功。

升级CSI-Provisioner

若需要升级CSI-Provisioner组件,请根据CSI-Provisioner组件的变更记录更新YAML文件中的镜像地址。关于CSI-Provisioner组件的版本信息,请参见csi-provisioner