本文介绍如何安装服务器迁移中心SMC Python SDK。

环境准备

首先确保您已经具备Python的Runtime,建议使用的Python版本为2.7或更高版本。

安装SDK

  • 通过pip安装,执行如下命令:
    pip install aliyun-python-sdk-smc
    说明 如果您的环境尚未安装pip,请参见 pip官网安装。
  • 通过源码安装,从GitHub下载SDK包,解压后进入目录,进入aliyun-python-sdk-smc子目录下,确认目录下有setup.py文件,然后执行命令如下:
    python setup.py install