控制台提示“查詢結果不精確”,如何解決?
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在您查詢和分析日誌時,如果Log Service控制台提示查詢結果不精確,可參考本文進行排查。
問題描述
在您查詢和分析日誌時,如果Log Service控制台提示查詢結果不精確,表示Log Service未能掃描全部日誌,返回的查詢和分析結果不是基於全部日誌的精確結果。在Log Servicenginx-log日誌庫的查詢分析頁面,執行SQL語句select http_referer, count(1) pv group by http_referer order by pv desc,日誌條數約1000億條(100,006,376,644),統計分析結果顯示紅色警告結果不精確。
可能原因
查詢結果不精確一般由以下原因造成。
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查詢時間範圍太大
例如查詢時間範圍為3個月或1年時,Log Service無法在一次查詢中完整掃描這個時間段內的所有日誌。為了快速返回結果,先返回部分不精確的結果。
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查詢條件過於複雜
例如您在同一個查詢語句中設定了30個查詢條件,則Log Service無法一次性讀取查詢結果。
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SQL計算時要讀取的資料量太大
如果您在一個分析語句中設定了多個欄位,而這些欄位對應的資料量很大,超過Shard讀取能力(每個Shard僅能讀取1 GB資料),則返回結果不精確。
解決方案
方案一
開啟SQL完全精確,可以確保查詢結果精確完整。
方案二
縮小查詢和分析的時間範圍,多次(10次以內)執行查詢和分析語句。
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