該介面用於修改 RDS 執行個體的設定項目。
介面說明
適用引擎
RDS PostgreSQL
RDS SQL Server
調試
您可以在OpenAPI Explorer中直接運行該介面,免去您計算簽名的困擾。運行成功後,OpenAPI Explorer可以自動產生SDK程式碼範例。
調試
授權資訊
|
操作 |
存取層級 |
資源類型 |
條件關鍵字 |
關聯操作 |
|
rds:ModifyDBInstanceConfig |
none |
*DBInstance
|
無 | 無 |
請求參數
|
名稱 |
類型 |
必填 |
描述 |
樣本值 |
| DBInstanceId |
string |
是 |
執行個體 ID。可呼叫 DescribeDBInstances 取得。 |
pgm-2ze**** |
| ConfigName |
string |
是 |
待修改的設定項目名稱,配合 ConfigValue 使用。 |
pgbouncer |
| ConfigValue |
string |
是 |
待修改設定項目的取值,配合 ConfigName 使用。 |
true |
| ResourceGroupId |
string |
否 |
資源群組 ID。可呼叫 DescribeDBInstanceAttribute 取得。 |
rg-bp67acfmxazb4p**** |
| ClientToken |
string |
否 |
用於保證請求的冪等性,防止重複提交請求。由用戶端產生該參數值,要保證在不同請求間唯一,最大值不超過 64 個 ASCII 字元,且該參數值中不能包含非 ASCII 字元。 |
6000170000591aed949d0f**** |
| SwitchTime |
string |
否 |
指定執行修改的時間。建議在業務離峰時段執行變更配置。格式:yyyy-MM-ddTHH:mm:ssZ(UTC 時間)。 |
2025-05-06T09:24:00Z |
| SwitchTimeMode |
string |
否 |
切換時間。取值:
|
Immediate |
返回參數
|
名稱 |
類型 |
描述 |
樣本值 |
|
object |
傳回參數詳細資訊。 |
||
| RequestId |
string |
請求 ID。 |
76364A52-E0AB-5CC8-9818-CF1DC482C092 |
樣本
正常返回樣本
JSON格式
{
"RequestId": "76364A52-E0AB-5CC8-9818-CF1DC482C092"
}
錯誤碼
|
HTTP status code |
錯誤碼 |
錯誤資訊 |
描述 |
|---|---|---|---|
| 400 | %s | DB Operation Failed:%s. | |
| 400 | InvalidDBInstanceName.NotFound | The specified DB instance name does not exist. | 該執行個體 ID 不存在,請確認後重試。 |
| 400 | MinorVersionNotSupport | The current database minor version does not support the operation. | 目前執行個體核心小版本不支援該操作,可嘗試升級核心小版本。 |
| 400 | InvalidConfigName | The ConfigName is not valid. | ConfigName 無效。 |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | 套件執行個體不允許單獨操作。 |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | 定價計劃價格結果沒有找到。 |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | 您尚未通過實名認證,不符合購買條件,請登入費用與成本進行實名認證。 |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | 您的帳戶可用額度小於 0,請先儲值後再嘗試購買。 |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | 呼叫商品服務傳回失敗。 |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | 客戶您好,阿里雲端計劃對目前地域進行最佳化調整,該區域雲端服務將停止營運,為確保您的業務連續性及資料遷移工作的平穩過渡,您目前無法操作新購類型的訂單,感謝理解與支援。 |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | 您購買的模組不合法,請重新購買。 |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | 客戶您好,該地域已裁撤。 |
| 400 | Price.CommoditySys | Commodity system call exception. | 商品系統呼叫異常。 |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | 您選購的週期有問題,請重新選購。 |
| 400 | pay.noCreditCard | Account not bound to credit card. | 帳戶未綁定信用卡。 |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | 您選購的服務存在未支付訂單,請支付或作廢後再下單。 |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | 沒有為您的帳戶指定付款方式。我們建議您新增一種付款方式。 |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | 您的資訊不完整,請在操作前填寫您的資訊。 |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | 您的帳戶出現異常,詳情請聯絡客服。 |
| 400 | Api.NotSupport | Specified api is not supported. | 目前介面不支援。 |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | 存在禁止下單的標籤,請聯絡您的經銷商處理。 |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | 指定的執行個體不存在,請檢查該執行個體是否存在,未被刪除。 |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | 目前執行個體規格不支援該儲存類型。 |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | 操作失敗,無效的參數。 |
| 400 | KmsApiError | User secret key invalid. | 使用者金鑰失效。 |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | 帳戶不存在。 |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | SQL 命令執行失敗或執行逾時。 |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | 目前執行個體引擎版本不支援歸檔冷資料。 |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | 目前核心版本不支援歸檔冷資料。 |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | 目前規格不支援此操作。 |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | 連結位址名稱重複,請重新設定連線字串。 |
| 400 | RequiredParam.NotFound | Required input param is not found. | 未傳入必要的參數。 |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | 參數錯誤,請檢查參數。 |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | 資料歸檔不支援跨地域備份和秒級快照,請檢查備份策略。 |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | 執行個體狀態不支援此操作。 |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | 執行個體釋放後的歸檔備份保留策略無效。 |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | DB 執行個體引擎類型不支援此操作。 |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | VPC 網路類型執行個體不支援此操作。 |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | 目前資料庫執行個體映像已存在。 |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | 執行個體規格停止販售。 |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | 備份集中沒有指定的資料庫。 |
| 400 | OrdTCommodityQueryError | Failed to query for product. | 查詢產品失敗。 |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | 執行個體已釋放,請核實後下單。 |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | 客戶您好,該地域已裁撤。 |
| 400 | InvalidSourceCategory | specified source category is invalid. | 指定的來源類別無效。 |
| 400 | InvalidParameter | Invalid parameter. | 無效的參數。 |
| 400 | InvalidConfigValue | The ConfigValue is not valid. | 操作失敗,指定的參數設定無效。 |
| 400 | InvalidParameters.Format | Specified parameters is not valid. | 無效的參數。 |
| 400 | DuckDBOperationConflictBetweenPrimaryAndReadOnlyInstance | Current instance is already attached to another duckdb instance, operation is conflict. | 目前執行個體已關聯另一個 DUCKDB 執行個體,這與目前的 DUCKDB 操作衝突。 |
| 400 | KmsServiceLinkedRoleNotGranted | The service linked role is not granted, please check. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | 請求服務失敗,請稍後重試。 |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | 請求服務失敗,請稍後再試或聯絡服務人員。 |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | 由於 RDS API 服務失敗,請求處理失敗。 |
| 403 | IncorrectDBInstanceType | Current DB instance type does not support this operation. | 操作失敗,目前資料庫執行個體引擎和類型不支援。 |
| 403 | IncorrectDBInstanceLockMode | Current DB instance lock mode does not support this operation. | |
| 403 | IncorrectDBInstanceState | Current DB instance state does not support this operation. | 操作失敗,目前執行個體狀態不支援該操作,請稍後重試。 |
| 403 | CloudDiskEncryptionNotSupport | The encryption key is not allowed for general-purpose instance. | 通用型規格執行個體不支援雲端硬碟加密。 |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | 執行個體目前存在未支付訂單,請支付後重試。 |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | 縮容目標容量不能小於目前儲存空間使用量。 |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | SSD 雲端硬碟不支援此操作,請升級至 ESSD。 |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | 使用者權限不支援此操作。 |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | 指定的 VSwitchId 格式不正確或為空。 |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | 目前引擎小版本不支援此操作。 |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | 沒有可用的庫存區域。 |
| 403 | NotInFlowController | Sorry,no permission. | 非集團上雲使用者不可用,無權限。 |
| 403 | InvalidKmsKey | Kms key is disabled. | Kms key 已停用。 |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | 操作失敗,規定的規格代碼不支援該終端節點數量,請檢查分片數量和目前的終端節點數量。 |
| 403 | UnsupportedByBlueGreenDeployment | Operation prohibited due to blue green deployment. | 由於存在藍綠部署,因此不允許此操作。 |
| 403 | EncryptionKeyNotSupport | The encryption key is not support to generate encryption disk. | 該金鑰不支援建立雲端硬碟加密執行個體。 |
| 403 | IncorrectDBState | The current DB state does not support this operation. | 操作失敗,目前資料庫狀態不正確。例如,資料庫正在建立中或者正在上雲端中。 |
| 403 | UnsupportedReadOrBakReadState | Current DB instance has read or bak read running in unsupport states | 目前 DB 執行個體已在不支援狀態下執行 read 或 bak read。 |
| 403 | IncorrectAccountPrivilegeType | the current account privilege type does not support this operation. | 當前帳戶權限類型不支援此操作。 |
| 403 | DBInstanceStatusNotActive | The status of the current instance is not active. | 操作失敗,請檢查執行個體運作狀態。 |
| 403 | ReadOnlyInstanceNotSupport | Read-only instance does not support this operation. | 操作失敗,唯讀執行個體不支援此操作。 |
| 403 | Invalid.Parameter | Specified parameters is not valid. | 指定的參數無效。 |
| 403 | TargetMajorVesionNotSupported | The specified major version is not supported. | 目標大版本不支援。 |
| 403 | ReadInstanceNotSupport | Instances with read-only do not support this operation. | 帶有唯讀執行個體的執行個體不支援此操作。 |
| 403 | IncorrectDBInstance | The current DB instance does not support this operation. | 操作失敗,目前執行個體不支援此操作。 |
| 404 | InvalidDBInstance.NotFound | Specified instance does not exist or not support. | 指定的執行個體不存在或不支援此操作。 |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | 目前執行個體未授權存取金鑰管理服務。 |
| 404 | Request.NotFound | The requested resource is not available. | 請求的資源無法使用。 |
| 404 | HostInfo.NotFound | The specified host info is not found. | 指定的主機資訊不存在。 |
| 404 | InvalidAccountName.NotFound | The specified account is not found. | 未找到該帳戶。如果您是在進行建立帳號或重設密碼等操作,請指定您的帳號。 |
| 404 | InvalidReadDBInstance.NotFound | The specified read only database instance does not exist. | 唯讀執行個體未建立或請求執行個體參數有誤。 |
訪問錯誤中心查看更多錯誤碼。
變更歷史
更多資訊,參考變更詳情。