該介面用於為 RDS 執行個體建立一個唯讀執行個體。
介面說明
適用引擎
RDS MySQL
RDS PostgreSQL
RDS SQL Server
相關功能文件
調試
您可以在OpenAPI Explorer中直接運行該介面,免去您計算簽名的困擾。運行成功後,OpenAPI Explorer可以自動產生SDK程式碼範例。
調試
授權資訊
|
操作 |
存取層級 |
資源類型 |
條件關鍵字 |
關聯操作 |
|
rds:CreateReadOnlyDBInstance |
create |
*DBInstance
|
|
無 |
請求參數
|
名稱 |
類型 |
必填 |
描述 |
樣本值 |
| ClientToken |
string |
否 |
用於保證請求的冪等性,防止重複提交請求。由用戶端產生該參數值,要保證在不同請求間唯一,最大值不超過 64 個 ASCII 字元,且該參數值中不能包含非 ASCII 字元。 |
ETnLKlblzczshOTUbOC**** |
| RegionId |
string |
是 |
地域 ID。唯讀執行個體的地域必須和主執行個體相同。可呼叫 DescribeRegions 取得。 |
cn-hangzhou |
| ZoneId |
string |
是 |
可用區 ID。可呼叫 DescribeRegions 取得。
|
cn-hangzhou-b |
| DBInstanceId |
string |
是 |
主執行個體 ID。可呼叫 DescribeDBInstances 取得。 |
rm-uf6wjk5**** |
| DBInstanceClass |
string |
是 |
執行個體規格,詳見唯讀執行個體規格清單。建議唯讀執行個體規格不小於主執行個體規格,否則易導致唯讀執行個體延遲高、負載高等現象。 |
mysqlro.n2.small.1c |
| DBInstanceStorage |
integer |
是 |
儲存空間,唯讀執行個體儲存空間需要大於或等於主執行個體儲存空間。取值:請參見唯讀執行個體規格清單的儲存空間欄位。每 5 GB 進行遞增,單位:GB。 |
20 |
| EngineVersion |
string |
是 |
資料庫版本號碼。必須與主執行個體相同。
|
5.6 |
| PayType |
string |
是 |
付費類型。取值: |
Postpaid |
| DBInstanceDescription |
string |
否 |
執行個體描述,長度為 2~256 個字元。以中文、英文字母開頭,可以包含數字、中文、英文、底線(_)、連字號(-)。 |
testReadOnly |
| InstanceNetworkType |
string |
否 |
唯讀執行個體的網路類型。取值:
預設建立專有網路執行個體,需要傳入 VPCId 和 VSwitchId。 說明
唯讀執行個體的網路類型可以與主執行個體不同。 |
Classic |
| VPCId |
string |
否 |
唯讀執行個體的專用網路 VPC ID。當 InstanceNetworkType 設定為空或 VPC 時需要傳入。 說明
|
vpc-uf6f7l4fg90**** |
| VSwitchId |
string |
否 |
唯讀執行個體的虛擬交換器 ID。當 InstanceNetworkType 設定為空或 VPC 時需要傳入。 |
vsw-uf6adz52c2p**** |
| PrivateIpAddress |
string |
否 |
設定唯讀執行個體的內網 IP,需要在指定交換器的 IP 位址範圍內。系統預設透過 VPCId 和 VSwitchId 自動分配。 |
172.16.XX.XX |
| ResourceGroupId |
string |
否 |
資源群組 ID。 |
rg-acfmy**** |
| Category |
string |
否 |
執行個體系列。取值:
說明
PostgreSQL 雲端硬碟執行個體的唯讀執行個體為基礎系列,因此必須傳入 Basic。 |
HighAvailability |
| DBInstanceStorageType |
string |
否 |
執行個體儲存類型。取值:
說明
|
local_ssd |
| DedicatedHostGroupId |
string |
否 |
在專屬叢集內建立唯讀執行個體時指定專屬叢集 ID。 |
dhg-4n**** |
| TargetDedicatedHostIdForMaster |
string |
否 |
在專屬叢集內建立唯讀執行個體時,指定主執行個體的主機 ID。 |
i-bp**** |
| GdnInstanceName |
string |
否 |
備用參數,無需設定。 |
test |
| TddlBizType |
string |
否 |
備用參數,無需設定。 |
test |
| TddlRegionConfig |
string |
否 |
備用參數,無需設定。 |
test |
| InstructionSetArch |
string |
否 |
備用參數,無需設定。 |
test |
| UsedTime |
string |
否 |
指定購買時長。取值:
說明
若 PayType 為 Prepaid,需要傳入該參數。 |
1 |
| Period |
string |
否 |
指定預付費執行個體為包年或者包月類型。取值: |
Month |
| AutoRenew |
string |
否 |
執行個體是否自動續費,僅在建立包年包月執行個體時傳入。取值:
說明
|
true |
| DeletionProtection |
boolean |
否 |
是否啟用 RDS 釋放保護功能。取值: |
true |
| Port |
string |
否 |
支援在 RDS MySQL 主執行個體建立唯讀執行個體時初始化連接埠。 |
3306 |
| BurstingEnabled |
boolean |
否 |
棄用參數,無需設定。 |
0 |
| IsAnalyticReadOnlyIns |
boolean |
否 |
高效能雲端硬碟的 IO 效能突增功能開關。取值: |
false |
| AutoPay |
boolean |
否 |
是否建立 DuckDB 分析執行個體。取值:
說明
目前僅 RDS MySQL 和 RDS PostgreSQL 支援建立 DuckDB 分析執行個體。 |
false |
| AutoCreateProxy |
boolean |
否 |
是否自動支付。取值:
說明
預設值為 true。如果您的支付方式餘額不足,可以將參數 AutoPay 設定為 false,此時會產生未支付訂單,您可以登入 RDS 管理主控台自行支付。 |
false |
| IoAccelerationEnabled |
string |
否 |
是否自動建立代理。取值: |
false |
| AutoUseCoupon |
boolean |
否 |
高效能雲端硬碟的 Buffer Pool Extension(BPE) 功能開關。取值:
|
0 |
| PromotionCode |
string |
否 |
是否使用代金券。取值: |
true |
| CustomExtraInfo |
string |
否 |
優惠券 code。 |
71744626**** |
|
否 |
備用參數,無需設定。 |
None |
返回參數
|
名稱 |
類型 |
描述 |
樣本值 |
|
object |
返回參數詳情。 |
||
| ConnectionString |
string |
建立的唯讀執行個體內網資料庫連線位址。 |
rr-****.mysql.rds.aliyuncs.com |
| DBInstanceId |
string |
建立的唯讀執行個體 ID。 |
rr-uf6wjk5**** |
| OrderId |
string |
訂單 ID。 |
10078937**** |
| Port |
string |
建立的唯讀執行個體內網資料庫連線連接埠。 |
3306 |
| RequestId |
string |
請求 ID。 |
1E43AAE0-BEE8-43DA-860D-EAF2AA0724DC |
樣本
正常返回樣本
JSON格式
{
"ConnectionString": "rr-****.mysql.rds.aliyuncs.com",
"DBInstanceId": "rr-uf6wjk5****",
"OrderId": "10078937****",
"Port": "3306",
"RequestId": "1E43AAE0-BEE8-43DA-860D-EAF2AA0724DC"
}
錯誤碼
|
HTTP status code |
錯誤碼 |
錯誤資訊 |
描述 |
|---|---|---|---|
| 400 | InvalidEngineVersion.Malformed | The specified parameter EngineVersion is not valid. | |
| 400 | InvalidNetworkTypeClassicWhenCloudStorage | The Specified InstanceNetworkType value Classic is not valid when choose cloud storage type. | 選擇雲端儲存類型時,指定 InstanceNetworkType 的值為 Classic 是無效的。 |
| 400 | InvalidSecurityIPList.Malformed | The specified parameter SecurityIPList is not valid. | |
| 400 | InvalidSecurityIPList.Duplicate | The Security IP address is not in the available range or occupied. | 指定的安全 IP 清單無效。其中包含重複值。 |
| 400 | InvalidParameter | The specified parameter dbInstanceId is not valid. | |
| 400 | OperationDenied | VPC IP is in use, please check. | 執行個體規格不支援目前操作。 |
| 400 | InvalidZoneId.NotSupported | The Specified vpc Zone not supported. | 目前可用區不支援建立 VPC 網路類型執行個體,請更換可用區。 |
| 400 | InvalidAvZone.NotSupport | Specified availableArea multiZone does not support in RDS. | 指定的 availableArea multiZone 在 RDS 中不支援。 |
| 400 | CDDC.AvailableHostsNotEnoughInZone | Not enough available hosts are in the target zone. | 目標可用區沒有足夠的主機資源,請在可用區中建立主機。 |
| 400 | InvalidReadEngineVersionPattern | The engine versions of the primary instance and the read-only instance do not match. | 主執行個體和唯讀執行個體 engineVersion 不匹配。 |
| 400 | InvalidDBInstanceClass.Offline | The specified instance type is no longer provided. Please specify another instance type. | 目前所選的執行個體規格已下線,請更換其他執行個體規格。 |
| 400 | SYSTEM.CONCURRENT_OPERATE | Concurrent operation is detected. | 系統中存在並行操作。 |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | 定價計畫價格結果沒有找到。 |
| 400 | InvalidDBInstanceName.Duplicate | Specified DB instance name already exists in the Aliyun RDS. | 操作失敗,執行個體名稱已存在,請修改執行個體名稱後重試。 |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | 目前執行個體規格不支援該儲存類型。 |
| 400 | InvalidRequestId | The request is copy, check your token. | 重複請求,請檢查 token。 |
| 400 | InvalidParam.InstanceNetworkType | Creation of classic network instances is not supported. | 傳統網路已下線,不支援建立傳統網路執行個體! |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | 套件執行個體不允許單獨操作。 |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | 您尚未通過實名認證,不符合購買條件,請登入費用與成本進行實名認證。 |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | 您的帳戶可用額度小於 0,請先儲值後再嘗試購買。 |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | 呼叫商品服務傳回失敗。 |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | 使用者您好,阿里雲端計劃對當前地域進行最佳化調整,該區域雲端服務將停止營運,為確保您的業務連續性及資料移轉工作的平穩過渡,您目前無法操作新購類型的訂單,感謝理解與支援。 |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | 您購買的模組不合法,請重新購買。 |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | 使用者您好,該地域已裁撤。 |
| 400 | Price.CommoditySys | Commodity system call exception. | 商品系統呼叫異常。 |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | 您選購的週期有問題,請重新選購。 |
| 400 | pay.noCreditCard | Account not bound to credit card. | 無信用卡。 |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | 您選購的服務存在未支付訂單,請支付或作廢後再下單。 |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | 帳戶未指定付款方式。我們建議您新增付款方式。 |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | 您的基本資訊未完善,請在操作前先完善您的基本資訊。 |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | 您的帳戶出現異常,詳情請聯絡客服。 |
| 400 | Api.NotSupport | Specified api is not supported. | 目前介面不支援。 |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | 存在禁止下單的標籤,請聯絡您的經銷商處理。 |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | 提供的 DBInstanceId 不存在。 |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | 輸入參數無效。 |
| 400 | KmsApiError | User secret key invalid. | 使用者金鑰失效。 |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | 您的阿里雲端帳號不存在,或者您的 AccessKey 已經過期。 |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | SQL 命令執行失敗或執行逾時。 |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | 目前執行個體引擎版本不支援歸檔冷資料。 |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | 目前核心版本不支援歸檔冷資料。 |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | 目前規格不支援此操作。 |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | 連結位址名稱重複,請重新設定連線字串。 |
| 400 | RequiredParam.NotFound | Required input param is not found. | 沒有傳入必要的參數。 |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | 參數錯誤,請檢查參數。 |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | 當前的備份策略不支援此操作。 |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | 執行個體狀態不支援此操作。 |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | 執行個體釋放後的歸檔備份保留策略無效。 |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | DB 執行個體引擎類型不支援此操作。 |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | VPC 網路類型執行個體不支援此操作。 |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | 目前資料庫執行個體映像已存在。 |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | 執行個體規格已停止銷售。 |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | 備份集中沒有指定的資料庫。 |
| 400 | OrdTCommodityQueryError | Failed to query for product. | 查詢產品失敗。 |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | 執行個體已釋放,請核實後下單。 |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | 指定的地域無效。 |
| 400 | InvalidVSwitchId.Format | The specified vswitch Id format is incorrect. | 指定的 vswitch Id 格式不正確。 |
| 400 | InvalidParameterValue.NotStandard | Invalid parameter format. | 指定的參數格式不規範。 |
| 400 | AtLeastThreeVSwitchAvailableIp | The primary vswitch requires at least three available IP addresses. | 主要交換器至少需要 3 個可用 IP。 |
| 400 | AtLeastTwoVSwitchAvailableIp | The primary vswitch requires at least two available IP addresses. | 主要交換器至少需要 2 個可用的 IP。 |
| 400 | DuckDBOperationConflictBetweenPrimaryAndReadOnlyInstance | Current instance is already attached to another duckdb instance, operation is conflict. | 目前執行個體已經關聯了另一個 DUCKDB 執行個體,這和目前的 DUCKDB 操作衝突了。 |
| 500 | CannotDecreaseEssdPerfLevel | cannot decrease cloud essd performance level. | |
| 500 | InvalidEssdStorageSize | invalid cloud essd storage size. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | 請求服務失敗,請稍後重試。 |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | 請求服務失敗,請稍後再試或聯絡服務人員。 |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | 由於 RDS API 服務失敗,請求處理失敗。 |
| 403 | OperationDenied.PrimaryDBInstanceStatus | The operation is not permitted due to status of primary instance. | 操作失敗,無法遷移專屬叢集內非執行狀態的 RDS 執行個體。 |
| 403 | InvalidReadStorageTypePattern | The storage type of the primary instance and the read-only instance do not match. | |
| 403 | IncorrectCharacterType | Current DB instance character type does not support this operation. | 目前執行個體字元類型不支援此操作。 |
| 403 | InvalidMultiparamZoneInfoList | Zoneinfo list is invaild. | 目前主要可用區未對齊,無法遷移主要資料庫。 |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | 執行個體當前存在未支付訂單,請支付後重試。 |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | 縮容目標容量不能小於目前儲存空間使用量。 |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | SSD 磁碟不支援此操作,請升級至 ESSD。 |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | 使用者權限不支援此操作。 |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | 指定的 VSwitchId 格式不正確或為空。 |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | 目前引擎小版本不支援此操作。 |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | 沒有可用的庫存區域。 |
| 403 | NotInFlowController | Sorry,no permission. | 非集團上雲使用者不可用,無權限。 |
| 403 | InvalidKmsKey | Kms key is disabled. | Kms key 已停用。 |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | 目前資料庫執行個體層級不支援此操作。 |
| 403 | BasicCategoryNotSupport | The Basic category is not supported. | 不支援基礎版系列。 |
| 403 | GuardDBInstanceNotSupport | Guard instance does not support this operation. | 災備執行個體不支援此操作。 |
| 404 | IncorrectDBInstanceConnType | Current DB instance conn type does not support this operation. | |
| 404 | InvalidDBInstance.NotFound | The specified instance does not exist or is not supported. | 沒有找到指定的執行個體,請檢查執行個體的正確性。 |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | 當前執行個體未授權存取金鑰管理服務。 |
| 404 | Request.NotFound | The requested resource is not available. | 請求的資源不可用。 |
| 404 | HostInfo.NotFound | The specified host info is not found. | 指定的主機資訊不存在。 |
訪問錯誤中心查看更多錯誤碼。
變更歷史
更多資訊,參考變更詳情。