Windows Server出現termdd藍屏問題如何處理?

更新時間:
Copy as MD

本文介紹Windows Server 2008 R2出現termdd藍屏問題的原因及解決方案。

問題描述

Windows Server 2008 R2在運行過程中出現termdd(錯誤碼是0x000000D1或者其他)藍屏問題,如下圖所示。

A problem has been detected and windows has been shut down to prevent damage
to your computer.

DRIVER_IRQL_NOT_LESS_OR_EQUAL

If this is the first time you've seen this Stop error screen,
restart your computer. If this screen appears again, follow
these steps:

Check to make sure any new hardware or software is properly installed.
If this is a new installation, ask your hardware or software manufacturer
for any windows updates you might need.

If problems continue, disable or remove any newly installed hardware
or software. Disable BIOS memory options such as caching or shadowing.
If you need to use Safe Mode to remove or disable components, restart
your computer, press F8 to select Advanced Startup Options, and then
select Safe Mode.

Technical information:

*** STOP: 0x000000D1 (0x0000000000000000,0x0000000000000002,0x0000000000000000,0xFFFFF88002B43006)

***     termdd.sys - Address FFFFF88002B430^

Dump資訊中顯示termdd.sys(C:\Windows\System32\drivers\termdd.sys)檔案的版本在6.1.7601.24441以下。

問題原因

是系統漏洞導致。微軟於20190514日修複了該漏洞,CVE詳細資料請參考CVE-2019-0708。 

解決方案

  1. 更新系統。

    Windows自動更新系統

    使用Windows更新,將系統更新至最新。

    1. 遠端連線ECS執行個體。

      具體操作,請參見使用Workbench登入Windows執行個體

    2. 修改註冊表中的WSUS地址。

      1. 依次選擇開始 > 運行 > regedit

      2. 進入電腦\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate路徑,將WUServerWUStatusServer的值修改為http://update.cloud.aliyuncs.com

    3. 依次選擇開始 > 控制台 > 系統和安全 > Windows Update

    4. 掃描更新後,單擊安裝更新

    5. 更新完成後,重啟Windows系統。

    手動更新系統

    1. 遠端連線ECS執行個體。

      具體操作,請參見使用Workbench登入Windows執行個體

    2. 下載累計安全補丁KB4499164或者僅安全更新補丁KB4499175

    3. 雙擊安裝補丁。

    4. 重啟Windows系統。

    公用命令更新系統

    1. 登入ECS管理主控台

    2. 在左側導覽列,選擇營運與監控 > 雲助手

    3. 公用命令頁簽,找到公用命令ACS-ECS-ApplySecurityPatches-for-windows.ps1,單擊執行

    4. 選擇待更新的Windows執行個體並配置其他參數,更新系統。

      具體操作,請參見查看和執行公用命令

  2. 驗證問題是否修複。

    • 查看已安裝的補丁。

      自動更新系統或者手動更新系統後,開啟CMD命令列,使用systeminfo命令查看已安裝的補丁,確認系統安裝了KB4499164或者KB4499175補丁。

      [55]:  KB3156019
      [56]:  KB3159398
      [57]:  KB3161949
      [58]:  KB3161958
      [59]:  KB3172605
      [60]:  KB3177467
      [61]:  KB3179573
      [62]:  KB3181988
      [63]:  KB3210131
      [64]:  KB4019990
      [65]:  KB4040980
      [66]:  KB4093108
      [67]:  KB4103712
      [68]:  KB4284867
      [69]:  KB4338823
      [70]:  KB4343205
      [71]:  KB4343899
      [72]:  KB4457145
      [73]:  KB4462915
      [74]:  KB4467106
      [75]:  KB4471328
      [76]:  KB4474419
      [77]:  KB4480960
      [78]:  KB4486654
      [79]:  KB4489885
      [80]:  KB4493448
      [81]:  KB4499175
      [82]:  KB4503269
      [83]:  KB4507456
    • 查看termdd.sys檔案版本。

      確認termdd.sys(C:\Windows\System32\drivers\termdd.sys)檔案版本是否在6.1.7601.24441及以上。

    如果確認系統安裝了KB4499164或者KB4499175補丁以及termdd.sys檔案版本在6.1.7601.24441及以上,藍屏問題將得到解決。