本文介紹Windows系統的ECS執行個體更新系統時,一直卡在0%的問題原因和解決方案。
問題現象
Windows系統的ECS執行個體更新系統時,一直卡在0%。通過執行個體健康診斷時提示“該執行個體的防火牆服務(對應的進程名稱為mpssvc)目前不處於運行中,會導致Windows系統更新失敗”。
問題原因
該問題可能是由於Windows防火牆服務(mpssvc)未運行,導致Windows更新失敗。
解決方案
您可以通過修改註冊表並啟動防火牆服務,來解決上述問題。
遠端連線Windows執行個體。
具體操作,請參見通過密碼或密鑰認證登入Windows執行個體。
查看Windows防火牆狀態。
單擊右下角的
表徵圖,然後選擇。在控制台頁面,選擇。
如果彈出提示Windows 防火牆無法更改某些設定。錯誤碼 0x80070422,說明該問題是由於防火牆服務未運行導致。

修改防火牆服務註冊表。
選擇,輸入regedit,開啟登錄編輯程式。
在註冊表路徑中輸入HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mpssvc,按
Enter鍵,然後尋找Start。按右鍵Start,然後單擊修改(M)...。

在彈出的對話方塊中,基數選擇十進位(D),數值資料(V)設定2,單擊確定。

啟動防火牆服務。
選擇,輸入services.msc,單擊確定。
在服務頁面,找到Windows Defender Firewall服務,啟動該服務。
重啟執行個體,使以上修改生效。
具體操作,請參見重啟執行個體。
警告重啟執行個體會造成您的執行個體停止工作,可能導致業務中斷,建議您在非業務高峰期時執行該操作。
重新更新Windows系統,如果可以正常更新,說明該問題已解決。