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:通過Workbench工具RDP遠端連線Windows執行個體的問題

更新時間:Dec 03, 2024

通過Workbench遠端連線Windows執行個體提示連線逾時,怎麼辦?

問題現象

通過Workbench工具遠端連線Windows執行個體時提示“登入主機:i-m5e****73a (47.*.*.157:3389) 失敗,原因:連結逾時!”錯誤。連結逾時

問題原因

導致此問題的常見原因如下:

  • Windows執行個體的安全性群組設定不允許Workbench工具串連目標Windows執行個體。

  • 遠端桌面RDP連接埠不是預設的3389連接埠。

  • Windows執行個體內的防火牆設定未允許Workbench工具串連目標Windows執行個體。

  • 第三方安全管理軟體限制使用者遠程登入。

解決方案

請參考以下步驟進行排查:

  1. 查看目標Windows執行個體的RDP連接埠。具體操作,請參見查看ECS Windows遠端桌面連接埠

    • 不是3389連接埠

      在Workbench工具中通過修改後的RDP連接埠重試遠端連線。

    • 是3389連接埠

      請繼續下一步檢查。

  2. 查看目標Windows執行個體的安全性群組設定,檢查SSH服務的連接埠是否放開。具體操作,請參見查詢安全性群組規則

    說明
    • 此處的連接埠範圍以RDP預設的連接埠3389為例。如果您修改過RDP預設連接埠,此處應當為您修改後的連接埠號碼。

    • 授權對象如果不是0.0.0.0/0,則需要同時對您需要訪問的ECS執行個體的IP地址進行授權,此處47.96.60.0/24和118.31.243.0/24為例。

    規則方向

    授權策略

    優先順序

    連接埠範圍

    授權對象

    入方向

    允許

    1

    目的:3389/3389

    • 源:47.96.60.0/24和118.31.243.0/24

    • 源:0.0.0.0/0

  3. 檢查Windows執行個體中是否開啟防火牆,且不允許Workbench工具串連RDP連接埠。檢查步驟如下:

    1. 通過阿里雲VNC方式登入Windows執行個體。具體操作,請參見使用VNC登入執行個體

    2. 檢查防火牆狀態。具體操作,請參見開啟或關閉Windows系統防火牆

      • 已開啟,請關閉防火牆,然後通過Workbench工具重試遠端連線。

      • 未開啟,請繼續下一步檢查。

  4. 檢查Windows執行個體中是否安裝第三方安全管理軟體,例如安全狗等,並且通過該軟體限制使用者遠程登入。

    • 第三方安全管理軟體限制了遠程登入

      請暫時關閉第三方安全管理軟體對遠程登入的限制,然後通過Workbench工具嘗試遠端連線。

    • 未通過第三方安全管理軟體限制遠程登入

      Windows執行個體中可能存在其他限制遠程登入的系統設定,建議您選擇阿里雲VNC工具進行遠端連線。具體操作請參見使用VNC登入執行個體

通過Workbench遠端連線Windows執行個體提示使用者名稱或密碼不正確,怎麼辦?

問題現象

通過Workbench工具遠端連線Windows執行個體時提示“登入執行個體失敗,原因:使用者名稱或密碼不正確”錯誤。

問題原因

導致此問題的常見原因如下:

  • 複製粘貼或手動輸入了錯誤的帳號或密碼。

  • 遠程登入使用者不屬於Remote Desktop Users組。

  • Windows執行個體的本地安全性原則中被添加了拒絕使用者遠程登入的策略。

解決方案

請參考以下步驟進行排查:

  1. 檢查您輸入的使用者名稱是否為Administrator。

    • 非Administrator使用者

      Windows系統中遠端桌面RDP預設的使用者名稱為Administrator,如果您未修改過該使用者名稱,請嘗試通過該使用者名稱進行遠程登入。

    • 是Administrator使用者

      請繼續下一步檢查。

  2. 請確認您在Workbench中輸入了正確的使用者名稱和密碼。

    • 輸入錯誤

      手動輸入使用者名稱和密碼時可能存在輸入錯誤的情況,請檢查您輸入的使用者名稱和密碼,確認拼字正確。

      說明

      使用者名稱Administrator拼字錯誤屬於遠端連線失敗的常見原因之一。

    • 忘記密碼

      請重設執行個體密碼,然後使用新密碼重新登入Windows執行個體。具體操作,請參見重設執行個體登入密碼

    • 使用者名稱和密碼正確

      請繼續下一步檢查。

  3. 如果您曾經修改過Windows執行個體中的本地安全性原則,請檢查本地安全性原則中是否添加了拒絕使用者遠程登入的策略。檢查方法,請參見通過遠端桌面連線Windows執行個體提示“遠端桌面使用者組沒有該許可權”錯誤怎麼辦?中的本地安全性原則問題的解決方案章節。

    說明

    請先通過阿里雲VNC方式登入Windows執行個體,然後再進行檢查。具體操作,請參見使用VNC登入執行個體

    • 存在拒絕使用者遠程登入的策略

      在本地安全性原則中移除被拒絕遠端桌面登入的使用者,然後重試遠端連線。

    • 未修改過本地安全性原則或者不存在拒絕使用者遠程登入的策略

      請繼續下一步檢查。

  4. 如果您使用非Administrator使用者遠端連線,請檢查該使用者是否屬於Remote Desktop Users組。檢查方法請參見通過遠端桌面連線Windows執行個體提示“遠端桌面使用者組沒有該許可權”錯誤怎麼辦?中的普通使用者未附加遠程登入許可權的解決方案章節。

    • 不屬於Remote Desktop Users組

      將遠端連線使用者添加到Remote Desktop Users組,然後重試遠端連線。

    • 屬於Remote Desktop Users組

      Windows執行個體中可能存在其他限制遠程登入的系統設定,建議您選擇阿里雲VNC工具遠端連線。具體操作,請參見使用VNC登入執行個體