全部產品
Search
文件中心

:SDK重新運行後不能成功訂閱資料

更新時間:Feb 08, 2025

問題描述

SDK重新運行後不能成功訂閱資料。

問題原因

因為資料訂閱通道中保留資料的時間範圍為1天,從目前時間減1天,當天時間訂閱通道會刪除到期資料。因此如果上次SDK退出時最後一條消費資料的時間點對應的資料,不在當前訂閱通道中,就不能訂閱到這個消費位點對應的資料。

解決方案

為了修複這個問題,在啟動SDK之前,需要先修改消費位點,使消費位點在資料範圍內,具體的修改方法詳見文檔修改訂閱通道的消費位點

適用於

  • Data Transmission Service

如果您的問題仍未解決,您可以在阿里雲社區免費諮詢