阿里雲團隊努力不懈,力求將最新的技術內容更快地以您最熟悉的語言呈現。本文由簡體中文內容自動轉碼而成,過程無人工干預。阿里雲不保證此自動轉碼的準確性、完整性及時效性。因轉碼造成的任何內容錯誤及因此可能帶來的損失,阿里雲概不負責,敬請見諒。本文内容請以簡體中文版本為準。
全部產品
Search
文件中心

Windows伺服器遠端桌面提示“沒有遠端桌面授權伺服器可以提供許可證”錯誤

更新時間: Aug 07, 2019

免責聲明:本文檔可能包含第三方產品資訊,該資訊僅供參考。阿里雲對第三方產品的效能、可靠性以及操作可能帶來的潛在影響,不做任何暗示或其他形式的承諾。

 

問題描述

  1. 使用遠端桌面連線Windows伺服器,輸入正確的使用者名稱和密碼後,無法正常遠端連線,並提示如下錯誤資訊。
    a.png
  2. 通過管理終端串連Windows執行個體, 開啟 RD授權診斷程式,提示如下錯誤資訊。
    b.png

 

問題原因

該問題的原因可能有以下兩種。

  • 他人登入
    該帳號有其他人在登入,由於終端服務配置RDP-TCP限制每個使用者只能進行一個會話,所以其他會話無法建立。

 

  • 安裝了遠端桌面工作階段主機角色
    • 在系統內安裝了遠端桌面工作階段主機角色,此功能免費試用120天,之後需要進行付費。如果沒有付費會造成無法通過管理終端串連。
    • 正常情況下,Windows伺服器預設提供兩個使用者的免費遠端桌面管理授權。如果有更高的串連需求,則需要配置遠端桌面工作階段主機伺服器角色,同時購買和配置相應的授權後,才可以使用更多的遠端桌面管理並發。
    • 另一方面,在配置遠端桌面工作階段主機角色後,會同時取消預設兩個使用者的免費串連授權。在沒有正確配置相關授權的時候,會導致遠端桌面無法串連,並出現上述錯誤提示。

 

解決方案

根據實際情況,參考以下兩種解決方案。

 

他人登入

取消RDP-TCP限制每個使用者只能進行一個會話,具體步驟如下。

  1. 通過管理終端串連Windows執行個體。
  1. 選擇 開始,單擊 運行,在開啟框中輸入 gpedit.msc,單擊 確定
  1. 進入本機群組原則編輯器頁面,選擇 電腦配置 > 系統管理範本 > Windows 組件,雙擊 遠端桌面服務

  2. 雙擊 遠端桌面工作階段主機 > 串連
  3. 單擊 限制串連的數量,在彈出的視窗中,選擇 已啟用,在 允許 RD 最大串連數 框中,輸入需要的最大串連數,單擊 確定
    註:允許RD 最大串連數本文以3為例,現場以實際環境為準。

  4. 選擇 開始,單擊 運行,在開啟框中輸入 cmd,單擊 確定。開啟命令列,執行如下命令。
    gpupdate
    系統顯示類似如下。

 

安裝了遠端桌面工作階段主機角色

安裝遠端桌面工作階段主機導致無法遠程Windows伺服器,請參考如下兩種解決方案。

 

方法一

配置遠端桌面工作階段主機伺服器後,在微軟官網購買和配置相應的認證授權,相關操作方法可以參閱微軟官方文檔

 

方法二

刪除遠端桌面工作階段主機角色,使用預設兩個使用者的免費串連授權。參考以下步驟對不同版本的Windows伺服器進行配置。

 

Windows 2012作業系統

  1. 通過管理終端串連Windows執行個體。
  1. 選擇 開始,單擊 運行,在開啟框中輸入 servermanager.msc,單擊 確定
  1. 進入伺服器管理員頁面,選擇 管理 > 刪除角色和功能

  1. 進入刪除功能和角色頁面,單擊下一步,單擊下一步
  1. 角色 框中,取消勾選 遠端桌面服務,其它配置預設,單擊 下一步

  1. 在Windows執行個體內重啟執行個體。

 

Windows 2008作業系統

  1. 通過管理終端串連Windows執行個體。
  1. 選擇 開始,單擊 運行,在開啟框中輸入 servermanager.msc,單擊 確定
  1. 進入伺服器管理頁面,單擊 角色,按右鍵 遠端桌面服務 ,選擇 刪除角色服務

  1. 在快顯視窗中,取消勾選 遠端桌面工作階段主機 ,單擊 下一步,等待配置完成。
    a.jpg
  2. 在Windows執行個體內重啟執行個體。

 

Windows 2003作業系統

  1. 通過管理終端串連Windows執行個體。
  1. 選擇 開始 > 控制台
  1. 選擇 添加或者刪除程式 > 添加/刪除 Windows 組件
  1. 取消勾選 終端伺服器,單擊 下一步。在彈出的視窗中,單擊完成
    jAhoeSorVNsLmOoFHFqB.png
  1. 在Windows執行個體內重啟執行個體。

 

適用於

  • Elastic Compute Service

 

如果您的問題仍未解決,您可以在阿里雲社區免費諮詢,或提交工單聯絡阿里雲支援人員。