本文主要介紹遷移在SMC遷移時,遷移任務出錯提示“Client.Rsync.SyncStuck”的原因及解決方案。
問題描述
在SMC遷移時,遷移任務出錯提示“Client.Rsync.SyncStuck”。
問題原因
源系統磁碟分割檔案資料同步卡住,導致遷移任務逾時。
解決方案
檢查源系統到目標執行個體的
IP:8703連接埠網路是否正常穩定,源系統頻寬速度是否足夠,防止因網路頻寬過小導致的傳輸進度過慢而逾時。具體檢查方式請參考評估遷移時間與測試傳輸速度。檢查源系統磁碟分割是否存在以下情況並處理:
動態變化的大檔案,如資料庫資料檔案或記錄檔。
可以考慮在合適的時間點暫停相關資料商務服務,確保遷移的過程中大檔案不再動態變化後再試。
使用過濾配置排除相關目錄後再試,具體操作,請參見如何過濾、排除不需要遷移的檔案或目錄。對於未遷移的檔案或目錄,後續可考慮用其他方案遷移。
大量小檔案,如Distributed File System海量資料、檔案伺服器等。
使用過濾配置排除相關目錄後再試,具體操作,請參見如何過濾、排除不需要遷移的檔案或目錄。對於未遷移的檔案或目錄,後續可考慮用其他方案遷移。
問題排查解決後,您可運行SMC用戶端進行驗證。