Todos os produtos
Search
Central de documentação

Server Load Balancer:CreateListener

Última atualização: Jun 28, 2026

Cria um listener para uma instância de Gateway Load Balancer (GWLB).

Descrição da operação

A operação CreateListener é assíncrona. Após o envio de uma solicitação, o sistema retorna um ID de solicitação. O listener é criado em segundo plano. Você pode chamar a operação GetListenerAttribute para consultar o status de criação do listener:

  • Se um listener estiver no estado Provisioning, o listener está sendo criado.

  • Se um listener estiver no estado Running, o listener foi criado.

Experimente agora

Experimente esta API no OpenAPI Explorer, sem necessidade de assinatura manual. Chamadas bem-sucedidas geram automaticamente código SDK correspondente aos seus parâmetros. Faça o download com segurança de credenciais integrada para uso local.

Testar

Autorização RAM

A tabela abaixo descreve a autorização necessária para chamar esta API. Você pode defini-la em uma política do Resource Access Management (RAM). As colunas da tabela estão detalhadas abaixo:

  • Ação: As ações que podem ser usadas no elemento Action das instruções de política de permissão do RAM para conceder permissões para executar a operação.

  • API: A API que você pode chamar para executar a ação.

  • Nível de acesso: O nível de acesso predefinido concedido para cada API. Valores válidos: create, list, get, update e delete.

  • Tipo de recurso: O tipo de recurso que suporta autorização para executar a ação. Indica se a ação suporta permissão em nível de recurso. O recurso especificado deve ser compatível com a ação. Caso contrário, a política será ineficaz.

    • Para APIs com permissões em nível de recurso, os tipos de recursos obrigatórios são marcados com um asterisco (*). Especifique o Nome de Recurso Alibaba Cloud (ARN) correspondente no elemento Resource da política.

    • Para APIs sem permissões em nível de recurso, é exibido como Todos os Recursos. Use um asterisco (*) no elemento Resource da política.

  • Chave de condição: As chaves de condição definidas pelo serviço. A chave permite controle granular, aplicando-se somente a ações ou a ações associadas a recursos específicos. Além das chaves de condição específicas do serviço, o Alibaba Cloud fornece um conjunto de chaves de condição comuns aplicáveis a todos os serviços compatíveis com RAM.

  • Ação dependente: As ações dependentes necessárias para executar a ação. Para concluir a ação, o usuário RAM ou a função RAM deve ter permissões para executar todas as ações dependentes.

Ação

Nível de acesso

Tipo de recurso

Chave de condição

Ação dependente

gwlb:CreateListener

create

*LoadBalancer

acs:gwlb:{#regionId}:{#accountId}:loadbalancer/{#LoadbalancerId}

*ServerGroup

acs:gwlb:{#regionId}:{#accountId}:servergroup/{#ServerGroupId}

*Listener

acs:gwlb:{#regionId}:{#accountId}:listener/*

Nenhuma Nenhuma

Parâmetros da solicitação

Parâmetro

Tipo

Obrigatório

Descrição

Exemplo

LoadBalancerId

string

Sim

O ID da instância GWLB.

gwlb-te609d6696632f7*****

ListenerDescription

string

Não

A descrição do listener.

A descrição deve ter de 2 a 256 caracteres. Pode conter caracteres chineses, letras, dígitos, vírgulas (,), pontos (.), ponto e vírgula (;), barras (/), arrobas (@), sublinhados (_) e hifens (-).

listener-description

ServerGroupId

string

Sim

O ID do grupo de servidores.

sgp-ckh01px70dszof****

TcpIdleTimeout

integer

Não

O período de tempo limite de uma conexão TCP ociosa.

Valores válidos: 60 a 6000 segundos.

Valor padrão: 350 segundos.

350

DryRun

boolean

Não

Especifica se deve ser realizado um dry run. Valores válidos:

  • true: Realiza um dry run. O sistema verifica os parâmetros obrigatórios, o formato da solicitação e os limites do serviço. Se a solicitação falhar no dry run, uma mensagem de erro será retornada. Se a solicitação passar no dry run, o código de erro DryRunOperation será retornado.

  • false (padrão): Envia a solicitação. Se a solicitação passar na verificação, um código de status HTTP 2xx será retornado e a operação será executada.

false

ClientToken

string

Não

O token de cliente usado para garantir a idempotência da solicitação.

Você pode usar o cliente para gerar um token, mas deve garantir que o token seja exclusivo entre diferentes solicitações. O token pode conter apenas caracteres ASCII.

Nota

Se você não especificar este parâmetro, o sistema usará automaticamente o RequestId da solicitação como o ClientToken. O RequestId pode ser diferente para cada solicitação.

123e4567-e89b-12d3-a456-42665544****

Tag

array<object>

Não

As tags. Você pode especificar até 20 tags em cada chamada.

object

Não

A tag.

Key

string

Não

A chave da tag. Se você especificar este parâmetro, não poderá deixá-lo vazio. A chave da tag pode ter até 128 caracteres e não pode começar com aliyun ou acs:. Não pode conter http:// ou https://.

testKey

Value

string

Não

O valor da tag. O valor da tag pode ter até 256 caracteres e não pode conter http:// ou https://.

testValue

Elementos de resposta

Elemento

Tipo

Descrição

Exemplo

object

Os dados retornados.

ListenerId

string

O ID do listener.

lsn-wi3c0v30ivysrg****

RequestId

string

O ID da solicitação.

A045E652-D298-5E70-A978-7247135336FB

Exemplos

Resposta de sucesso

JSON formato

{
  "ListenerId": "lsn-wi3c0v30ivysrg****",
  "RequestId": "A045E652-D298-5E70-A978-7247135336FB"
}

Códigos de erro

Código de status HTTP

Código de erro

Mensagem de erro

Descrição

400 IncorrectBusinessStatus.LoadBalancer The business status of %s [%s] is incorrect. Resource %s with business state %s does not support current operation
400 MissingParam.TagKey The param of TagKey is missing. The parameter of tag key is missing.
400 MissingParam.TagValue The param of TagValue is missing. The parameter of tag value is missing.
400 OperationDenied.TooManyListeners The operation is not allowed because of TooManyListener. The number of listeners of the load balancer instance exceeds the limit. The operation is denied.
400 IncorrectStatus.LoadBalancer The status of %s [%s] is incorrect. Resource %s current state %s does not support operation
400 ResourceInUse.IP The specified resource of IP is in use.
400 Mismatch.VpcId The %s is mismatched for %s and %s. The VPC IDs of the two resources do not match.
400 IncorrectStatus.ServerGroup The status of %s [%s] is incorrect. The status of %s [%s] is incorrect.
400 DuplicatedParam.TagKey The param of %s is duplicated. The parameter of tag key is duplicated.
400 IllegalParam.TagKey The param of %s is illegal.
400 IllegalParam.TagValue The param of %s is illegal. The parameter of tag value is illegal.
400 OperationDenied.TcpIdleTimeoutConflictWithScheduler The TCP idle timeout of listener must be default value when the scheduling algorithm of server group is not 5TCH. The TCP idle timeout of listener must be default value when the scheduling algorithm of server group is not 5TCH.
404 ResourceNotFound.LoadBalancer The specified resource of %s is not found. The specified resource of .LoadBalancer is not found.
404 ResourceNotFound.ServerGroup The specified resource of %s is not found. The specified server group resource does not exist.

Consulte Códigos de Erro para uma lista completa.

Notas de versão

Consulte Notas de Versão para uma lista completa.