Todos os produtos
Search
Central de documentação

:Enable and disable release protection

Última atualização: Jun 26, 2026

Se sua instância do ApsaraDB RDS Custom hospeda serviços críticos, armazena dados importantes ou possui configurações essenciais, recomendamos ativar a proteção contra liberação. Esse recurso impede que a instância seja liberada acidentalmente, o que poderia causar consequências irreversíveis. Após ativar a proteção contra liberação, não é possível liberar a instância manualmente pelo console ou por meio de uma API.

Precauções

A proteção contra liberação não impede que uma instância seja liberada automaticamente nas seguintes situações:

  • A instância é liberada automaticamente devido a um pagamento atrasado há mais de 15 dias.

  • A instância é liberada automaticamente após a expiração da assinatura.

  • A instância é interrompida ou liberada devido a riscos de segurança ou conformidade.

Efeitos da proteção contra liberação

Ao tentar liberar uma instância com a proteção contra liberação ativada, a operação falha da seguinte forma:

  • Se você tentar liberar a instância manualmente no console, a operação falhará e uma mensagem de erro será exibida.

  • Se você chamar a operação de API DeleteRCInstances para liberar a instância, a chamada falhará e retornará uma mensagem de erro.

Ativar ou desativar a proteção contra liberação

É possível ativar ou desativar esse recurso durante a criação da instância ou a qualquer momento posterior.

Para uma instância existente

  1. Faça login no console do RDS. No painel de navegação à esquerda, clique em RDS Custom > Custom Instances. Na barra de navegação superior, selecione uma região.

  2. Na coluna Actions da instância desejada, clique em More > Enable Release Protection ou More > Disable Release Protection.

    Alternativamente, na página Basic Information da instância, na seção Configuration Information, clique em Configure ao lado de Release Protection.

  3. Na caixa de diálogo exibida, clique em OK.

Durante a criação da instância

Ao criar uma instância do RDS Custom, na seção More, selecione Prevents instances to be deleted by using the console or calling an API operation by mistake..

Verificar o status da proteção contra liberação

  1. Faça login no console do RDS. No painel de navegação à esquerda, clique em RDS Custom > Custom Instances. Na barra de navegação superior, selecione uma região.

  2. Clique no ID da instância para acessar sua página Basic Information.

  3. Na seção Configuration Information, visualize o campo Release Protection.

APIs relacionadas

Referências

Visão geral do ApsaraDB RDS Custom