Todos os produtos
Search
Central de documentação

:ReplaceSystemDisk

Última atualização: Jul 03, 2026

Substitui o sistema operacional de uma instância do Elastic Compute Service (ECS). Após a substituição do sistema operacional, o disco original é liberado e um novo disco de sistema é criado. Consequentemente, o ID do disco de sistema muda.

Observações de uso

Observe os seguintes pontos:

  • Não é possível alterar a categoria do disco de sistema.

  • Não é possível modificar o método de faturamento do disco de sistema.

  • A instância deve estar no estado Stopped.

    Nota

    Este item aplica-se apenas a instâncias em Virtual Private Clouds (VPCs). Se a instância for do tipo pagamento conforme o uso e o modo econômico estiver ativado por padrão, desative o modo econômico e ative o modo padrão ao parar a instância. Essa medida evita falhas na reinicialização devido à insuficiência de recursos do ECS após a substituição do disco de sistema. Para mais informações, consulte StopInstance.

  • Se a resposta contiver {"OperationLocks": {"LockReason" : "security"}}, a instância está bloqueada por motivos de segurança e nenhuma operação é permitida. Para mais informações, consulte Comportamento da API quando uma instância é bloqueada por motivos de segurança.

  • Não deve haver pedidos pendentes de pagamento associados à instância.

  • Configure o parâmetro SystemDisk.Size para especificar a capacidade do novo disco de sistema.

Após chamar esta operação, use um dos métodos abaixo para verificar se o disco de sistema foi substituído:

  • Chame a operação DescribeDisks para consultar o estado do novo disco de sistema. Se o novo disco estiver no estado In_use, a substituição foi concluída.

  • Chame a operação DescribeInstances para consultar o estado da instância cujo disco de sistema foi substituído. Se o parâmetro de resposta OperationLocks estiver vazio, a substituição foi concluída.

Depuração

O OpenAPI Explorer calcula automaticamente o valor da assinatura. Recomendamos chamar esta operação no OpenAPI Explorer para maior conveniência. O OpenAPI Explorer gera dinamicamente o código de exemplo da operação para diferentes SDKs.

Parâmetros de solicitação

Parâmetro

Tipo

Obrigatório

Exemplo

Descrição

Action

String

Yes

ReplaceSystemDisk

A operação a ser executada. Defina o valor como ReplaceSystemDisk.

InstanceId

String

Yes

i-bp67acfmxazb4ph****

O ID da instância.

ImageId

String

No

m-bp67acfmxazb4ph****

O ID da imagem usada para substituir o disco de sistema.

Se você não configurar o parâmetro DiskId, este parâmetro será obrigatório.

SystemDisk.Size

Integer

No

80

A capacidade do novo disco de sistema. Unidade: GiB. Valores válidos:

  • Disco básico: Max{20, Tamanho da imagem especificada pelo parâmetro ImageId} até 500.

  • Outro tipo de disco: Max{20, Tamanho da imagem especificada pelo parâmetro ImageId} até 2048.

Valor padrão: Max{40, Tamanho da imagem especificada pelo parâmetro ImageId}.

Nota

Se a capacidade do novo disco de sistema exceder Max{20, Capacidade do disco de sistema original}, haverá cobrança pela capacidade excedente.

ClientToken

String

No

123e4567-e89b-12d3-a456-426655440000

O token de cliente usado para garantir a idempotência da solicitação. Use o cliente para gerar o token, mas certifique-se de que ele seja único entre diferentes solicitações. O token pode conter apenas caracteres ASCII e não pode exceder 64 caracteres. Para mais informações, consulte Como garantir a idempotência.

UseAdditionalService

Boolean

No

true

Especifica se as configurações de sistema para máquinas virtuais fornecidas pelo Alibaba Cloud devem ser usadas. Configurações para Windows: NTP e KMS. Configurações para Linux: NTP e YUM.

Nota

Este parâmetro só tem efeito se você anexar um disco de sistema cujo nome de dispositivo seja /dev/xvda.

Password

String

No

EcsV587!

Define se a senha da instância deve ser redefinida. A senha deve ter entre 8 e 30 caracteres e conter pelo menos três dos seguintes tipos de caracteres: letras maiúsculas, letras minúsculas, dígitos e caracteres especiais. Os seguintes caracteres especiais são permitidos:

()`~!@#$%^&*-_+=|{}[]:;'<>,.?/

A senha de uma instância Windows não pode começar com uma barra (/).

Por padrão, este parâmetro está vazio, indicando que a senha atual permanece inalterada.

Nota

Por motivos de segurança, recomendamos usar HTTPS para enviar solicitações quando o parâmetro Password for especificado.

PasswordInherit

Boolean

No

false

Especifica se a senha predefinida na imagem deve ser utilizada.

Valor padrão: false.

Nota

Ao configurar o parâmetro PasswordInherit, deixe o parâmetro Password vazio e certifique-se de que a imagem selecionada possua uma senha predefinida.

KeyPairName

String

No

testKeyPairName

O nome do par de chaves.

Nota

Este parâmetro aplica-se apenas a instâncias Linux. É possível vincular um par de chaves SSH à instância como credencial de login. Após vincular o par de chaves SSH, o método de login por usuário e senha é desativado para a instância.

DiskId

String

No

d-bp67acfmxazb4ph****

Nota

Este parâmetro foi descontinuado. Recomendamos o uso do parâmetro ImageId para garantir compatibilidade.

Platform

String

No

CentOS

Nota

Este parâmetro foi descontinuado.

Architecture

String

No

i386

Nota

Este parâmetro foi descontinuado.

SecurityEnhancementStrategy

String

No

Active

Especifica se o Security Center deve ser usado gratuitamente após a substituição do disco de sistema. Valores válidos:

  • Active: usa o Security Center gratuitamente após a substituição do disco de sistema. Este valor aplica-se apenas a imagens públicas.

  • Deactive: não usa o Security Center gratuitamente após a substituição do disco de sistema. Este valor aplica-se a todas as imagens.

Valor padrão: Deactive.

Encrypted

Boolean

No

false

Especifica se o novo disco de sistema deve ser criptografado. Valores válidos:

  • true

  • false

Valor padrão: false.

KMSKeyId

String

No

e522b26d-abf6-4e0d-b5da-04b73c

O ID da chave do Key Management Service (KMS) a ser usada para o disco de sistema.

EncryptAlgorithm

String

No

hide

Nota

Este parâmetro não está disponível publicamente.

Arn.N.RoleType

String

No

null

Nota

Este parâmetro não está disponível publicamente.

Arn.N.Rolearn

String

No

null

Nota

Este parâmetro não está disponível publicamente.

Arn.N.AssumeRoleFor

Long

No

0

Nota

Este parâmetro não está disponível publicamente.

Parâmetros de resposta

Parâmetro

Tipo

Exemplo

Descrição

DiskId

String

d-bp67acfmxazb4ph****

O ID do novo disco de sistema.

RequestId

String

473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E

O ID da solicitação.

Exemplos

Exemplos de solicitações

http(s)://ecs.aliyuncs.com/?Action=ReplaceSystemDisk
&InstanceId=i-bp67acfmxazb4ph****
&ImageId=m-bp67acfmxazb4ph****
&SystemDisk.Size=80
&ClientToken=123e4567-e89b-12d3-a456-426655440000
&UseAdditionalService=true
&Password=EcsV587!
&PasswordInherit=false
&KeyPairName=testKeyPairName
&SecurityEnhancementStrategy=Active
&<Common request parameters>

Exemplos de respostas de sucesso

Formato XML

HTTP/1.1 200 OK
Content-Type:application/xml

<ReplaceSystemDiskResponse>
    <DiskId>d-bp67acfmxazb4ph****</DiskId>
    <RequestId>F3CD6886-D8D0-4FEE-B93E-1B73239673DE</RequestId>
</ReplaceSystemDiskResponse>

Formato JSON

HTTP/1.1 200 OK
Content-Type:application/json

{
  "RequestId" : "337568C5-64F3-4B76-8CDD-D3D8C57B5B8C",
  "DiskId" : "d-bp67acfmxazb4ph****"
}

Códigos de erro

Código de status HTTP

Código de erro

Mensagem de erro

Descrição

400

LoginAsNonRoot.ImageNotSupport

The specified image does not support login as non-root.

A imagem não suporta logins de usuários não root.

400

InvalidSystemDiskSize.ValueNotSupported

The specified parameter SystemDisk.Size is invalid.

Valor inválido para SystemDisk.Size.

400

InvalidParameter.Conflict

The specified image does not support the specified instance type.

A imagem não pode ser usada para instâncias deste tipo.

400

InvalidSystemDiskSize.ImageNotSupportResize

The specified image does not support resize.

A imagem especificada não suporta redimensionamento.

400

InvalidSystemDiskSize

The specified parameter SystemDisk.Size is invalid.

Valor inválido para SystemDisk.Size.

400

InvalidPasswordParam.Mismatch

The input password should be null when passwdInherit is true.

A senha não foi deixada em branco quando PasswdInherit foi definido como true.

400

OperationDenied

The specified image contains the snapshot of the data disk,does not support this operation.

A operação não é permitida quando a imagem especificada contém snapshots de disco de dados.

400

InvalidParameter.Conflict

%s

Valor de parâmetro inválido. Verifique se existem conflitos de parâmetros. %s é uma variável. Uma mensagem de erro é retornada dinamicamente com base nas condições da chamada.

400

InvalidSystemDiskSize.ValueNotSupported

%s

Valor inválido para SystemDisk.Size.

400

OperationDenied

%s

A operação foi negada.

400

InvalidKeyPairName.NotFound

The specified KeyPairName does not exist.

O KeyPairName não foi encontrado.

400

DependencyViolation.IoOptimize

The specified parameter InstanceId is not valid.

Configuração de otimização de I/O da instância inválida.

400

MissingParameter.Architecture

Architecture should not be null.

O parâmetro Architecture é obrigatório.

400

InvalidArchitecture.Malformed

Architecture is not valid.

Valor inválido para Architecture.

400

MissingParameter.Platform

Platform should not be null.

O parâmetro Platform é obrigatório.

400

InvalidPlatform.Malformed

Platform is not valid.

Valor inválido para Platform.

400

InvalidParameter.AllEmpty

%s

Os parâmetros obrigatórios não foram especificados.

400

InvalidDiskId.NotFound

The specified disk do not exist.

O DiskId não foi encontrado.

400

InvalidDatadisk.DiskStatusViolation

The operation is not permitted due to status of the Datadisk.

O disco de dados no estado atual não suporta esta operação.

400

InvalidDatadisk.DiskCategoryViolation

The operation is not permitted due to category of the Datadisk.

O disco de dados desta categoria não suporta esta operação.

400

InvalidSystemDiskSize.ValueNotSupported

The specified SystemDiskSize is not valid.

Valor inválido para SystemDisk.Size.

400

InvalidInstance.NotFoundSystemDisk

The specified instance has no system disk.

A instância especificada não possui disco de sistema anexado. Certifique-se de que a instância tenha um disco de sistema anexado. Chame a operação DescribeInstances para consultar os detalhes da instância.

400

InvalidStorageClusterId.CapacityNotEnough

The remaining capacity of the current dedicated storage cluster is less than the size of disk.

A capacidade restante do cluster de armazenamento em bloco dedicado ao qual o disco pertence é insuficiente.

400

QuotaExceed.DiskCapacity

The used capacity of disk type has exceeded the quota in the zone, %s.

A capacidade utilizada de discos desta categoria excede o limite de cota da zona. Acesse o Quota Center para visualizar e aumentar a cota de capacidade de disco.

403

InvalidSystemDiskStatus.IsTransfering

The current status of the resource does not support this operation, system disk is transfering.

O recurso no estado atual não suporta esta operação. Tente novamente após o disco de sistema parar de transmitir dados.

403

IncorrectDiskStatus

The current disk status does not support this operation.

Esta operação não pode ser realizada no disco no estado atual. Certifique-se de que o disco esteja disponível e sem pagamentos pendentes.

403

IncorrectInstanceStatus

The current status of the resource does not support this operation.

O recurso no estado atual não suporta esta operação.

403

InstanceLockedForSecurity

The instance is locked due to security.

A operação não é permitida quando o recurso está bloqueado por motivos de segurança.

403

ImageNotSubscribed

The specified image has not be subscribed.

Você não assinou a imagem no Alibaba Cloud Marketplace.

403

ImageRemovedInMarket

The specified market image is not available, Or the specified user defined image includes product code because it is based on an image subscribed from marketplace, and that image in marketplace includeing exact the same product code has been removed.

A imagem do Alibaba Cloud Marketplace está indisponível, ou a imagem personalizada contém o código de produto da imagem do Alibaba Cloud Marketplace da qual foi derivada, e essa imagem original foi removida do Alibaba Cloud Marketplace.

403

InstanceExpiredOrInArrears

The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode).

A instância expirou ou possui pagamentos pendentes. Renove ou conclua o pagamento da instância e tente novamente.

403

ChargeTypeViolation

The operation is not permitted due to charge type of the instance.

Esta operação não pode ser realizada na instância com o método de faturamento atual.

403

DiskCreatingSnapshot

The operation is denied due to a snapshot of the specified disk is not completed yet.

Um snapshot está sendo criado para o disco especificado.

403

IoOptimized.NotSupported

The specified image is not support IoOptimized Instance.

A imagem não suporta instâncias otimizadas para I/O.

403

ImageNotSupportInstanceType

The specified image don not support the InstanceType instance.

A imagem especificada não suporta o tipo de instância.

403

QuotaExceed.BuyImage

The specified image is from the image market,You have not bought it or your quota has been exceeded.

Você não comprou a imagem especificada do Alibaba Cloud Marketplace ou sua cota de imagens foi esgotada.

403

INST_HAS_UNPAID_ORDER

The instance has unpaid order.

Sua conta possui pedidos pendentes de pagamento para a instância.

403

OperationDenied.InstanceCreating

The specified instance is creating.

A instância especificada está sendo criada.

403

InvalidParameter.NotMatch

%s

Valor de parâmetro inválido. Verifique se existem conflitos de parâmetros.

403

ResourcesNotInSameZone

The specified instance and disk are not in the same zone.

A instância e o disco não residem na mesma zona.

403

ImageNotSupportInstanceType

The specified instanceType is not supported by instance with marketplace image.

A imagem especificada do Alibaba Cloud Marketplace não suporta o tipo de instância.

403

OperationDenied.UnpaidOrder

The specified instance has unpaid order.

Existem pedidos pendentes de pagamento para a instância. Faça login no console do ECS para pagar os pedidos.

403

OperationDenied.ImageNotValid

%s

A imagem não suporta esta operação.

403

HibernationConfigured.InstanceOperationForbidden

The operation is not permitted due to limit of the hibernation configured instance.

A operação não é permitida devido às limitações de instâncias com o recurso de hibernação ativado.

403

InvalidOperation.MultiAttachDisk

Multi attach disk does not support this operation.

O disco com o recurso multi-attach ativado não suporta esta operação.

403

InvalidParameter.KmsNotEnabled

The specified operation need enable KMS.

É necessário ativar o KMS.

403

InvalidParameter.KMSKeyId.NotFound

The specified KMSKeyId does not exist.

O KMSKeyId não foi encontrado.

403

InvalidParameter.KMSKeyId.CMKNotEnabled

The CMK needs to be enabled.

O CMK não está ativado quando seu ID é especificado para um disco. Chame a operação DescribeKey do KMS para consultar informações sobre o CMK especificado.

403

InvalidParameter.KMSKeyId.KMSUnauthorized

ECS service have no right to access your KMS.

O ECS não tem autorização para acessar seus recursos do KMS.

404

InvalidInstanceId.NotFound

The specified InstanceId does not exist.

O InstanceId não foi encontrado.

404

InvalidInstanceId.NotFound

The specified instance does not exist.

A instância não foi encontrada. Verifique se o ID da instância está correto.

404

InvalidImageId.NotFound

The specified ImageId does not exist.

A imagem não foi encontrada nesta conta. Verifique se o ID da imagem está correto.

404

InvalidSystemDiskSize.MoreThanMaxSize

The specified SystemDisk.Size parameter exceeds the maximum size.

O tamanho máximo do disco de sistema foi excedido.

404

InvalidSystemDiskSize.LessThanImageSize

The specified parameter SystemDisk.Size is less than the image size.

O tamanho do disco de sistema é menor que o tamanho da imagem.

404

InvalidSystemDiskSize.LessThanMinSize

The specified parameter SystemDisk.Size is less than the min size.

O tamanho do disco de sistema especificado é menor que o tamanho mínimo permitido.

404

NoSuchResource

The specified resource is not found.

O recurso especificado não foi encontrado.

500

OperationDenied

Internal Error.

Ocorreu um erro interno.

500

InternalError

The request processing has failed due to some unknown error.

Ocorreu um erro interno. Tente novamente mais tarde.

500

InternalError

The request processing has failed due to some unknown error, exception or failure.

Ocorreu um erro interno. Tente novamente mais tarde.

Para obter uma lista de códigos de erro, consulte Códigos de erro do serviço.