Todos os produtos
Search
Central de documentação

Data Transmission Service:Migrar do RDS MySQL para um banco de dados Oracle autogerenciado

Última atualização: Jul 17, 2026

Use o Data Transmission Service (DTS) para migrar dados de uma instância ApsaraDB RDS for MySQL para um banco de dados Oracle autogerenciado.

Pré-requisitos

Observações de uso

Nota

Durante a migração completa e incremental de dados:

  • Inconsistências de dados podem ocorrer se existirem operações de atualização ou exclusão em cascata no banco de dados de origem.

  • Desative chaves estrangeiras ou triggers caso existam no banco de dados de destino. Caso contrário, a tarefa de migração de dados poderá falhar.

Tipo

Descrição

Limites do banco de dados de origem

  • As tabelas a serem migradas devem possuir uma chave primária ou uma restrição única, e os valores nas colunas restritas precisam ser exclusivos. Caso contrário, dados duplicados poderão surgir no banco de dados de destino.

  • Ao migrar dados no nível de tabela com necessidade de edição (como mapeamento de nomes de tabelas ou colunas), uma única tarefa de migração suporta até 1.000 tabelas. Se esse limite for excedido, o envio da tarefa falhará com um erro. Nesse cenário, divida as tabelas em vários lotes para migração ou configure uma tarefa para migrar todo o banco de dados.

  • Para utilizar migração incremental, ative o log binário:

    • Defina binlog_format como ROW e binlog_row_image como FULL. Do contrário, a pré-verificação falhará e a tarefa não poderá ser iniciada.

      Importante

      Se sua origem MySQL autogerenciada for um cluster dual-master — onde cada instância atua simultaneamente como master e slave — ative o parâmetro log_slave_updates. Isso garante que o DTS consiga ler todos os logs binários.

    • Para instâncias RDS for MySQL, retenha os logs binários locais por pelo menos três dias (sete dias é o recomendado). Para bancos de dados MySQL autogerenciados, mantenha os logs binários locais por no mínimo sete dias. A tarefa falhará se o DTS não conseguir acessar os logs binários. Em casos extremos, pode haver inconsistência ou perda de dados. Problemas causados por períodos de retenção de logs binários inferiores aos exigidos pelo DTS não são cobertos pelo SLA do serviço.

      Nota

      Para definir o retention period dos logs binários locais em uma instância RDS for MySQL, consulte Excluir automaticamente logs locais.

  • Não execute operações DDL que alterem o schema do banco de dados ou das tabelas durante as fases de migração de schema e migração completa. Tais operações causam falha na tarefa de migração de dados.

    Nota

    Na fase de migração completa, o DTS consulta o banco de dados de origem. Essa ação cria um bloqueio de metadados que pode impedir operações DDL no banco de origem.

  • Evite gravar novos dados no banco de origem se estiver executando apenas uma migração completa de dados. Essa prática gera inconsistência entre os bancos de origem e destino. Para manter a consistência dos dados em tempo real, selecione migração de schema, migração completa de dados e migração incremental de dados.

  • Instâncias RDS for MySQL que não registram logs de transações — como instâncias somente leitura do RDS for MySQL 5.6 — não são suportadas como origem quando a migração incremental é necessária.

  • O DTS não migra dados gerados por alterações que não escrevem em logs binários. Exemplos incluem dados restaurados de backups físicos ou criados por operações em cascata.

    Nota

    Se isso ocorrer, execute novamente a migração completa assim que sua aplicação permitir.

  • O DTS não consegue ler colunas ocultas invisíveis se o banco de dados MySQL de origem for versão 8.0.23 ou posterior e contiver tais colunas. Isso pode resultar em perda de dados.

    Nota

    Execute ALTER TABLE <table_name> ALTER COLUMN <column_name> SET VISIBLE; para tornar a coluna oculta visível. Para mais informações, consulte Invisible Columns.

Outros limites

  • Não utilize ferramentas como pt-online-schema-change para executar operações DDL online nos objetos de migração do banco de dados de origem. Isso causa falha na tarefa de migração de dados.

  • Perda de dados ou falha na tarefa podem ocorrer no banco de destino se o banco de origem usar operações DDL online no modo de tabela temporária — incluindo cenários de mesclagem de múltiplas tabelas — ou adicionar índices baseados em funções a colunas de chave única.

  • Para colunas dos tipos FLOAT ou DOUBLE, o DTS utiliza ROUND(COLUMN,PRECISION) para ler os valores. Sem uma precisão definida explicitamente, o DTS adota uma precisão de migração padrão de 38 para FLOAT e 308 para DOUBLE. Verifique se a precisão de migração atende aos requisitos do seu negócio.

  • Avalie o desempenho dos bancos de dados de origem e destino antes de iniciar a migração. Recomendamos migrar em horários de baixa demanda, pois a migração completa consome recursos de leitura e escrita em ambos os bancos, podendo aumentar a carga.

  • Operações INSERT concorrentes durante a migração completa causam fragmentação de tabelas no banco de destino. Consequentemente, após a conclusão da migração completa, as tabelas no banco de destino ocuparão mais tablespace do que na instância de origem.

  • O DTS tenta retomar tarefas com falha dentro de sete dias. Antes de transferir suas cargas de trabalho para a instância de destino, pare ou libere a instância, ou use o comando REVOKE para revogar as permissões de escrita da conta usada pelo DTS para acessar a instância de destino. Isso impede que a tarefa seja retomada automaticamente e sobrescreva os dados de destino.

  • A migração completa não é suportada se a instância RDS for MySQL tiver Always-Encrypted ativado.

    Nota

    Instâncias RDS for MySQL com Transparent Data Encryption (TDE) ativado suportam migração de schema, migração completa e migração incremental.

  • Em caso de falha na tarefa, a equipe de suporte do DTS tentará restaurá-la em até oito horas. Durante a restauração, eles podem reiniciar a tarefa ou ajustar seus parâmetros.

    Nota

    Apenas os parâmetros da tarefa DTS são modificados — não os parâmetros do banco de dados. Os parâmetros passíveis de ajuste incluem aqueles listados em Modificar parâmetros da instância.

Casos especiais

  • Para origens MySQL autogerenciadas:

    • Um failover entre master e standby no banco de origem causa falha na tarefa de migração.

    • O cálculo de latência do DTS compara o timestamp do último registro migrado para o banco de destino com a hora atual. A medição de latência torna-se imprecisa se nenhuma operação DML for executada na origem por um longo período. Execute uma operação DML na origem para atualizar o valor de latência caso ele pareça excessivamente alto.

      Nota

      Crie uma tabela de heartbeat e atualize-a ou grave nela a cada segundo se optar pela migração de banco completo.

    • Periodicamente, o DTS executa CREATE DATABASE IF NOT EXISTS test no banco de origem para avançar o offset do log binário.

    • Garanta que o nome de domínio ou endereço IP configurado para a tarefa — bem como sua resolução DNS — aponte sempre para um nó de leitura e escrita (RW) se a origem for Amazon Aurora MySQL ou outra instância MySQL em cluster. A tarefa de migração pode falhar caso contrário.

  • Para origens RDS for MySQL:

    • Instâncias RDS for MySQL que não registram logs de transações — como instâncias somente leitura do RDS for MySQL 5.6 — não são suportadas como origem quando a migração incremental é necessária.

    • Periodicamente, o DTS executa CREATE DATABASE IF NOT EXISTS test no banco de origem para avançar o offset do log binário.

Faturamento

Tipo de migração

Taxa de configuração da instância

Taxa de tráfego de Internet

Migração de schema e migração completa de dados

Gratuito.

Há cobrança de tráfego de Internet quando o parâmetro Access Method do banco de dados de destino está definido como Public IP Address. Para mais informações, consulte Visão geral do faturamento.

Migração incremental de dados

Pago. Para mais informações, consulte Visão geral do faturamento.

Tipos de migração

  • Migração de schema

    O DTS migra os schemas dos objetos de migração do banco de dados de origem para o banco de dados de destino.

  • Migração completa de dados

    O DTS transfere todos os dados existentes nos objetos de migração do banco de origem para o banco de destino.

  • Migração incremental de dados

    Após a migração completa, o DTS replica as atualizações incrementais do banco de origem para o banco de destino, minimizando o tempo de inatividade das aplicações autogerenciadas.

Operações SQL para migração incremental

Tipo de operação

Instrução SQL

DML

INSERT, UPDATE e DELETE

DDL

CREATE TABLE, ALTER TABLE, RENAME TABLE, TRUNCATE TABLE e DROP TABLE

Permissões necessárias para contas de banco de dados

Banco de dados

Migração de schema

Migração completa

Migração incremental

ApsaraDB RDS for MySQL

Permissão SELECT

Permissão SELECT

Permissões REPLICATION SLAVE, REPLICATION CLIENT e SELECT para os objetos de origem. O DTS concede essas permissões automaticamente à conta do banco de dados.

Oracle

Permissões de proprietário do schema.

Para mais informações sobre criação e autorização de contas de banco de dados, consulte os seguintes tópicos:

Procedimento

Este exemplo utiliza um banco de dados Oracle autogerenciado em uma instância ECS como banco de destino.

  1. Acesse a página da lista de tarefas de migração da região de destino usando um dos métodos abaixo.

    Pelo console do DTS

    1. Faça login no console do Data Transmission Service (DTS).

    2. No painel de navegação à esquerda, clique em Data Migration.

    3. No canto superior esquerdo da página, selecione a região onde a instância de migração está localizada.

    Pelo console do DMS

    Nota

    As operações reais podem variar conforme o modo e o layout do console DMS. Para mais detalhes, consulte Console no modo simples e Personalizar o layout e o estilo do console DMS.

    1. Faça login no console do Data Management (DMS).

    2. Na barra de menu superior, escolha Data + AI > Data Transmission (DTS) > Data Migration.

    3. À direita de Data Migration Tasks, selecione a região onde a instância de migração está localizada.

  2. Clique em Create Task para ir à página de configuração da tarefa.

  3. Configure os bancos de dados de origem e destino.

    Categoria

    Parâmetro

    Descrição

    N/A

    Task Name

    O DTS gera automaticamente um nome para a tarefa. Recomendamos especificar um nome descritivo para facilitar a identificação. O nome não precisa ser único.

    Source Database

    Select DMS Database Instance

    Selecione uma instância existente conforme necessário.

    • As informações do banco de dados são preenchidas automaticamente ao usar uma instância existente. Não é necessário inseri-las novamente.

    • Insira as informações do banco de dados abaixo caso não utilize uma instância existente.

    Database Type

    Selecione MySQL.

    Access Method

    Selecione Alibaba Cloud Instance.

    Instance Region

    Selecione a região da instância ApsaraDB RDS for MySQL de origem.

    Cross-account

    Indica se o banco de dados de origem pertence a uma conta diferente da Alibaba Cloud. Neste exemplo, selecione No.

    RDS Instance ID

    Selecione o ID da instância ApsaraDB RDS for MySQL de origem.

    Database Account

    Insira a conta do banco de dados da instância ApsaraDB RDS for MySQL de origem. Para mais informações sobre as permissões necessárias, consulte Permissões necessárias para contas de banco de dados.

    Database Password

    Insira a senha da conta do banco de dados.

    Connection Method

    Escolha Non-encrypted ou SSL-encrypted conforme os requisitos do seu banco de dados. Ao definir este parâmetro como SSL-encrypted, é obrigatório ativar previamente a criptografia SSL na instância RDS for MySQL. Para mais informações, consulte Ativar rapidamente a criptografia SSL usando um certificado cloud.

    Destination Database

    Select DMS Database Instance

    Selecione uma instância existente conforme necessário.

    • As informações do banco de dados são preenchidas automaticamente ao usar uma instância existente. Não é necessário inseri-las novamente.

    • Insira as informações do banco de dados abaixo caso não utilize uma instância existente.

    Database Type

    Selecione Oracle.

    Access Method

    Selecione Self-managed Database on ECS.

    Nota

    É necessário preparar o ambiente se o banco de dados de destino for autogerenciado. Para mais informações, consulte Visão geral da preparação.

    Instance Region

    Selecione a região da instância Oracle autogerenciada de destino.

    ECS Instance ID

    Selecione o ID da instância ECS que hospeda o banco de dados Oracle autogerenciado de destino.

    Port Number

    Insira a porta de serviço do banco de dados Oracle autogerenciado de destino. Valor padrão: 1521.

    Oracle Type

    Selecione o tipo de instância Oracle. Neste exemplo, selecione RAC or PDB Instance.

    • Non-RAC Instance: Especifique o SID ao escolher esta opção.

    • RAC or PDB Instance: Especifique o Service Name ao escolher esta opção.

    Database Account

    Insira a conta do banco de dados da instância Oracle autogerenciada de destino.

    Database Password

    Insira a senha da conta do banco de dados.

  4. Após concluir a configuração, clique em Test Connectivity and Proceed na parte inferior da página. Na caixa de diálogo CIDR Blocks of DTS Servers exibida, clique em Test Connectivity.

    Nota

    Certifique-se de que os segmentos de IP do serviço DTS foram adicionados automática ou manualmente às configurações de segurança dos bancos de dados de origem e destino para permitir o acesso dos servidores DTS. Para mais informações, consulte Adicionar endereços IP de servidores DTS a uma lista de permissões.

  5. Configure os objetos da tarefa.

    1. Na página Configure Objects, configure os objetos que deseja migrar.

      Parâmetro

      Descrição

      Migration Types

      • Selecione tanto Schema Migration quanto Full Data Migration caso precise apenas de uma migração completa.

      • Para migrar sem tempo de inatividade, selecione Schema Migration, Full Data Migration e Incremental Data Migration.

      Nota
      • Garanta que exista um banco de dados e tabelas para receber os dados no destino caso não selecione Schema Migration. Também é possível utilizar o recurso de mapeamento de nomes de objetos na caixa Selected Objects conforme necessário.

      • Não grave novos dados na instância de origem durante a migração se não selecionar Incremental Data Migration, a fim de garantir a consistência dos dados.

      Processing Mode for Existing Destination Tables

      • Precheck and Report Errors: Verifica se existem tabelas no banco de destino com os mesmos nomes das tabelas de origem. A pré-verificação é aprovada se tais tabelas não existirem. Caso contrário, a pré-verificação falha e a tarefa de migração não pode ser iniciada.

        Nota

        Altere os nomes das tabelas no banco de destino se não for possível excluir ou renomear as tabelas com nomes iguais. Para mais informações, consulte Mapear nomes de tabelas e colunas.

      • Ignore Errors and Proceed: Ignora a verificação de tabelas com nomes iguais no banco de destino.

        Aviso

        Selecionar Ignore Errors and Proceed pode causar inconsistência de dados e expor seu negócio a riscos. Por exemplo:

        • Se um registro de destino tiver a mesma chave primária que um registro de origem e os schemas coincidirem:

          • Durante uma migração completa de dados, o DTS mantém o registro de destino e não migra o registro de origem.

          • Durante uma migração incremental de dados, o DTS sobrescreve o registro de destino com o registro de origem.

        • A inicialização de dados pode falhar se os bancos de origem e destino tiverem schemas diferentes, resultando em migração parcial ou falha total da migração.

      Case Sensitivity Policy for Destination Object Names

      Configure a sensibilidade a maiúsculas e minúsculas para nomes de bancos de dados, tabelas e colunas na instância de destino. Por padrão, a DTS default policy vem selecionada. Outras opções estão disponíveis para garantir que o uso de maiúsculas/minúsculas nos nomes dos objetos seja consistente com o banco de origem ou destino. Para mais informações, consulte Sensibilidade a maiúsculas e minúsculas de nomes de objetos na instância de destino.

      Source Objects

      Na caixa Source Objects, clique nos objetos a serem migrados e, em seguida, clique em Right arrow para movê-los para a caixa Selected Objects.

      Nota

      A granularidade para seleção de objetos de migração é schema, tabela e coluna. Outros objetos, como views, triggers e stored procedures, não serão migrados para o banco de destino se você selecionar apenas tabelas ou colunas como objetos de migração.

      Selected Objects

      Clique com o botão direito em um banco de dados na caixa Selected Objects. Na página Edit Schema, altere o Schema Name para o schema do banco de dados de destino no seu banco Oracle autogerenciado. Por padrão, o nome do schema é igual à Database Account. Para mais informações sobre o recurso de mapeamento de nomes de objetos, consulte Mapear nomes de tabelas e colunas.

      Nota
      • O uso de mapeamento de nomes de objetos pode causar falhas na migração de objetos dependentes.

      • Para definir uma condição WHERE de filtragem de dados, clique com o botão direito na tabela a ser migrada na seção Selected Objects e defina a condição de filtro na caixa de diálogo exibida. Para mais informações, consulte Configurar condições de filtro.

      • Para selecionar operações SQL para migração no nível de banco de dados ou tabela, clique com o botão direito em um objeto de migração na caixa Selected Objects e selecione as operações SQL desejadas na caixa de diálogo.

    2. Clique em Next: Advanced Settings para configurar parâmetros avançados.

      Parâmetro

      Descrição

      Dedicated Cluster for Task Scheduling

      Por padrão, o DTS agenda tarefas em um cluster compartilhado. Não é necessário selecionar um. Para obter tarefas mais estáveis, adquira um cluster dedicado para executar tarefas de migração do DTS.

      Retry Time for Failed Connections

      Após o início da tarefa de migração, se a conexão com o banco de dados de origem ou destino falhar, o DTS relata um erro e inicia imediatamente uma nova tentativa de conexão. A duração padrão de tentativa é de 720 minutos. Personalize o tempo de tentativa para um valor entre 10 e 1440 minutos. Recomendamos definir a duração para mais de 30 minutos. A tarefa de migração será retomada automaticamente se o DTS reconectar aos bancos de origem e destino dentro do período especificado. Caso contrário, a tarefa falhará.

      Nota
      • Para múltiplas instâncias DTS que compartilham a mesma origem ou destino, o tempo de tentativa de rede é determinado pela configuração da última tarefa criada.

      • Como há cobrança pela tarefa durante o período de tentativa de conexão, recomendamos personalizar o tempo de tentativa conforme as necessidades do seu negócio ou liberar a instância DTS o mais rápido possível após a liberação das instâncias de banco de dados de origem e destino.

      Retry Time for Other Issues

      Após o início da tarefa de migração, se ocorrer um problema não relacionado à conexão — como uma exceção na execução de DDL ou DML — no banco de origem ou destino, o DTS relata um erro e inicia imediatamente uma nova tentativa da operação. A duração padrão de tentativa é de 10 minutos. Personalize o tempo de tentativa para um valor entre 1 e 1440 minutos. Recomendamos definir a duração para mais de 10 minutos. A tarefa de migração será retomada automaticamente se as operações relacionadas forem bem-sucedidas dentro do período de tentativa especificado. Caso contrário, a tarefa falhará.

      Importante

      O valor de Retry Time for Other Issues deve ser menor que o valor de Retry Time for Failed Connections.

      Enable Throttling for Full Data Migration

      Durante a migração completa, o DTS consome recursos de leitura e escrita nos bancos de origem e destino, o que pode aumentar a carga do banco de dados. Se necessário, ative o throttling para a tarefa de migração completa. Defina Queries per second (QPS) to the source database, RPS of Full Data Migration e Data migration speed for full migration (MB/s) para reduzir a carga no banco de destino.

      Nota
      • Este item de configuração está disponível apenas se você selecionar Full Data Migration em Migration Types.

      • Também é possível ajustar a velocidade da migração completa depois que a instância de migração estiver em execução.

      Enable Throttling for Incremental Data Migration

      Se necessário, também é possível definir limites de velocidade para a tarefa de migração incremental. Configure RPS of Incremental Data Migration e Data migration speed for incremental migration (MB/s) para reduzir a carga no banco de destino.

      Nota
      • Este item de configuração está disponível apenas se você selecionar Incremental Data Migration em Migration Types.

      • Também é possível ajustar a velocidade da migração incremental depois que a instância de migração estiver em execução.

      Environment Tag

      Selecione uma tag de ambiente para identificar a instância de migração. Neste exemplo, nenhuma tag é necessária.

      Whether to delete SQL operations on heartbeat tables of forward and reverse tasks

      Escolha se deseja gravar informações SQL de heartbeat no banco de origem enquanto a instância DTS estiver em execução.

      • Yes: As informações SQL de heartbeat não são gravadas no banco de origem. Isso pode fazer com que a instância DTS relate atraso.

      • No: Grava informações SQL de heartbeat no banco de origem. Isso pode interferir em recursos como backup físico e clonagem do banco de origem.

      Configure ETL

      Conforme as necessidades do seu negócio, selecione se deseja configurar o recurso ETL para processar dados.

      Monitoring and Alerting

      Selecione se deseja configurar alertas e receber notificações de alerta conforme as necessidades do seu negócio.

      • No: Não configura alerta.

      • Yes: Configure alertas definindo um limiar de alerta e um notificações de alerta. O sistema envia uma notificação de alerta se a migração falhar ou se a latência exceder o limiar.

    3. Clique em Next: Data Validation para configurar uma tarefa de validação de dados.

      Para mais informações sobre o recurso de validação de dados, consulte Configurar validação de dados.

  6. Salve a tarefa e execute uma pré-verificação.

    • Para visualizar os parâmetros de configuração desta instância ao chamar a operação da API, passe o ponteiro sobre o botão Next: Save Task Settings and Precheck e clique em Preview OpenAPI parameters no balão exibido.

    • Clique em Next: Save Task Settings and Precheck na parte inferior da página se não precisar visualizar os parâmetros da API ou já tiver terminado de visualizá-los.

    Nota
    • O DTS realiza uma pré-verificação antes do início da tarefa de migração. A tarefa só começa após ser aprovada na pré-verificação.

    • Se a pré-verificação falhar, clique em View Details ao lado do item reprovado, corrija o problema conforme a instrução e execute a pré-verificação novamente.

    • Se um aviso for relatado durante a pré-verificação:

      • Para itens de verificação que não podem ser ignorados, clique em View Details ao lado do item reprovado, corrija o problema conforme a instrução e execute a pré-verificação novamente.

      • Para itens de verificação que podem ser ignorados, clique em Confirm Alert Details, Ignore, OK e Precheck Again para pular o item de alerta e executar a pré-verificação novamente. Ignorar um aviso pode causar problemas como inconsistência de dados e representar riscos ao seu negócio.

  7. Adquira uma instância.

    1. Quando a Success Rate atingir 100%, clique em Next: Purchase Instance.

    2. Na página Purchase, selecione a especificação de link para a instância de migração de dados. Para mais informações, consulte a tabela a seguir.

      Categoria

      Parâmetro

      Descrição

      New Instance Class

      Resource Group Settings

      Selecione o grupo de recursos ao qual a instância pertence. O valor padrão é o grupo de recursos padrão. Para mais informações, consulte O que é Resource Management?

      Instance Class

      O DTS oferece especificações de migração com diferentes níveis de desempenho. A especificação do link afeta a velocidade da migração. Selecione uma especificação baseada no seu cenário de negócio. Para mais informações, consulte Especificações de link de migração de dados.

    3. Após concluir a configuração, leia e selecione Data Transmission Service (Pay-as-you-go) Service Terms.

    4. Clique em Buy and Start. Na caixa de diálogo OK exibida, clique em OK.

      Acompanhe o progresso da tarefa de migração na página de lista Data Migration Tasks.

      Nota
      • A tarefa para automaticamente após a conclusão da migração completa se não incluir migração incremental. Após a parada da tarefa, seu Status muda para Completed.

      • A tarefa não para automaticamente se incluir migração incremental. A tarefa de migração incremental continua em execução. Enquanto a tarefa de migração incremental estiver ativa, o Status da tarefa será Running.