すべてのプロダクト
Search
ドキュメントセンター

Virtual Private Cloud:CreateRouteEntry

最終更新日:Sep 18, 2026

vRouter または Virtual Border Router (VBR) にカスタムルートエントリを作成します。

操作説明

  • CreateRouteEntry 操作は非同期です。リクエストを送信した後、システムはバックグラウンドでカスタムルートエントリを追加している間にインスタンス ID を返します。 DescribeRouteEntryList を呼び出して、カスタムルートエントリのステータスをクエリできます。
    • カスタムルートエントリのステータスが Creating の場合、カスタムルートエントリは追加中です。

    • カスタムルートエントリのステータスが Created の場合、カスタムルートエントリは追加済みです。

  • CreateRouteEntry 操作では、同じ VPC または同じ VBR 内でのカスタムルートエントリの同時追加はサポートされていません。

  • CreateRouteEntry 操作では、同時実行シナリオで TaskConflict エラーコードが返される場合があります。必要に応じてリクエストをリトライしてください。

この操作を使用して vRouter のルートテーブルにカスタムルートエントリを追加する場合は、次の項目に注意してください。

説明

追加するカスタムルートエントリがプレフィックスリストルートの場合、ルートクォータは既存のルート数とプレフィックスリストルートのエントリの最大値の合計に基づいて計算されます。合計がルートクォータ制限を超えないようにしてください。

  • ルートテーブルには、最大値 200 個のカスタムルートエントリを含めることができます。

  • カスタムルートエントリの送信先 CIDR ブロック (DestinationCidrBlock) は、VPC 内の vSwitch の CIDR ブロックと同じにすることはできません。送信先 CIDR ブロックは vSwitch の CIDR ブロックを含むことができますが、vSwitch の CIDR ブロックに含まれることはできません。

  • カスタムルートエントリの送信先 CIDR ブロック (DestinationCidrBlock) は、クラウドサービスで使用されるシステムルートの CIDR ブロック 100.64.0.0/10 よりも具体的な CIDR ブロックにすることができますが、この CIDR ブロックと同じにすることはできません。

    重要 送信先 CIDR ブロック 100.64.0.0/10 のシステムルートは、VPC 内のクラウドサービス間の通信に使用されます。より具体的なルートを設定する場合は注意してください。設定が正しくないと、クラウドサービスにアクセスできなくなる可能性があります。

  • 同じルートテーブル内のルートエントリの送信先 CIDR ブロック (DestinationCidrBlock) は一意である必要があります。

  • 指定された送信先 CIDR ブロック (DestinationCidrBlock) が IP アドレスの場合、32 ビットマスクを持つ CIDR ブロックとして扱われます。

  • 複数のカスタムルートエントリは、同じネクストホップ (NextHopId) をポイントできます。

  • カスタムルートエントリのネクストホップ (NextHopId) は、ルートテーブルと同じ VPC 内にある必要があります。

  • NextHopList パラメータ設定を使用して ECMP ルーティングをセットできます。

    • 非 ECMP カスタムルートを追加するには、DestinationCidrBlock、NextHopType、および NextHopId パラメーターを指定します。NextHopList パラメーターは指定しないでください。

    • ECMP ルートを追加するには、DestinationCidrBlock および NextHopList パラメーターを指定します。NextHopType または NextHopId パラメーターは指定しないでください。

この操作を使用して Virtual Border Router のルートテーブルにカスタムルートエントリを追加する場合は、次の項目に注意してください。

  • ルートテーブルには、最大値 200 個のカスタムルートエントリを含めることができます。

  • NextHopList パラメーターはサポートされていません。

  • カスタムルートエントリの送信先 CIDR ブロック (DestinationCidrBlock) は、クラウドサービスで使用されるシステムルートの CIDR ブロック 100.64.0.0/10 よりも具体的な CIDR ブロックにすることができますが、この CIDR ブロックと同じにすることはできません。

    重要 送信先 CIDR ブロック 100.64.0.0/10 のシステムルートは、VPC 内のクラウドサービス間の通信に使用されます。より具体的なルートを設定する場合は注意してください。設定が正しくないと、クラウドサービスにアクセスできなくなる可能性があります。

  • 同じルートテーブル内のルートエントリの送信先 CIDR ブロック (DestinationCidrBlock) は一意である必要があります。

  • 指定された送信先 CIDR ブロック (DestinationCidrBlock) が IP アドレスの場合、32 ビットマスクを持つ CIDR ブロックとして扱われます。

  • 複数のカスタムルートエントリは、同じネクストホップ (NextHopId) をポイントできます。

  • カスタムルートエントリのネクストホップ (NextHopId) は、VBR に関連付けられた vRouter インターフェイスである必要があります。

  • VBR にルートエントリを追加できるのは、VBR が Active ステータスであり、対応する Express Connect 回線が Enabled ステータスであり、かつ支払い遅延により回線がロック済みでない場合のみです。

  • 非 ECMP ルートエントリのみがサポートされています。DestinationCidrBlock、NextHopType、および NextHopId パラメーターを指定します。NextHopList パラメーターは指定しないでください。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

vpc:CreateRouteEntry

create

*RouteTable。

acs:vpc:{#regionId}:{#accountId}:routetable/{#RouteTableId}

なし なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

RegionId

string

任意

ルートテーブルのリージョン ID。

DescribeRegions 操作を呼び出してリージョン ID をクエリできます。

cn-hangzhou

RouteTableId

string

必須

カスタムルートエントリを追加するルートテーブルの ID。

vtb-bp145q7glnuzd****

DestinationCidrBlock

string

必須

カスタムルートエントリの送信先 CIDR ブロック。IPv4 CIDR ブロック、IPv6 CIDR ブロック、プレフィックスリストの送信先 CIDR ブロック、およびプレフィックスリストのインスタンス ID がサポートされています。次の要件を満たす必要があります。

  • 送信先 CIDR ブロックは、100.64.0.0/10 をポイントすることも、100.64.0.0/10 に含まれることもできません。

  • 同じルートテーブル内の異なるルートエントリの送信先 CIDR ブロックは一意である必要があります。

192.168.0.0/24

NextHopId

string

任意

カスタムルートエントリのネクストホップインスタンスの ID。

説明

NextHopType を ECR に設定した場合、 DescribeExpressConnectRouterAssociation 操作を呼び出して、ネクストホップ ID として AssociationId を取得できます。

i-j6c2fp57q8rr4jlu****

ClientToken

string

任意

リクエストのべき等性を確保するために使用されるクライアントトークン。

クライアントからパラメーター値を生成します。異なるリクエスト間で値が一意であることを確認してください。ClientToken 値には ASCII 文字のみを使用できます。

説明

このパラメーターを指定しない場合、システムは API リクエストの RequestId を ClientToken として使用します。RequestId は API リクエストごとに異なる場合があります。

02fb3da4-130e-11e9-8e44-001****

RouteEntryName

string

任意

追加するカスタムルートエントリの名前。

名前は 1~128 文字で、http:// または https:// で始まることはできません。

test

Description

string

任意

カスタムルートエントリの説明。

説明は 1~256 文字で、http:// または https:// で始まることはできません。

test

NextHopType

string

任意

カスタムルートエントリのネクストホップのタイプ。有効な値:

  • Instance (デフォルト): ECS インスタンス。

  • HaVip: 高可用性仮想 IP アドレス。

  • RouterInterface: vRouter インターフェイス。

  • NetworkInterface: エラスティックネットワークインターフェースコントローラー (NIC)。

  • VpnGateway: VPN ゲートウェイ。

  • IPv6Gateway: IPv6 ゲートウェイ。

  • NatGateway: NAT ゲートウェイ。

  • Attachment: トランジットルーター。

  • VpcPeer: VPC ピアリング接続。

  • Ipv4Gateway: IPv4 ゲートウェイ。

  • GatewayEndpoint: ゲートウェイエンドポイント。

  • Ecr: Express Connect Router (ECR)。

  • GatewayLoadBalancerEndpoint: Gateway Load Balancer エンドポイント (GWLBe)。

  • RouteTargetGroup: ルートターゲットグループ。

列挙値:

  • HaVip :

    HaVip。

  • VpnGateway :

    VpnGateway。

  • RouteTargetGroup :

    RouteTargetGroup。

  • GatewayLoadBalancerEndpoint :

    GatewayLoadBalancerエンドポイント。

  • VpcPeer :

    VpcPeer。

  • Instance :

    Instance。

  • NetworkInterface :

    NetworkInterface。

  • NatGateway :

    NatGateway。

  • Attachment :

    Attachment。

  • Ipv4Gateway :

    Ipv4Gateway。

  • GatewayEndpoint :

    Gatewayエンドポイント。

  • Ecr :

    Ecr。

  • RouterInterface :

    RouterInterface。

  • IPv6Gateway :

    IPv6Gateway。

RouterInterface

NextHopList

array<object>

任意

ネクストホップのフォーマット。

object

任意

ネクストホップのフォーマット。

NextHopId

string

任意

ECMP ルートのネクストホップインスタンスの ID。

ri-2zeo3xzyf3cd8r4****

NextHopType

string

任意

ECMP ルートのネクストホップのタイプ。有効な値: RouterInterface (ルーターインターフェイス)。

RouterInterface

Weight

integer

任意

ECMP ルートのネクストホップの重み。

10

DryRun

boolean

任意

ドライランを実行するかどうかを指定します。有効な値:

  • true: ルートエントリを作成せずにドライランを実行します。システムは必須パラメーター、リクエストフォーマット、およびサービス制限をチェックします。チェックに失敗すると、対応するエラーが返されます。チェックに成功すると、DryRunOperation エラーコードが返されます。

  • false (デフォルト): リクエストを送信します。リクエストがチェックに合格すると、HTTP 2xx 状態コードが返され、操作が実行されます。

false

レスポンスフィールド

フィールド

型

説明

例

object

カスタムルートエントリの ID。

RequestId

string

リクエスト ID。

0ED8D006-F706-4D23-88ED-E11ED28DCAC0

RouteEntryId

string

カスタムルートエントリの ID。

rte-sn6vjkioxte1gz83z****

例

成功レスポンス

JSONJSON

{
  "RequestId": "0ED8D006-F706-4D23-88ED-E11ED28DCAC0",
  "RouteEntryId": "rte-sn6vjkioxte1gz83z****"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 IllegalParam.CidrBlock The specified CidrBlock is illegal. CIDR ブロックが無効です。
400 QuotaExceeded Route entry quota exceeded in this route table.
400 MissingParameter Miss mandatory parameter.
400 InvalidCidrBlock.Malformed Specified CIDR block is not valid.
400 InvalidCIDRBlock.Duplicate Specified CIDR block is already exists.
400 IncorrectVpcStatus Current VPC status does not support this operation.
400 IncorrectInstanceStatus Current instance status does not support this operation.
400 IncorrectRouteEntryStatus Some route entry status blocked this operation.
400 IncorrectVSwitchStatus The current virtual switch status does not support this operation. VPC 内の vSwitch が作成中の状態であるため、vSwitch の作成に失敗しました。
400 InvalidCidrBlock Specified CIDR block is not valid. 考えられる原因: 1. 10.0.0.0/8 CIDR ブロックのホワイトリストに登録されていないため、この CIDR ブロックを使用できません。 2. カスタムルートエントリの送信先 CIDR ブロックを、同じ VPC 内のいずれかの vSwitch の CIDR ブロックのサブセットにすることはできません。 3. 100.64.0.0/10 はクラウドサービス用の CIDR ブロックであるため、この CIDR ブロックをオンプレミスデータセンターにポイントするルートエントリは追加できません。 4. 100.64.0.0/10 に加え、100.64.0.0/11 や 100.96.0.0/11 などの特定の CIDR ブロックはオンプレミスデータセンターでは使用できません。
400 InvalidNextHop.NotFound Specified next hop does not exist.
400 InvalidVRouter.NotFound vRouter not exists.
400 InvalidVPC.NotFound vpc not exists.
400 InvalidNexthopTypeAndList.BothNull both nexthopType and nextHopList are null.
400 InvalidNexthopTypeAndList.BothNotNull both nexthopType and nextHopList are not null.
400 InvalidRouterInterface invalid router interface.
400 InvalidOppositeRouterType nexthop list cannot only contain router interface whose opposite router interface is on vbr.
400 InvalidNexthopListSize nexthop size is illegal. Must be between 2 and 4. ネクストホップとして 2~4 個のルーターインターフェイスを指定する必要があります。
400 InvalidEntryRuleQuota.NotFound Route entry quota rule not exists.
400 Forbidden.CheckEntryRuleQuota Route entry quota rule check error.
400 InvalidVBRStatus invalid virtual border router status.
400 InvalidPhysicalConnectionBusinessStatus invalid physical connection business status.
400 InvalidRouterType Cannot specify nexthop list in vbr's route table. 指定されたネクストホップが VBR ルートテーブルに存在しません。
400 IncorrectHaVipStatus This operation is denied because satus of the specified HaVip is neither Available nor InUse. この操作は、HaVip が InUse 状態の場合にのみ実行できます。
400 CountLimitExceed.HaVipRouteEntry The count of route entry to HaVip in one route table is exceeded. HaVip インスタンスをポイントするルートの数が上限に達しました。
400 InvalidRouteEntry.Duplicate The route entry already exist.
400 InvalidParam The Ecmp routerEntry with router interfaces local vgw vip not match.
400 INVALID_WEIGHT_PARAM Specified value of weight invalid
400 FORBIDDEN_USE_VPC_AS_INTERNET_GATEWAY The Specified CIDR must be in vpc CIDR.
400 InvalidNexthop The Specified nexthop illegal.
400 INVALID_VPC_ID The Specified VpcId not match. VPC が存在しません。指定された VPC が正しいかどうかを確認してください。
400 InvalidRouteEntrySize The Specified routerEntry size not legal. 等コストマルチパス (ECMP) ルーティングでは、ネクストホップとして 2~4 個のルーターインターフェイスが必要です。
400 TaskConflict The operation is too frequent, please wait a moment and try again. EIP に対する操作が頻繁すぎます。
400 InvalidRouteEntry Specified routeEntry not exist.
400 InvalidDestinationCidrBlock The specified destinationCidrBlock must not included in black list cidr.
400 Forbidden.VRouterNotFound Specified virtual switch is not found during access authentication.
400 DefaultValidate.Error validte fail.
400 Region.NotSupport The specified region does not currently support nextHopType for networkInterface
400 OperationFailed.NotifyCenCreate Failed to notify cen when create route entry.
400 Forbidden.PrivateIpNotFound Private ip address not exist.
400 OperationUnsupported.InactiveMode Vpc multi scope route only support active standby.
400 InvalidRouteEntryName.Malformed Specified RouteEntry name is not valid. 指定されたルートエントリ名が無効なため、変更に失敗しました。
400 IncorrectStatus.MultiScopeRiRouteEntry MultiScope ri status must not in idle.
400 OperationUnsupported.MoreThanOneVpnOrHavip MultiScope can not support more than one vpn/havip.
400 OperationUnsupported.EcmpRiTypeOrNumber Emcp entry not supported if vpc-vbr or vbr-vlan ri does not exist.
400 Duplicated.VpcNextHop Route entry nexthop duplicate. 重複するルートエントリが既に存在します。
400 OperationUnsupported.SubRouteTableECMP Vpc subRouteTable don't support ecmp or multiScope.
400 InvalidNexthop.NotFound VRouterEntry nexthop does not exist.
400 IllegalParam.NextHopId Instance not exists or not vpc vm.
400 QuotaExceeded.HaVipRouteEntry Vpc havip route entry quota exceed.
400 InvalidNexthop.DirectEni The direct Eni cannot be nexthop. パススルー ENI をネクストホップとして使用することはできません。
400 OperationFailed.InvalidNexthop vpc multi scope route must has a enable nexthop.
400 OperationFailed.NotifyCenDelete Failed to notify cen when delete route entry.
400 InvalidNatGateway.NotFound Natgateway not exist.
400 OperationFailed.CxpRouteExist Cxp route alreay existed.
400 OperationFailed.GetEniInfo Failed to get networkInterface info.
400 OperationUnsupported.InvalidRouterInterfaceType Only vpc vbr interface support ecmp route.
400 InvalidHaVip.NotFound The specified HaVip does not exist in the specified region.
400 OperationFailed.MultiScopeType The specified nexthop type is not support in multiScope.
400 OperationFailed.DistibuteLock Distibute lock fail. リソースはロック済みです。操作は許可されていません。
400 QuotaExceeded.VpnRouteEntry Vpn route entry quota exceeded. VPC ルートテーブル内で VPN ゲートウェイを宛先とするルートの数がクォータ制限に達しました。
400 InvalidAttachment.NotFound The attachment is not found. アタッチが存在しません。
400 OperationFailed.ActiveNetworkInterfaceNotFound No active network interface is found on the attachment. アタッチ上に利用可能な Elastic ネットワークインターフェース (ENI) が存在しません。
400 InvalidNetworkInterface.NotFound The network interface is not found on the attachment. アタッチ上の Elastic ネットワークインターフェース (ENI) が存在しません。
400 OperationFailed.QueryAttachmentInfo Failed to query attachment information. アタッチ情報のクエリに失敗しました。
400 IllegalParam.AttachmentId The attachment is invalid. アタッチは無効です。
400 OperationFailed.NotSupportIPV6 The specified next hop does not support IPv6. 指定されたネクストホップは IPv6 をサポートしていません。
400 IncorrectStatus.Ipv6Address The IPv6 address of the specified next hop is being assigned or deleted. 指定されたネクストホップの IPv6 アドレスは作成中または削除中です。
400 OperationUnsupported.Ipv6EntryOnPrimaryNetworkInterface You cannot create IPv6 route entries on a primary network interface. プライマリ Elastic ネットワークインターフェース (ENI) をネクストホップとする IPv6 ルートの作成は許可されていません。
400 OperationUnsupported.SpecifyIpOnIpv6Entry You cannot specify the private IP address when you create IPv6 route entries. IPv6 ルートの作成時に非公開 IP パラメーターを指定することはできません。
400 OperationUnsupported.MutipleIpv6Address You cannot specify a next hop that has bound multiple IPv6 addresses. 複数の IPv6 アドレスにバインド可能なネクストホップは指定できません。
400 OperationDenied.Ipv6EntryOnCustomTable You cannot create any IPv6 route entry on a custom route table. カスタムルートテーブルでの IPv6 ルートの作成は許可されていません。
400 OperationDenied.CloudBoxVbrEntryAllowedInCustomRouteTable The operation is not allowed because only the custom routing table can add a routing entry with the next hop pointing to the cloud box type VBR. ネクストホップが CloudBox VBR をポイントしているルートエントリを追加できるのはカスタムルートテーブルのみであるため、指定された操作は禁止されています。
400 OperationDenied.RouteTableAssociateNotCloudBoxVSwitch The operation is not allowed because of the routing table is bound to a non-cloud box type vswitch, and routing entries pointing to the cloud box VBR cannot be added. ルートテーブルが非 CloudBox vSwitch に関連付けられており、CloudBox VBR をポイントするルートエントリを追加できないため、この操作は実行できません。
400 OperationDenied.VbrMisMatchCloudBox The operation is not allowed because the routing table is bound to a cloud box vswitch, and routing entries pointing to other cloud box VBRs cannot be added. ルートテーブルが CloudBox vSwitch に関連付けられており、別の CloudBox 内の VBR をポイントするルートエントリを追加できないため、この操作は実行できません。
400 OperationDenied.VbrIdle The operation is not allowed because the next hop of the added routing entry is a VBR type RI at the opposite end, which cannot be in an idle state. ルートエントリのネクストホップがピアとして VBR を持つルーターインターフェイスであり、当該ルーターインターフェイスをアイドル状態にできないため、この操作は実行できません。
400 OperationDenied.RouterInterfaceToDifferentVpc The operation is not allowed because the router interface is connected to different VPCs. ルーターインターフェイスが異なる VPC をポイントしているため、この操作は実行できません。
400 OperationDenied.RouterInterfaceFromDifferentZones The operation is not allowed because the router interface resides in different zones. ルーターインターフェイスが異なるゾーンに属しているため、指定された操作は禁止されています。
400 OperationFailed.PconnTrafficNotEnable The operation is failed because of PconnTrafficNotEnable. アウトバウンドトラフィックが有効になっていないため、操作に失敗しました。
400 ResourceNotFound.VpcPeer The specified resource of %s is not found. 指定された VPC ピアリング接続が見つかりません。
400 IncorrectStatus.VpcPeer The status of %s [%s] is incorrect. %s [%s] のステータスが正しくありません。
400 OperationDenied.RouteTableTypeNotPermitted The operation is not allowed because the type of route table is not permitted. 指定されたルートテーブルタイプでは、ルートエントリを作成できません。
400 OperationDenied.GatewayRouteTableNotPermitted The operation is not allowed to create a route pointing to this nextHop type on gateway route table. ゲートウェイルートテーブルでは、このインスタンスタイプをポイントするルートエントリの作成はサポートされていません。
400 UnsupportedFeature.VpcPeerIpv6 IPv6 route entries for VPC peering connections cannot be created in this region. このルーターインターフェイスのピアは VPC です。このネクストホップタイプを持つ IPv6 ルートの作成は、このリージョンではサポートされていません。
400 OperationDenied.VpcIpv6NotEnabled IPv6 has not been enabled for the VPC. 指定された VPC で IPv6 が有効化されていないため、操作は拒否されました。
400 IncorrectStatus.Ipv4Gateway The status of Ipv4Gateway is incorrect.
400 ResourceNotFound.PrefixList The specified resource of prefixList is not found. 指定されたプレフィックスリストが存在しません。
400 UnsupportedFeature.CreatePrefixListEcmpRouteEntry The feature of creating ecmp route entry with prefixList is not supported. プレフィックスリストを使用した ECMP ルートの作成はサポートされていません。
400 OperationDenied.RouterInterfaceIpv6NotEnabled Routerinterface does not support IPv6. ルーターインターフェイスは IPv6 をサポートしていません。
400 OperationDenied.NextHopTypeNotPermitted The operation is not allowed because the nextHop type is invalid. このタイプのネクストホップを持つルートは作成できません。
400 ResourceAlreadyAssociated.PrefixList The operation failed because the specified prefixList route entry already exists. プレフィックスリストルートが既に存在するため、操作に失敗しました。
400 OperationFailed.CidrConflictWithPrefixList The specified CIDR block already exists in a prefixList route entry. ルーティング CIDR ブロックには、既存のプレフィックスリストルートとのルートの競合があります。
400 ResourceNotFound.Ipv4Gateway Specified Ipv4Gateway does not exist. 指定された IPv4 ゲートウェイが見つからないため、削除できません。
400 Mismatch.HaVipIdAndRouteTableId The HaVip and RouteTable are mismatched. 指定された高可用性仮想 IP アドレスとルートテーブルは、同じ VPC に属していません。
400 OperationFailed.OperationLocked The operation failed because the nextHop instance is in the O&M lock state. ルートのネクストホップインスタンスが O&M ロック状態のため、操作できません。
400 Mismatch.Ipv4GatewayIdAndRouteTableId The specified IPv4Gateway and RouteTable are not matched. 指定された IPv4 ゲートウェイとルートテーブルが同じ VPC に属していないため、操作に失敗しました。
400 OperationUnsupported.DestinationCidrBlockOverlapWithVSwitch The destination IPv6 network segment specified in the route entry overlaps with the vSwitch network segment. ルートエントリに指定された送信先 IPv6 CIDR ブロックが、vSwitch の CIDR ブロックと重複しています。
400 ResourceNotAssociated.Cen The Vpc and Cen are not associated. 操作が失敗した原因は、VPC がこの CEN インスタンスに関連付けられていないことです。
400 IncorrectStatus.CenRelation The status of Vpc in Cen is incorrect. 操作が失敗した原因は、VPC が CEN インスタンス内で安定した状態に達していないことです。
400 OperationDenied.CenTypeInvalid The operation is not allowed because of Cen type is invalid.. ルートテーブルでは、このタイプの CEN をポイントするルートの作成はサポートされていません。
400 ResourceNotFound.Cen The specified resource of Cen is not found. 操作が失敗した原因は、指定された CEN リソースが存在しないことです。
400 ResourceNotFound.NetworkInterface The specified resource of network interface is not found. 指定された ENI が存在しません。
400 RouteConflict.AlreadyExist Route conflict exists in routing table. ルートテーブルにルートの競合が存在します。
400 IncorrectStatus.RouterInterface The specified RouterInterface status is invalid. 現在の状態ではインスタンスを削除できません。状態が変化するまで待ってから、再度お試しください。
400 InvalidNexthop.UnsupportedEniBizType The biz type of NetworkInterface is illegal. ルートのネクストホップとして使用される ENI のサービスタイプが無効です。
400 OperationDenied.RouterInterfaceIpv6 RouterInterface does not support IPv6. RouterInterface は IPv6 をサポートしていません。
400 InvalidNextHopType Specified parameter "NextHopType" is not valid. ネクストホップのタイプが不正です。
400 OperationDenied.VbrAttachEcrInMiddleStatus The operation is not allowed because of VBR attach or detach ECR in middle status. 仮想ボーダールーターが Express Connect Router (ECR) のロードまたはアンロードの処理中にあるため、操作を実行することはできません。後でもう一度お試しください。
400 ResourceNotAssociated.Ecr The ECR is not associated. 現在のリソースは Express Connect Router (ECR) に関連付けられていないため、操作を実行できません。リソースを確認して、もう一度お試しください。
400 UnsupportedFeature.RouterInterfaceIpv6 The feature of ipv6 is not supported for the routerInterface. ルーターインターフェイスは IPv6 をサポートしていません。
400 InvalidVpnInstanceId.NotFound The specified VPN was not found. 指定された VPN インスタンスが見つかりません。
400 OperationFailed.ScopeActiveRouteEntryType Operation failed because the type of the active route entry is not supported. 操作に失敗しました。このアクティブなルートのタイプはサポート対象外です。
400 OperationFailed.ScopeStandbyRouteEntryQuota Operation failed because the quota for standby route entries in the scope has been exceeded. 操作が失敗した原因は、スタンバイルートエントリのクォータを超えているためです。
400 OperationFailed.ScopeActiveRouteEntryQuota Operation failed because the quota for active route entries in the scope has been exceeded. アクティブなルートエントリのクォータの上限に達したため、操作に失敗しました。
400 OperationUnsupported.ScopeInvalidRouteType The specified route type is unsupported. このルートタイプはサポートされていません。
400 OperationFailed.EcmpInvalidRouterInterfaceOppositeType Operation failed because the opposite type of the router interface is invalid for ECMP configuration. 操作に失敗しました。ECMP に対するルートエントリのピアタイプは無効です。
400 OperationUnsupported.Ipv6EcmpRouteEntry The EcmpRouteEntry is not supported for IPv6. IPv6 では ECMP ルートはサポートされていません。
400 OperationUnsupported.Ipv6CidrBlock The specified IPv6 CIDR block is unsupported. 指定された IPv6CidrBlock はサポートされていません。
400 OperationUnsupported.Ipv6ForVBR IPv6 route entry is not supported for VirtualBorderRouter. 仮想ボーダールーター (VBR) では、IPv6 ルートの注文はサポートされていません。
400 IncorrectStatus.RouteTableStatus The status of the specified RouteTable is incorrect. 指定されたルートテーブルは安定した状態ではありません。
400 OperationFailed.InvalidNextHopType Operation failed because Ecmp routeEntry has more than one ri entry and can only support one non-ri entry. 等コストマルチパス (ECMP) ルーティングでは、ネクストホップとしてルーターインターフェイス以外のタイプを 1 つしか指定できないため、ルートエントリを作成できませんでした。
400 UnsupportedRegion The feature is not supported in current region. このリージョンでは、プレフィックスリストルートはサポートされていません。
400 UnsupportedFeature.VpcAdvancedFeature The VPC does not support some advanced features. 指定された vSwitch が属する VPC は高度な機能をサポートしていません。別の vSwitch を使用して、もう一度お試しください。
400 OperationDenied.CreateEcmpForPublishedRouteEntry Operation denied because of can not create EcmpRouteEntry for published RouteEntry. 公開されたルートエントリでは、アクティブ/スタンバイルートまたは負荷分散ルートの作成はサポートされていません。
400 OperationDenied.TrAttachmentIpv6Disabled The operation is not allowed because tr attachment Ipv6 is disabled. トランジットルーターアタッチメントで IPv6 が有効になっていません。
400 Mismatch.EniIdAndRouteTableId The operation is not allowed because eni and route table not in same vpc. 指定された Elastic ネットワークインターフェイス (ENI) とルートテーブルが同じ VPC に属していないため、操作に失敗しました。
400 InvalidDescription.Malformed The Description is illegal. 指定されたリソースの説明のフォーマットが無効です。説明は 2~256 文字の長さである必要があり、http:// または https:// で始めることはできません。
400 OperationFailed.InstanceDismatchCurrentVpc The specified instance does not exist in current vpc.
400 OperationDenied.RouterInterfaceStatusNotAllowed The operation is not allowed because of RouterInterfaceStatusNotAllowed. ルーターインターフェイスが異常な状態です。
400 OperationFailed.Ipv6AddressNotBind The specified next hop has no IPv6 address. IPv6 ルートのネクストホップに IPv6 アドレスが指定されていません。
400 OperationUnsupported.MultipleIpv6Address Operation unsupported because specific route next hop instance has multiple IPv6 address. 指定されたルートのネクストホップインスタンスが複数の IPv6 アドレスに関連付けられているため、この操作はサポートされていません。
400 IncorrectStatus.NextHop The status of %s [%s] is incorrect. 指定されたネクストホップリソースが過渡状態にあります。
400 ResourceNotFound.RouteTargetGroup The specified resource of %s is not found. 指定されたリソース %s は存在しません。
400 IncorrectStatus.PrefixListRelation The related prefix list relation is in an intermediate state and cannot perform the current operation. 関連付けられたプレフィックスリストの関連付けがトランジション状態にあります。現在の操作は実行できません。
400 OperationDenied.BatchCreateRouteEntryToCen Failed to batch create route entries to CEN. The CEN side rejected this route distribution operation. CEN へのルートエントリのバッチでの作成に失敗しました。CEN がルート広告操作を拒否しました。
400 IncorrectBusinessStatus.PhysicalConnection Invalid physical connection business status. 現在の Express Connect 回線のサービスステータスでは、この操作はサポートされていません。
500 VPC.ERROR error code 500,Internal server error.
500 InternalError The request processing has failed due to some unknown error, exception or failure. リクエストの処理が失敗した原因は、不明なエラーです。
500 IncorrectStatus.Ipv4Gateway The status of Ipv4Gateway is incorrect. IPv4 ゲートウェイは過渡状態にあります。
403 IncorrectInstanceStatus The current status of the resource does not support this operation.
404 InvalidParameter Instance not exists or not vpc vm
404 InvalidNatGatewayId.NotFound Specified value of NatGatewayId is not found in our record.
404 InvalidInstanId.NotFound Specified instance does not exist.
404 InvalidNextHopId.NotFound Specified next hop does not exist.
404 InvalidRouteTableId.NotFound Specified route table does not exist.
404 InvalidHaVipId.NotFound The specified HaVip does not exist in the specified VPC. 指定された HaVip は、指定されたリージョンに存在しません。選択したリージョンが正しいかどうかを確認してください。
404 InvalidNetworkInterface.NotFound The specified networkInterface does not exist.
404 InvalidVpc.NotFound Specified vpc is not found in our record.
404 InvalidIpv6Gateway.NotFound Specified Ipv6Gateway does not exist.
404 ResourceNotFound.GatewayLoadBalancerEndpoint GatewayLoadBalancerEndpoint instance not found. Gateway Load Balancer エンドポイントインスタンスが見つかりませんでした。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。